Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help With Dual Boot, Windows 10 and Ubuntu


  • Please log in to reply
15 replies to this topic

#1 Rocky Bennett

Rocky Bennett

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:02:57 AM

Posted 26 November 2015 - 10:52 AM

I have been trying to set up a dual boot on my system. I have the Ubuntu ISO downloaded, and I have a separate drive with a partition and about 400 gb of free space assigned to Disc I. I have not been able to boot from my Ubuntu that is on a USB stick, and I think that my problem is in the UEFI of the motherboard. I have repeatedly gone into the boot set up menu and I have chosen to boot from the USB stick as number 1 option, but it continues to boot straight to Windows. What am I doing wrong? Any help would be appreciated.

 

Thank you


594965_zpsp5exvyzm.png


BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:09:57 AM

Posted 26 November 2015 - 12:11 PM

I have repeatedly gone into the boot set up menu and I have chosen to boot from the USB stick as number 1 option


Does USB remain as the number 1 option?

#3 Agouti

Agouti

  • Members
  • 1,548 posts
  • OFFLINE
  •  
  • Local time:04:57 AM

Posted 26 November 2015 - 03:03 PM

1. Ensure Boot Mode is set to Legacy.

 

2. Turn off Secure Boot.

 

3. Try again.



#4 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 26 November 2015 - 04:16 PM

Odds are, you aren't doing anything wrong. There are several things to consider. I started writing a reply, but decided it would be more beneficial to post in the tutorials section since this is a common problem. Here's the link to that posting.

 

@Agouti

1. Ensure Boot Mode is set to Legacy.

If he does that will he need to switch back and forth between UEFI and CSM legacy in order to use both Windows and Ubuntu? Ubuntu is UEFI capable, so he shouldn't need to install it under CSM legacy mode.



#5 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,904 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia

Posted 26 November 2015 - 04:18 PM

You might want to look at this. Fix no Grub menu in Windows UEFI and Linux dual boot

Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#6 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:06:57 PM

Posted 27 November 2015 - 06:44 AM

Thanks guys, I will take a look at those links. This has been very frutrating because earlier this year I was dual booting with no problem. I will look at this some more.


594965_zpsp5exvyzm.png


#7 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:02:57 AM

Posted 27 November 2015 - 09:14 AM

 

 

This post pointed me in the right direction and I was able to install the Ubuntu OS. Funny thing is that I spent days trying (I have been off all week due to Thanksgiving) and I have searched the internet repeatedly without success, but the key was I had to install from a DVD not a USB. I assumed that because I installed Windows from USB, that any OS can install from USB, but thanks to Nick I am working in the right direction.


594965_zpsp5exvyzm.png


#8 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:02:57 AM

Posted 27 November 2015 - 09:16 AM

Odds are, you aren't doing anything wrong. There are several things to consider. I started writing a reply, but decided it would be more beneficial to post in the tutorials section since this is a common problem. Here's the link to that posting.

 

@Agouti

 

 

1. Ensure Boot Mode is set to Legacy.

If he does that will he need to switch back and forth between UEFI and CSM legacy in order to use both Windows and Ubuntu? Ubuntu is UEFI capable, so he shouldn't need to install it under CSM legacy mode.

 

 

I am sorry for the above, it was this link from HollowFace that helped, but thanks to all that posted.


594965_zpsp5exvyzm.png


#9 pcpunk

pcpunk

  • Members
  • 5,659 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:02:57 AM

Posted 27 November 2015 - 11:10 AM

Rocky, what exactly helped?


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#10 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:04:57 AM

Posted 27 November 2015 - 01:01 PM

I had been trying to boot from a USB, when I really needed to burn the ISO to a DVD and then boot from that. So now I am running something called Ubuntu Wily Werewolf, which I think is 15.10. But I physically disconnected my C drive to install this OS, how do I load the grub loader so that I can dual Boot? Or is the grub loader part of the Ubuntu package? I know when I was dual booting with Linux Mint I had to load a special grub loader, but I do not know if it is the same with Ubuntu.


594965_zpsp5exvyzm.png


#11 pcpunk

pcpunk

  • Members
  • 5,659 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:02:57 AM

Posted 27 November 2015 - 01:26 PM

Sorry Rocky I read that post and then got sidetracked, thanks for the reply.

 

About the Grub, you will have to wait for someone to help with that.  You should have left the drive connected but had some kind of backup.  There are grub repair disks out there you can use but I have never had to use one.

 

Wait for help, but I think you will have to do something like this, or a Grub Repair Tool:

 

Reinstalling GRUB 2 from a Working System

If Ubuntu is operating normally, boot into the working installation and run the following command from a terminal. 

  • X is the drive (letter) on which you want GRUB to write the boot information. Normally users should not include a partition number, which would produce an error message as the command would attempt to write the information to a partition. 

    sudo grub-install /dev/sdX # Example: sudo grub-install /dev/sda

https://help.ubuntu.com/community/Grub2/Installing#Fixing_a_Broken_System


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#12 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:57 AM

Posted 27 November 2015 - 03:19 PM

With both drives connected, have a look in your BIOS for a hard drive menu, and prioritise the drive with Linux on it over the drive with Windows on it. Save and exit BIOS.

Now hopefully your computer will boot into Linux. If so, open a terminal and update Grub bootloader by running this command:
sudo update-grub
(I assume you have run commands in a Linux terminal before. If not, please ask for more details)

When Grub has updated, reboot your computer and you should find a boot menu there.

If that works, that would be the easiest thing to do.

#13 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:09:57 AM

Posted 27 November 2015 - 03:52 PM

Thanks to all of the help. I will try the little BIOS setting and report back.


594965_zpsp5exvyzm.png


#14 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:02:57 AM

Posted 27 November 2015 - 05:17 PM

With both drives connected, have a look in your BIOS for a hard drive menu, and prioritise the drive with Linux on it over the drive with Windows on it. Save and exit BIOS.

Now hopefully your computer will boot into Linux. If so, open a terminal and update Grub bootloader by running this command:

sudo update-grub
(I assume you have run commands in a Linux terminal before. If not, please ask for more details)

When Grub has updated, reboot your computer and you should find a boot menu there.

If that works, that would be the easiest thing to do.

 

 

 

Thanks, this command worked wonderfully.


594965_zpsp5exvyzm.png


#15 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:57 AM

Posted 28 November 2015 - 06:05 AM

Pleased to hear it. :)

Thanks for the update.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users