Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

ASUS X53E Atheros AR9485 Wireless Network Adapter and PCI Simple Comm Controller


  • Please log in to reply
No replies to this topic

#1 walkfacefirst

walkfacefirst

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 23 November 2015 - 06:50 PM

Hello,

 

I am trying to install these drivers on an ASUS X53E and been having nothing but problems.

 

The Atheros AR 9485 corresponds to the correct hardware ID and I am downloading the correct wireless driver from the ASUS website but it will install but there is still an exclamation mark in the device manager and cannot access the wi-fi.

 

Also with the PCI Simple Comm Controller, I cannot find the correct driver to download.

 

Screen shots are attached.

 

If anyone can help me, it will be greatly appreciated.

 

Thanks Brad

Attached Files



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users