Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Issue with Galaxy Note 2 buttons (e-buttons?)


  • Please log in to reply
1 reply to this topic

#1 Ech0

Ech0

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:15 PM

Posted 21 November 2015 - 06:46 PM

Hey everyone,

 

About an hour or so ago, I accidentally dropped my phone into the toilet. (Thankfully it wasn't being used, the seat just happened to be up!) And I've tried to do some quick things to save my phone, since obviously I was pretty panicked.

 

So far I've done the following:

 

Removed the battery

physically soaked up any water left over on the phone with a towel

used a hairdryer on low heat/cold air to try and evaporate any water (looking up online, this was a bad idea.)

Place the phone with the cover off, battery removed, in a bag filled with rice

 

I pulled it out maybe 5 minutes ago and all functions appear to be normal except that the back and menu e-buttons (I think those are what they're called), on each side of the home button are non-responsive. I know it was a bad idea to power the phone back on before a reasonable amount of time for drying had past, but I thought I'd check since no water got near the SIM card, SD card, or the battery connections. Initially, before I wiped the phone off, the physical power button would not work, and the speaker was warped, as if there was water in there. After I ran through the process with the rice, everything sans the e-buttons works fine.

 

My questions for you all are:

 

1) What can I do to regain the functionality on my e-buttons besides hoping it'll be solved by the rice?

2) If there is an issue, who can I contact to have my phone repaired or diagnosed/what parts can I purchase to fix this issue?

3) What, in your opinion, should my next step be?



BC AdBot (Login to Remove)

 


#2 Ech0

Ech0
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:15 PM

Posted 21 November 2015 - 07:24 PM

I've done some more hairdrying with cold air after depressing the home button. All functionality has returned! Thanks for reading :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users