Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


External HDD detected by Disk Management but not shown in My Computer.

  • Please log in to reply
1 reply to this topic

#1 Michirin


  • Members
  • 20 posts
  • Gender:Female
  • Location:Philippines
  • Local time:03:26 PM

Posted 07 November 2015 - 05:42 AM

Help! ;;___;; I have a WD Elements External HDD and when plugged in, can be detected by Disk Management but I can't even open it. Here is a screen shot of its status in Disk Management, which says "Unknown" and "Not initialized":




And it could be detected also in Devices:




Also, the HDD has its light on and you can feel vibrations in it when plugged in.

I hope you guys could help me :( I've got tons of stuff in it and I don't want to format it yet (unless that's the only option). Thanks in advance :D


BC AdBot (Login to Remove)



#2 JohnC_21


  • Members
  • 22,093 posts
  • Gender:Male
  • Local time:03:26 AM

Posted 07 November 2015 - 11:07 AM

Have you tried different USB ports on the computer. If that does not work use another USB cable. Have you tried attaching the drive to another computer? Do you have an available powered USB hub?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users