Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Can't Seem to Open or Associate .VBS Files


  • Please log in to reply
4 replies to this topic

#1 Angel Rodriquez

Angel Rodriquez

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:22 AM

Posted 05 November 2015 - 12:28 AM

So I am not entirely sure what happened, but I think something may have been changed in the registry and now I can't open .VBS files in Windows 7.

I know it's not a file association problem.

I went to Control Panel > All Control Panel Items > Default Programs > Set Associations

There were .VB files listed, but NOT .VBS

So I went back to the original .VBS file and associated it with "Microsoft Windows Based Script Host" (Located at C:\Windows\System32\wscript.exe)

But then when I go back to try and run the file, I get this error: There is no script engine for file extension ".vbs"
 

 

And when I have Windows search the web to find a program to associate the .vbs file with, it can't come up with anything.

 

 

 

Please help, very confused.

Attached Files


Edited by Angel Rodriquez, 05 November 2015 - 02:56 AM.


BC AdBot (Login to Remove)

 


#2 technonymous

technonymous

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:22 AM

Posted 05 November 2015 - 02:53 AM

Open cmd prompt as administrator. Type and run: cscript.exe //H:WScript

 

If that doesn't work try this command: regsvr32 %systemroot%\system32\vbscript.dll



#3 Angel Rodriquez

Angel Rodriquez
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:22 AM

Posted 05 November 2015 - 07:44 PM

Open cmd prompt as administrator. Type and run: cscript.exe //H:WScript

 

If that doesn't work try this command: regsvr32 %systemroot%\system32\vbscript.dll

Ran both lines successfully but still getting same error message. I ran Microsoft FixIt and was getting unresolved errors.



#4 Angel Rodriquez

Angel Rodriquez
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:22 AM

Posted 05 November 2015 - 11:44 PM

I knew it had SOMETHING to do with a missing registry value.

Ran this and it solved my problem:

http://www.techsupportall.com/file-association-fix-for-windows-7/


Edited by Angel Rodriquez, 05 November 2015 - 11:46 PM.


#5 technonymous

technonymous

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:22 AM

Posted 09 November 2015 - 03:08 PM

That's good you found the fix for it. Sounds like something damaged the registry in the past. Virus or something. If you use programs like CCleaner you gotta be really careful. You can break things really fast. I think now CCleaner has a registry backup feature, but still you don't find out something is bad till months, or even years down the road when you're trying to do something like this.

 

That's a good link. Someone went through the time and trouble of finding all the shell registry keys to common things like .vbs, .html etc into a .reg file you can merge back into the registry. If you right-click the .reg file and choose edit. you can see how elaborate it can be and just one of those deleted will bork your system. Merging .reg files can be dangerous too. Always backup first and do a system restore point.


Edited by technonymous, 09 November 2015 - 03:24 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users