Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How do I fix missing environment variables and icon text background colors?


  • Please log in to reply
3 replies to this topic

#1 midimusicman79

midimusicman79

  • Members
  • 729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norway
  • Local time:03:55 AM

Posted 03 November 2015 - 10:17 AM

Hi all!

 

I am running MS Win XP Pro SP3 32-bit.

 

While running Windows Repair - All in One during pre-scan I noticed a missing environment variable, called .MSC, but unfortunately the tool was incapable of correcting this for whatever reason, and I am therefore wondering how do I fix this manually, or more specifically; Is Safe Mode the best way to do this?

 

Also, frequently I encounter an 'Restore Active Desktop' error message, which causes the desktop wallpaper to disappear, and while attempting to fix this, I unfortunately lost the icon text background color; how do I fix this?

 

Just some small problems that I am trying to fix now before I am building myself a new computer... :busy:
 

Thank you very much in advance!

 

Regards,

midimusicman79


Edited by midimusicman79, 03 November 2015 - 10:18 AM.

MS Win 10 Pro 64-bit, EAM Pro/EEK, MB 3 Free, WPP, SWB Free, CryptoPrevent Free, NVT OSA and Unchecky, WFW, FFQ with CanDef, uBO, Ghostery, Grammarly Free and HTTPS Ew. Acronis TI 2018, K. Sw. Upd. AM-tools: 9-lab RT BETA, AdwCleaner, Auslogics AM, aswMBR, Avira PCC, BD ART, catchme, Cezurity AV, CCE, CKS, ClamWin P., Crystal Sec., DDS, DWCI, EMCO MD, eScan MWAV, ESS/EOS, FGP, FMTB, FRST, F-SOS, FSS, FreeFixer, GMP, GMER, hP BETA, HJT, Inherit, JRT, K. avz4, KVRT, K. TDSSKiller, LSP-Fix, MB 3 Free, MBAR BETA, MA Stinger, NMC, NoBot, NPE, NSS, NVT MRF (NMRF), OTL, PCC, QD, RCS, RSIT, RKill, Rs, SC, SR, SAP, SVRT, SAS, SL, TMHC, TSA ART, UHM, Vba32 AR, VRS, WR (AiO), Xvirus PG, ZAM, ZHPC, ZHPD and Zoek. I have 23 Years of PC Experience. Bold = effective.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,295 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:55 PM

Posted 03 November 2015 - 10:43 AM

I would disable active desktop as it is a security risk. Right click an empty spot on the Desktop > Properties > Desktop tab > Customize Desktop button > Web tab > uncheck any boxes. If the desktop image changes then set it up to your preferred image.

 

For Enviromental Variable issue right click Computer > Properties > Advanced tab > Environmental Variables button. In the System Variable Section click on PATHTXT. Press edit. If MSC is not in the list add it with a semicolon.  ;.msc

 

PATHEXT

.com;.exe;.bat;.cmd;.vbs;.vbe;.js;.jse;.wsf;.wsh;.msc



#3 midimusicman79

midimusicman79
  • Topic Starter

  • Members
  • 729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norway
  • Local time:03:55 AM

Posted 04 November 2015 - 10:04 AM

Hi again, JohnC_21!

 

Thank you for the prompt and instructive reply! :)

 

Thanks for the tip :wink:, as it happens; 'Active Desktop' is disabled already, as all boxes are unchecked. :thumbup2: However I am able to change the desktop image back again.

 

I also managed to reenable the icon text background color by unchecking the 'Use drop shadows for icon labels on the desktop' box in Control Panel. :thumbup2:

 

In addition in Normal Mode (not Safe Mode) I succeeded in editing the PATHEXT variable to include the .msc :thumbup2:

 

And actually in conjunction with all of the above, I luckily resolved another icon issue which has bothered me for a long time, namely that several icons had a squared background color (dark blue) and some strange shadows which however did not show up in Safe Mode; and I even downloaded TweakUI thinking that rebuilding the icon cache would help, but no luck there either, until today... :thumbsup:

 

Thank you very much for the help! :) The issues have been successfully resolved! :thumbsup:

 

Regards,

midimusicman79


Edited by midimusicman79, 04 November 2015 - 10:06 AM.

MS Win 10 Pro 64-bit, EAM Pro/EEK, MB 3 Free, WPP, SWB Free, CryptoPrevent Free, NVT OSA and Unchecky, WFW, FFQ with CanDef, uBO, Ghostery, Grammarly Free and HTTPS Ew. Acronis TI 2018, K. Sw. Upd. AM-tools: 9-lab RT BETA, AdwCleaner, Auslogics AM, aswMBR, Avira PCC, BD ART, catchme, Cezurity AV, CCE, CKS, ClamWin P., Crystal Sec., DDS, DWCI, EMCO MD, eScan MWAV, ESS/EOS, FGP, FMTB, FRST, F-SOS, FSS, FreeFixer, GMP, GMER, hP BETA, HJT, Inherit, JRT, K. avz4, KVRT, K. TDSSKiller, LSP-Fix, MB 3 Free, MBAR BETA, MA Stinger, NMC, NoBot, NPE, NSS, NVT MRF (NMRF), OTL, PCC, QD, RCS, RSIT, RKill, Rs, SC, SR, SAP, SVRT, SAS, SL, TMHC, TSA ART, UHM, Vba32 AR, VRS, WR (AiO), Xvirus PG, ZAM, ZHPC, ZHPD and Zoek. I have 23 Years of PC Experience. Bold = effective.


#4 JohnC_21

JohnC_21

  • Members
  • 24,295 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:55 PM

Posted 04 November 2015 - 10:40 AM

Your Welcome

Glad your back in business and thanks for the update.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users