Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How do you maintain aspect ratio on your screen?


  • Please log in to reply
5 replies to this topic

#1 signofzeta

signofzeta

  • Members
  • 421 posts
  • OFFLINE
  •  
  • Local time:09:25 AM

Posted 02 November 2015 - 08:30 PM

When I run my 4:3 aspect ratio games, I have it set, or should I say, my laptop already has it set so that there are black bars on the sides to maintain this aspect ratio.

 

I wanted to test something, and I changed my screen resolution, then I changed it back.  Now suddenly, my 4:3 aspect ratio games are stretched on my 16:9 screen.

 

There was a way to change the aspect ratio settings of whether you want to stretch or preserve the aspect ratio in windows vista, but I can't seem to find the settings on windows 8.1.

 

I performed a system restore, but I don't want to have to do a system restore in case I accidentally change the resolution and not knowing how to revert 4:3 aspect ratio on a 16:9 monitor from stretch to preserve aspect ratio.

 

I have both an Intel HD graphics card 4600, and a Nvidia Geforce GTX 760M.  I checked the intel graphics control panel, and the scaling is set at "maintain display scaling", which is why it probably stretches, but there is no option to preserve the aspect ratio.


Edited by signofzeta, 02 November 2015 - 08:30 PM.


BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,008 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:25 PM

Posted 06 November 2015 - 06:41 PM

Have you looked at the settings inside the games, or tried running them in a window instead of full screen ? 

 

Chris Cosgrove


I am going to be away until about the 22nd October. Time on-line will be reduced and my internet access may be limited. PMs may not be replied to as quickly as normal !


#3 signofzeta

signofzeta
  • Topic Starter

  • Members
  • 421 posts
  • OFFLINE
  •  
  • Local time:09:25 AM

Posted 09 November 2015 - 01:54 AM

They are old games so they don't have the setting.  They are meant to run on 4:3 monitors or screens rather than widescreen.  The games I am playing can be run in windowed mode, but I rather have it full screen with the two black bars on the side.

 

For some dumb reason, Intel does not let me set what happens if I go from my 1960x1080 resolution to a lower resolution, like 1024x768, when I run a game, for example.  The only way I can get the black bars is to actually set a resolution at 1024x768, which is the lowest resolution, set it so that it maintains aspect ratio, then reset it to 1960x768.  I haven't tried to see what happens when I run a 640x480 game, and don't want to test it out, as it would mess things up because my laptop does not have a 640x480 setting.  So far, when I run a 640x480 game, I get the black bars, and I don't want to change resolutions, and have my 640x480 games stretched with no way of changing it back, unless I do a system restore.

 

If Intel only made it so that I don't have to change my resolution just to set if I want my image to be stretched or maintain aspect ratio, especially when I run programs that don't use my native resolution.  For example, even at 1920x1080, I should still have the option to center the image, maintain aspect ratio, or stretch the image.  It is just that all 3 options wouldn't achieve anything, but when I run a game that uses a lower resolution, I would see the effect.  So far, the only option is "maintain display scaling", with the options appearing when I go to a lower resolution.

 

Just saying, I have the latest intel graphics driver, according to my computer's manufacturer.


Edited by signofzeta, 09 November 2015 - 01:59 AM.


#4 Platypus

Platypus

  • Global Moderator
  • 15,213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:01:25 AM

Posted 09 November 2015 - 08:05 AM

I checked the intel graphics control panel, and the scaling is set at "maintain display scaling", which is why it probably stretches, but there is no option to preserve the aspect ratio.


What happens if it is set to not maintain scaling?
Top 5 things that never get done:

1.

#5 signofzeta

signofzeta
  • Topic Starter

  • Members
  • 421 posts
  • OFFLINE
  •  
  • Local time:09:25 AM

Posted 09 November 2015 - 10:58 PM

 

I checked the intel graphics control panel, and the scaling is set at "maintain display scaling", which is why it probably stretches, but there is no option to preserve the aspect ratio.


What happens if it is set to not maintain scaling?

 

 

If there is only one option, you have to set it at that option.  The only way to not maintain display scaling is to set it at something else, such as maintain aspect ratio or center the image, which is not available at 1920x1080.



#6 Platypus

Platypus

  • Global Moderator
  • 15,213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:01:25 AM

Posted 10 November 2015 - 12:33 AM

Scaling determines the aspect ratio, which is why I asked about that function. So it isn't possible to uncheck the option to maintain scaling? There was a driver update in June over that issue for the 4000 series:

https://communities.intel.com/message/310578

"You can set your preferred scaling option for desktop modes here - now the scaling preference is independent of current resolution and is "sticky" (retained when resolution change occurs). In addition, you can try checking the box selecting "Override Application Scaling" checkbox to force scaling of games to match your preferred scaling option (e.g. either full screen or maintain aspect ratio depending on your preference)"

If your system is using an earlier driver it may not have the function. The most recent driver issue was last month:

https://downloadcenter.intel.com/product/81496/Intel-HD-Graphics-4600-for-4th-Generation-Intel-Core-Processors
Top 5 things that never get done:

1.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users