Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

external hard drive


  • Please log in to reply
2 replies to this topic

#1 bobbies

bobbies

  • Members
  • 162 posts
  • OFFLINE
  •  
  • Local time:09:26 PM

Posted 30 October 2015 - 08:10 AM

I have an Iomega external hard drive that needs a power source. I run Windows 7. I have never had any problems before. I was using it yesterday O/K. Then i have come to it today, and the little blue light is not coming on, so there is no power coming from the hard drive, it can´t be the socket outlet, as i have tried it in another one, also i have a duplicate hard drive so i tried with that power cable and that didn´t work either.

If i disconected the hard drive from my laptop, without closing the prog, i was on, is that enough to cause it not to fire up. Is it worth trying to get inside to have a look. Not as though i would know what i was looking at. thanks.



BC AdBot (Login to Remove)

 


#2 CodeSmasha

CodeSmasha

  • Banned
  • 524 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:26 AM

Posted 30 October 2015 - 08:17 AM

Try connecting it to another PC and see if the problem persists?



#3 n2coffee

n2coffee

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tennessee, USA
  • Local time:04:26 PM

Posted 30 October 2015 - 09:15 AM

Not an expert but...

 

Try the cord from the hard drive with the "duplicate hard drive"; if it works on the duplicate device, the problem is either a switch on the external hard drive or an internal component.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users