Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"javascript:void(0)" is preventing me from shopping at one online store.


  • Please log in to reply
2 replies to this topic

#1 Alyab123

Alyab123

  • Members
  • 71 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:36 AM

Posted 19 October 2015 - 12:58 AM

I have been shopping at a particular online store for a long time. About 4 days ago, when I tried to shop there, I encountered a problem. In order to locate the specific item I am interested in buying, I have to select a department, than a type of item etc. All that went fine. However, at the last step, where I can filter by size, color, manufacturer etc., the selections don't respond to my mouse, and the word "javascript:void(0)" shows up on the bottom left of my screen.

I have windows 7, and I am using firefox. I initially thought that the problem was related to an add-on, so I disabled all add-ons.
That did not help, so I uninstalled all my add-ons!
I set the browser to delete my history, my cache, my site preferences, my active logins, my cookies etc., and then restarted firefox. The problem persists.

I also realized that when I try to shop at that site, and I start the process of selecting the department, the type of item etc, a page loads with filters already selected, (eg. size, color, brand) apparently from a previous instance of shopping. I can not change those filters. when my mouse hovers over the filter option icons, that is where the "javascript:void(0)" word shows up on the bottom of my screen.

I tried to shop using Internet explorer, and chrome. The exact problem happened with those browsers too.
I contacted the technical support at that online store, and they insist there are no technical problems with the site.

It does appear to be something that is set and stuck on my computer.
I deleted my bookmark for that site.
I used ccleaner to get rid of any cookies or whatnot that I don't see on my pc.
I checked internet explorer (which I never use) options, and I don't see any place where javascript is disabled in any way. I am not sure if there are specific "scripting" options that should be enabled or disabled, since I never use Internet explorer, and I didn't have a problem in the past.
None of these things have helped!

I had gotten a number of security updates since October 14 (4 days ago), so I actually did a system restore to a time before those updates. I still have the problem. I also don't know of a specific site I can use to see if the same type of action is also blocked on that site. That should be fairly simple, if someone can make a suggestion of a specific place where I can try to replicate the action of filtering shopping selections using javascript in the same way. I tried searching on ebay, and had no problem filtering my search. But I don't know if ebay uses the same system.

Incidentally, I am having the problem at www.Kohls.com

Does anyone have any other suggestions of where I can look to find the setting that is keeping me stuck when I try to shop at this store?? where else might I find cookies, or a cache, or saved offline data "hiding" on my pc?

Thank you!

 

addendum:

I tested this situation at my mom's computer. She is using Windows 10. I have firefox installed at her PC. I had the same problem over there! Firefox over there is NOT set to sync, by the way, so that doesn't explain it!
I did NOT have the problem on chrome or Internet Explorer, while using her PC. On my PC I continue to have this problem on all 3 browsers. This thing is driving me nuts.

 

Somewhere there is a setting preventing javascript on this site. Perhaps in an obscure cookie, or a registry setting?


Edited by Alyab123, 19 October 2015 - 01:01 AM.


BC AdBot (Login to Remove)

 


#2 britechguy

britechguy

    Been there, done that, got the T-shirt


  • Moderator
  • 8,142 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Staunton, VA
  • Local time:05:36 AM

Posted 27 October 2015 - 06:44 PM

What you're seeing in the status bar is neither unusual nor an error message.  Generally one sees that particular phrasing when a pop-up is the most likely result of your mouse click.  You'll see it when you hover even before clicking on some browsers.

 

I suspect an actual coding error on the website itself, and they do happen.  You might want to contact the company in question to report this and see what their reply is.


Brian  AKA  Bri the Tech Guy (website in my user profile) - Windows 10 Home, 64-Bit, Version 1803, Build 17134 

      Memory is a crazy woman that hoards rags and throws away food.

                    ~ Austin O'Malley

 

 

 

              

 


#3 Alyab123

Alyab123
  • Topic Starter

  • Members
  • 71 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:36 AM

Posted 05 November 2015 - 09:46 PM

thank you so much for addressing my problem. It took me a while to get back here. I actually contacted the store in the beginning, asking for tech support. They said there is nothing wrong and nobody else is reporting a problem. So I still don't know what it is. But, if I refresh the page AFTER making my selection, it does load with the selection. It's annoying, but workable enough for me. Thanks also for explaining that the javascript:void isn't necessarily a reflection of the problem I'm having.

 

All the best to you.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users