Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Google Chrome memory hog


  • Please log in to reply
2 replies to this topic

#1 PGHinBKK

PGHinBKK

  • Members
  • 339 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bangkok, Thailand
  • Local time:03:26 PM

Posted 14 October 2015 - 10:39 PM

Hi, all!   

 

  I have a question about Google. Right now, I have two tabs open but when I look at the 'Processes' tab in Windows 'Task Manager', it shows 8 separate instances of Chrome running. I know Google has apps that run in the background, and the problem is that these apps use up enough memory that they slow down my unit to the point where sometimes it freezes. I then can't turn them off because nothing (mouse, etc) is working.  How can I get my installation of Google to use less memory and perhaps turn off these background apps?  

 

Thanks


Life is strange......and then there's Thailand....

BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,728 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:09:26 AM

Posted 17 October 2015 - 06:42 PM

Chrome can do this to you !

 

Click on the three bar symbol in the top right hand corner and choose 'Settiings'. At the bottom of the screen you will see 'Show advanced settings', click on this and the page will expand. Scroll down until you come to 'System' and untick the box that says 'Continue running background apps . . .'.

 

This should solve your problem. If it doesn't, post back.

 

Chris Cosgrove



#3 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 35,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:01:26 AM

Posted 17 October 2015 - 09:48 PM

This is a known issue with Chrome and it's being addressed. How soon they will deal with it is anybody's guess. However I have found tow extensions that deal pretty nicely with the issue. The first one I have been using is The Great Suspender https://chrome.google.com/webstore/detail/the-great-suspender/klbibkeccnjlkjkiokjodocebajanakg?hl=en

The second one I just found yesterday while looking deeper into your question. That is One Tab https://chrome.google.com/webstore/detail/onetab/chphlpgkkbolifaimnlloiipkdnihall?hl=en

These by no means are solutions to Chromes's well documented memory issue. But they do address the issue enough to make it less painful.

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users