Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Flash Drives & Discs opening in VLC


  • Please log in to reply
15 replies to this topic

#1 rozzer

rozzer

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 03 October 2015 - 01:52 AM

Linux Mint 17.1

Hi
When I insert a 'USB Flash Drive' it immediately tries to open in 'VLC' even though my media settings are set to 'ask what to do'.....all other media is also set to 'ask what to do'.
I have to close the 'VLC' application before I then proceed to open the 'Flash Drive' from 'Computer' I also have to do the same with any 'Discs' I use, Browse C: Drive (Browse your Virtual C: drive) also opens with 'VLC'.I tried opening with alternative applications and each time the screen reverted to just my background picture and all the icons disappeared but I was able to open the menu and shut the pc down but I was unable to unmount the 'Flash Drive' normally beforehand. I tried to change the options in various ways using the 'Preferred Applications' but it made no difference the 'Flash Drive' still opened with 'VLC'.
I created a new user and everything worked fine it mounted/unmounted ok and it opened the 'Flash Drive' automatically to see the files. After giving it some thought I decided to uninstall 'VLC' and the everything worked just fine and opened the way it should so I assumed the problem was with 'VLC' but then I tried installing 'Banshee' and the same thing happens.any ideas??

(I tried asking on the Linux forum but it appears as though they have maybe forgotten me)

Cheers

Edited by rozzer, 03 October 2015 - 02:04 AM.


BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 03 October 2015 - 05:05 AM

Hi rozzer,

Is there a particular file on the USB that tries to open in VLC or Banshee? If you plug in a USB flash drive that contains no videos, what happens?

Browse C: Drive (Browse your Virtual C: drive)


There is no C: drive or virtual C: drive in Linux. Are you using Wine, and if so did this issue appear after installing Wine?

Edited by Al1000, 03 October 2015 - 05:09 AM.


#3 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 03 October 2015 - 06:13 AM

Hi Al1000

Thanks again for replying (I'm keeping you busy today lol)

When I insert the USB it opens in VLC whether it has backup files, pictures, music etc.
Believe it or not but VLC can also read and display the documents on the USB but it tries
to open every folder and every document for reading etc.
I have 'Wine' installed as I tried to run some old games but without success so I no longer
have the games but I still have 'Wine'installed. I cannot tell you if the problem appeared
before 'Wine" or after, I have 'EngNet Clocks' as well as 'EngNet Tools' installed and they
need 'Wine to run them.
Maybe I should uninstall 'Wine' What do you think? I can always reinstall them!!

Thanks once again
Cheers

Edited by rozzer, 03 October 2015 - 06:14 AM.


#4 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 03 October 2015 - 06:40 AM

Believe it or not but VLC can also read and display the documents on the USB


I have no idea what's happening here. I just tried to open a text file using VLC and it didn't work (nor did I think it would).

Can you try opening a text file from the terminal using VLC and post the output?

Here is an example:
 
al@my_desktop_pc:~$ cd newtempdir/
al@my_desktop_pc:~/newtempdir$ vlc file1
VLC media player 2.1.6 Rincewind (revision 2.1.6-0-gea01d28)
[0x93f3910] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0xafb2bb58] es demux error: cannot peek
[0xafb2bb58] es demux error: cannot peek
That is the error message I'm getting when I try to open a text file called "file1" with VLC using the command
vlc file1
how to start applications from the terminal

Edited by Al1000, 03 October 2015 - 06:42 AM.


#5 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 03 October 2015 - 07:58 AM

Hi again

 

I did try as per your instructions but unsuccessfully, I will try and submit some screenshots once I discover how to do that.

 

I checked the actuall events whilst a USB & Disc  was loading inside VLC and some of the items where:-

1) Pictures of furniture from a home design programme

2) A list of items as the are being loaded

3) A pic. of a document I made in LO calc. spreadsheet

4) a Video acceleration error screen

 

Cheers


Edited by rozzer, 03 October 2015 - 08:21 AM.


#6 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 03 October 2015 - 08:48 AM

Hi again Al1000

Here are the files maybe they will help

 

Regards

rozzer

 

 

  20gntkp.png

  2hyf6ro.png

  2hcp72a.png

  33u7c5k.png


Edited by rozzer, 03 October 2015 - 08:50 AM.


#7 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 03 October 2015 - 10:07 AM

Thanks for the screenshots; yes they do help. Although thumbnail.png looks like a document, it's actually an image of a document, and does open in VLC. I imagine that the same might be true for the other files that open in VLC.

It just so happens that I have Linux Mint installed in VirtualBox, so I booted it up for a closer look. A couple of things to check:

  • Open "Preferred Applications" from the menu, click on the "Removable Media" tab, and check that all the boxes are set to "Ask What To Do."
  • Also click on the "Other Media" button under the Removable Media tab in Preferred Applications, and check that all the options in there, and particularly the "Windows software" option, are also set to "Ask What To Do."
Please let me know whether this fixes the issue.

#8 pcpunk

pcpunk

  • Members
  • 5,872 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:10:03 AM

Posted 03 October 2015 - 12:57 PM

I hate to butt in, but did this happen after you changed File Names in Home? just a thought.  This is why I love Timeshift, it might have solved something like this, that was possibly caused by a change that was made.  Hope you get er done!  I will look into this also.  I was wondering if it has anything to do with having music files on Medium without being in a Folder?  Or, I'm guessing, that it was not a problem before with the same setup?


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#9 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 04 October 2015 - 12:49 AM

Hi Al and pcpunk

Al..These are the settings which have been on for a while, I did try to change them but it made no difference
so I reverted back

Preferred Applications
Web Firefox
Mail Thunderbird
Text Text Editor
Music Videos
Video VLC
Photos XNView
TerminalTerminal

Removable Media
CD audio, DVD video, Music Player, Photos. Software...all set to 'Ask What To Do'

Other Media
audio DVD set to 'Ask What To Do'

pcpunk..I haven't changed any files names in 'Home' my other post was a query as to whether I could
but nothing changed so far. This problem has been with me ever since I installed Mint but it was an
issue which wasn't causing me any problems at the time as I was trying to get acquainted with Linux
in general, it became more of an issue now I have started to load my music on to the pc from my discs
and when I load a disc it opens to 'Play' automatically....I have to stop it and try to open the disc
in 'computer' sometimes I'm lucky first time and other times I have to try the procedure a few times.

Thanks guys
Cheers

#Edit..New issue
I opened every item in the Menu and found that these also open to VLC
Menu/Places/Documents
Menu/Places/Music
Menu/Places/Pictures
Menu/Places/Videos
Menu/Places/Downloads

Confused!!

Cheers

Edited by rozzer, 04 October 2015 - 05:43 AM.


#10 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 04 October 2015 - 06:05 AM

There's a check box in the lower left-hand corner under the Removable Media tab that looks like it might do the trick:

Linux%20Mint_zpsvtfh1ras.png

#11 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 04 October 2015 - 06:24 AM

Hi Al

 

MAGIC!!!!!!!!! works perfect, I tried the Flash Drive and a CD and they remained closed, accessed them via 'computer'

 

The edit in my previous post still stands even after this fix, is that normal, seems odd to me.

 

Brilliant anyway

 

Cheers :bananas:



#12 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 04 October 2015 - 07:08 AM

Excellent! :)
 

#Edit..New issue
I opened every item in the Menu and found that these also open to VLC
Menu/Places/Documents
Menu/Places/Music
Menu/Places/Pictures
Menu/Places/Videos
Menu/Places/Downloads

That is odd, and definitely not normal. The easiest thing to do might be to "purge" vlc from your computer by opening a terminal and running this command:
sudo apt-get purge vlc

(This command will uninstall everything relating to vlc, whereas a "normal" uninstall would only remove vlc system files but leave settings relating to vlc intact.)

(Press Enter on keyboard when asked if you want to continue)

Then reboot your computer, try opening Menu/Places/Documents etc, and they should hopefully open in Nemo, then you can install vlc again either from the software manager or by running this command:
sudo apt-get update && sudo apt-get install vlc


#13 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 04 October 2015 - 07:24 AM

Hi Al

I did the uninstall/install process and it's still the same sadly.

Cheers

#Edit....Success, I opened the Folder (Documents) from the Home folder on the desktop
and I changed the default from VLC to Files and tried again and it works fine. That may
not be the normal route or even the correct one but it seems to work.

Thanks a million Al (lets hope the problem is solved) going to reboot and see

cheers

Edited by rozzer, 04 October 2015 - 07:42 AM.


#14 Al1000

Al1000

  • Global Moderator
  • 7,729 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:03 PM

Posted 04 October 2015 - 08:00 AM

Good stuff! Pleased to hear you got it fixed.

I changed the default from VLC to Files

Could you please explain exactly how you did this, so that anyone else who has the same problem knows what to do?

Many thanks.

#15 rozzer

rozzer
  • Topic Starter

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:04:03 PM

Posted 04 October 2015 - 09:57 AM

New issue
Menu/Places/Documents
Menu/Places/Music
Menu/Places/Pictures
Menu/Places/Videos
Menu/Places/Downloads

All of these open to VLC

Hi Al

Re the above items opening in VLC, My last attempt to get these folders to open normally was
when I went to ''Home' on the desktop and 'double click' to open then right clicked the folder 'Documents' and selected
'Open With' then chose 'Other Application' and selected 'Files' from the dropdown menu and made
it the 'Default' and everything worked ok from then onwards

But I have to say I couldn't have done it without your help.(hope that explains it enough)
Thanks once again Al and BP
Cheers

Edited by rozzer, 04 October 2015 - 10:00 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users