Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Exchange 2010 Database won't mount. ESEUTIL error 1032


  • Please log in to reply
2 replies to this topic

#1 specter351

specter351

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:49 PM

Posted 27 September 2015 - 09:36 AM

Hello-

We've got a machine that had a power failure and the Exchange Database won't mount after startup.

No matter what I do, I can't get ESEUTIL to address the database.

 

-I have tried running ESEUTIL /p, and I have tried both Command Prompt and Exchange Management Shell both running as Administrator. 

 

I tried deleting the log files as well.

Below is the error I get when trying to run ESEUTIL.

 

 

[PS] C:\Windows\system32>eseutil /p "E:\Program Files\Microsoft\Exchange Server\Exchsvr\Mailbox Database 1258094299"

 

Extensible Storage Engine Utilities for Microsoft® Exchange Server

Version 14.02

Copyright © Microsoft Corporation. All Rights Reserved.

 

Error: Access to source database 'E:\Program Files\Microsoft\Exchange Server\Exchsvr\Mailbox Database 1258094299' failed

 with Jet error -1032.

 

Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after

20.31 seconds.

 

Help would be greatly appreciated.

Thanks/



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,257 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:49 AM

Posted 27 September 2015 - 02:12 PM

Jet error -1302 means you can't access the file, as it is locked or in use -- because you mounted the database and ran ESEUTIL. Dismount the database to take it offline and then run ESEUTIL.

 

https://social.technet.microsoft.com/Forums/exchange/en-US/5fde561c-7f73-4a82-be7a-d711af536e9d/exchange-2010-gives-me-error-when-i-run-eseutil?forum=exchangesvrgenerallegacy



#3 armanilowe

armanilowe

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:49 PM

Posted 01 October 2015 - 11:59 AM

Run Eseutil in /P (repair) mode it is preferred variant for me but otherwise you may try to use more powerful instrument for more complicated cases, only if it is your case https://exchangeserver.recoverytoolbox.com/  Recovery Toolbox for Exchange Server

 

Helpful threads over specs forums on Exchange Server:

http://community.office365.com/en-us/f/172/t/278716.aspx

http://forums.msexchange.org/m_1800598776/mpage_1/key_/tm.htm#1800598776

 

The easiest way to do this is to have both database files (.EDB and .STM) in the same directory (which they usually are). If they're in different places, you're going to have to point to the files on the command line.

Eseutil is located in the \exchsrvr\bin directory

Example:

eseutil /p c:\exchsrvr\mdbdata\db1.edb /sd:\exchsrvr\mdbdata\db1.stm /te:\temp.edb

This command line will repair DB1.EDB located on C: along with its matching .STM file located on D: and will put the temporary file on the E: drive.

If your streaming database file (.STM) is not matched to the database file (.EDB) or it has a problem that is blocking repair, you can add the /i switch to the repair command line.

The /i option ignores the signature mismatch error in the check phase. The database and streaming file will receive new signatures in the repair phase.

Repair can take a while--hours. When it finishes, it will leave you with a very detailed log file of what it did called .integ.raw.

Not quit finished yet, there are two more steps to complete.

Please see some more links in the conclusion for examples of the command line and a brief intro to the exchange utilities






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users