Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I keep getting the 'class not registered' error


  • Please log in to reply
9 replies to this topic

#1 clayto

clayto

  • Members
  • 474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:59 PM

Posted 25 September 2015 - 09:21 AM

I keep getting the 'class not registered' error when I search the web from Cortana and when I click on various links. For example, I have just been stopped from installing Belarc Advisor by this. I have not been able to do any web searches from Cortana. What appears is a box stating class not registered and listing OpenWith.exe.

 

I have tried using SFC and DISM, without success.

 



BC AdBot (Login to Remove)

 


#2 clayto

clayto
  • Topic Starter

  • Members
  • 474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:59 PM

Posted 26 September 2015 - 04:51 AM

All I have had to do (following advice) is to reset Edge as my default browser instead of Chrome.



#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:09:59 AM

Posted 26 September 2015 - 04:59 AM

Did that fix it?

If not, you can try these 2 things:

1)  Please attempt to fix your DCOM errors by doing this:

Go to Start, and then to Run (or the Win and R keys)
Type in "dcomcnfg" (without the quotes) and press Enter

In the Component Services window that opens, go to the left hand pane and double click on:
- Component Services, then on
- Computers, then on
- My Computer, then on
- DCOM Config
If it asks you to register any of the components, click Yes
This may happen several times if there are several unregistered components

Once you're finished, close the window and reboot the computer.
Check to see if the problems are fixed.
NOTE:  This is a generic "fix" for DCOM errors.  If it does not fix your problems, please post back.

2)  Run the following command in a Powershell window that's run as an Administrator in order to re-register the Windows Store apps:
Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
From this article:  http://www.thewindowsclub.com/re-register-windows-store-apps
 
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 clayto

clayto
  • Topic Starter

  • Members
  • 474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:59 PM

Posted 27 September 2015 - 04:40 AM

Yes, it did fix it but I have now been advised not use Edge as degault (!) but to use IE --- Cortana seems to be OK with that.



#5 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:09:59 AM

Posted 29 September 2015 - 07:10 AM

If it works for you, then that's that.  :0)

 

Just my 2¢:

I'm not an Edge expert, but I wonder about that advice.  AFAIK - Edge and Cortana were developed to work together.

If there's a problem, it'd be better to fix the problem rather than just avoid using a program.

 

BTW - the second tip that I gave (about reregistering Windows Store apps), won't work on Cortana as it's always running.

It will work on Edge if you ensure that it's fully closed (check in Task Manager).  And it'll work on most any other add-in that affects these 2 (again, as long as they are closed).


My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#6 clayto

clayto
  • Topic Starter

  • Members
  • 474 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:59 PM

Posted 03 October 2015 - 04:48 AM

Edge seemed to be working OK when I used it, a few times. As far as I know the advice not to use it was not about anything in particular but only a general comment on the basis that Edge is new and not 'tried and tested". So I will use it from time to time while keeping IE as my default from Cortana. In fact when I open a browser independently from Cortana I mainly use Maxthon which is quite quick, or Chrome if I am going to use the Chromecast.



#7 H3aTDom3

H3aTDom3

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 11 January 2016 - 11:47 AM

just use system restore to the latest back up point. that helped me.



#8 kleenmaint

kleenmaint

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 30 March 2016 - 02:14 PM

WINDOWS 10, on HP pavillion (originally Vista 2007 first edition)

 

simple fix for me as it occurred when I tried to open jpg. or bitmap images was to:

 

right click, "open with", in my case I used Nero Home Media, and "always use this program to open:

bitmap

jpg

etc.


Edited by kleenmaint, 30 March 2016 - 02:16 PM.


#9 rittenhouse

rittenhouse

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:59 AM

Posted 17 May 2017 - 08:17 AM

just unplug your machine for an hour or so, or overnight should restore in the morning



#10 dna9

dna9

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:07:59 AM

Posted 17 May 2017 - 10:15 AM

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-error-message-class-not-registered-in/f4b5753c-c28e-4696-bde7-6e811bd285fd

 

windows wants to be in control with default apps.  sad...






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users