Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

1 Laptop, 2 Hard Drives: HDD = Win7 & SSD = Ubuntu Linux... Boot Question


  • Please log in to reply
16 replies to this topic

#1 Pensive_By_Nature

Pensive_By_Nature

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:10:07 AM

Posted 23 September 2015 - 07:58 PM

Hello All!
I'm hoping you can help me with a boot problem. I've scanned a few posts on here and haven't found a similar problem so I'm posting myself.
 
I have an Acer Aspire 5750 laptop, I've replaced the optical drive with a hard drive caddy, within the caddy I installed a 480gb SSD drive, on that drive I installed Ubuntu Linux. On the "resident" HDD, I have Windows 7.
 
I would like to be able to boot the machine and be given the choice of either booting into;
 
> Windows 7 or
> Ubuntu Linux
 
However, currently when booting the machine, Windows 7 always loads.
 
When viewing the BIOS it only shows me the Windows 7 hard drive the other drive is not visible, however if I disconnect the Windows 7 drive completely, the machine boots Ubuntu without issue, can someone suggest a way for me to be able to create a boot options menu to fix this? I don't know if not seeing the SSD in the BIOS when both drives are installed is causing the problem. Any suggestions would be greatly appreciated... Thanks in advance.

Pensive By Nature

BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,570 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:08:07 PM

Posted 23 September 2015 - 10:32 PM

 

I don't know if not seeing the SSD in the BIOS when both drives are installed is causing the problem

You are right, If your BIOS cant see it, It cant boot from it.

 

 

Boot into BIOS and see if the option to boot from CD/DVD is still there, Maybe BIOS still sees the caddy as an optical drive.

 

IMO I would have put Win 7 on the SSD and Ubuntu/Linux on the HDD in the caddy.



#3 Al1000

Al1000

  • Global Moderator
  • 7,979 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:07 AM

Posted 24 September 2015 - 03:24 AM

Maybe BIOS still sees the caddy as an optical drive

Indeed, or it could be seen as a removable device in the boot menu, or an internal drive in the HDD menu.

It would be easy to install the Linux bootloader to the MBR of your Windows drive, which would give you the multi-boot menu that you want, but first of all you would ideally boot the machine into Linux with the Windows drive plugged in.

If you could boot from a Linux DVD (or USB) with both drives plugged in, and post the output of:
sudo fdisk -l
... in the first instance we can check that both drives are detected.

Edited by Al1000, 24 September 2015 - 03:25 AM.


#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:07 AM

Posted 24 September 2015 - 07:55 AM

Another question to throw in there, did you install Ubuntu on the laptop that the drive is currently in? Or did you have the SSD drive in a different computer, install it, then put it into the laptop? Hopefully that makes sense.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 Naught McNoone

Naught McNoone

  • Members
  • 308 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Great White North
  • Local time:05:07 AM

Posted 24 September 2015 - 11:51 AM

. . . Aspire 5750 . . . hard drive caddy . . . 480gb SSD drive . . Ubuntu Linux . . . "resident" HDD, I have Windows 7 . . .like to be able to . . . be given the choice of either booting . . .  Windows 7 or Ubuntu Linux . . .

 

. . . BIOS it only shows . . . Windows 7 hard drive . . . if I disconnect the Windows 7 drive . . . boots Ubuntu . . .

 

Pensive,

 

This may be an issue with the caddy.

 

Your HDD controller is probably set for AHCI mode, in the notebook BIOS.

Because of that, it will ignore the caddy, which is basic IDE.

In order to see the drive in the caddy, you may have to run the controller in IDE mode.

 

The reason that the notebook boots without the main drive, is that it goes into a fall back mode, and boots from the first available device.

 

However, if you change your controller to IDE mode, your Windows 7 may not boot properly.

 

In some BIOS's you can set the controller to "compatibility" mode, which should detect which kind of drive is connected to it.

 

Hope this helps.

 

Cheers!

 

Naught.



#6 Pensive_By_Nature

Pensive_By_Nature
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:10:07 AM

Posted 24 September 2015 - 08:37 PM

First of all, thanks for taking the time to reply to my post. I will try to answer all of the questions posed above, but you should know I'm new to Linux and wanted to explore the possibility of keeping my Windows installation separate to the Linux one because I've heard about concerns with having the two installations on the same drive in different partitions. I wanted to avoid any instability issues.

 

OK, now that's said, on to answering the above questions...

 

 

 

I don't know if not seeing the SSD in the BIOS when both drives are installed is causing the problem

You are right, If your BIOS cant see it, It cant boot from it.

 

 

Boot into BIOS and see if the option to boot from CD/DVD is still there, Maybe BIOS still sees the caddy as an optical drive.

 

IMO I would have put Win 7 on the SSD and Ubuntu/Linux on the HDD in the caddy.

 

 

@NickAu,
As suggested, I booted into the BIOS this morning to see what was available to me. The following options were available (Boot priority Order):
 
1. HDD : WDC WD7500BPVT-22HXZT1
2. ATAPI CDROM :
3. USB HDD :
4. USB FDD :
5. USB CRROM :
6. Network boot : BRCM MBA Slot 0200 v14.4.5
 
If I use F12 during a normal machine boot, I see the following options:
 
1. HDD: WDC WD7500BPVT-22HXZT1
2. Network Boot: BRCM MBA Slot 0200 v14.4.5
 
My Windows installation was a pre-install. The HDD is 750gb and I'm over half full. The SSD (which is 480gb), is very much the new addition to my setup, and was the main reason for installing Linux to that drive. I understand the SSD speed benefits would most likely be better served with Windows over Linux and that's something I might look at in the future. However for now, I didn't want to go through switching up everything yet.
 
Additional information....
 
I have another post currently being looked at in the Windows 7 forum HERE.... I was asked to run Speccy, which showed both drives in the Storage section of the report (but strangely (?) not in the BIOS):
 
Storage:
698GB Western Digital WDC WD7500BPVT-22HXZT1 (SATA): 41 °C
447GB Crucial_CT480M500SSD1 (SSD)
Optical Drives:
No optical disk drives detected
 
I'm not able to see the SSD in "My Computer" of Windows, not sure I should be able to. In "Computer Management", I see the following:
 
> Disk 0 (Dynamic) 698.64 GB Online
 
[Three Partitions]:
i) 15 GB Healthy (Recovery Partition)
ii) System Reserved 100 MB NTFS Healthy (System)
iii) Acer (C:) 683.54 GB NTFS Healthy (Boot, Page File, Crash Dump)
 
> Disk 1 (Basic) 447.13 GB Online
 
[Two Partitions]:
i) 243 GB Healthy (Active, Primary Partition)
ii) 446.89 GB Heathly (Primary Partition)
 
I hope this information is useful.

 

 

 

Maybe BIOS still sees the caddy as an optical drive

Indeed, or it could be seen as a removable device in the boot menu, or an internal drive in the HDD menu.

It would be easy to install the Linux bootloader to the MBR of your Windows drive, which would give you the multi-boot menu that you want, but first of all you would ideally boot the machine into Linux with the Windows drive plugged in.

If you could boot from a Linux DVD (or USB) with both drives plugged in, and post the output of:
sudo fdisk -l
... in the first instance we can check that both drives are detected.

 

 

@Al1000,
In response to the visibility of the SSD, please see what I wrote above to NickAu.
Regarding the Linux Bootloader and MBR, this sounds like where I want to be, however, I would need some guidance as to how to perform the "sudo fdisk -1" action. I'm not not very experienced with Linux Command Line.
 
My Linux installation was originally from a CD onto the SSD (with the HDD removed / replaced, i.e. not using the Caddy). It boots up perfectly and without issue. After installing Linux, I then replaced the HDD and moved the SSD into the Caddy. This is how my machine is setup now. So I'm guessing I need to put the Linux CD installation onto a USB and boot from it with both HDD and SSD installed as they are. Am I on the right track? Hope this makes sense.

 

Another question to throw in there, did you install Ubuntu on the laptop that the drive is currently in? Or did you have the SSD drive in a different computer, install it, then put it into the laptop? Hopefully that makes sense.

 

@DeimosChaos,
Your question makes perfect sense... The Linux install was completed entirely on the laptop, on the SSD drive with the Windows HDD removed (so the HDD was replaced by the SSD, Linux was installed via CD ROM, the SSD was then put into the caddy and the HDD was returned to it's original slot).
 

 

 

. . . Aspire 5750 . . . hard drive caddy . . . 480gb SSD drive . . Ubuntu Linux . . . "resident" HDD, I have Windows 7 . . .like to be able to . . . be given the choice of either booting . . .  Windows 7 or Ubuntu Linux . . .

 

. . . BIOS it only shows . . . Windows 7 hard drive . . . if I disconnect the Windows 7 drive . . . boots Ubuntu . . .

 

Pensive,

 

This may be an issue with the caddy.

 

Your HDD controller is probably set for AHCI mode, in the notebook BIOS.

Because of that, it will ignore the caddy, which is basic IDE.

In order to see the drive in the caddy, you may have to run the controller in IDE mode.

 

The reason that the notebook boots without the main drive, is that it goes into a fall back mode, and boots from the first available device.

 

However, if you change your controller to IDE mode, your Windows 7 may not boot properly.

 

In some BIOS's you can set the controller to "compatibility" mode, which should detect which kind of drive is connected to it.

 

Hope this helps.

 

Cheers!

 

Naught.

 

 

@Naughty McNoone,
 
Not sure where to begin with your response... I'm hoping some of what I've mentioned above goes some way towards giving you information that might help.
 
Thought it might be useful to show you the BIOS screens on my machine... See the following (stored in my dropbox):

 

BIOS Information Screen

BIOS Main Screen

BIOS Boot Screen


Edited by Pensive_By_Nature, 24 September 2015 - 08:39 PM.

Pensive By Nature

#7 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:07 AM

Posted 24 September 2015 - 08:55 PM

Hmm, so looks like your laptop just doesn't want to recognize your hdd in the CD/DVD bay... I found this post and it mentioned having the AHCI enabled in bios, which you do... unfortunately I do not know a ton about this. Hopefully some other folks have some other suggestions.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#8 Pensive_By_Nature

Pensive_By_Nature
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:10:07 AM

Posted 24 September 2015 - 08:59 PM

Hi DeimosChaos, correction, it's the SSD in the CD/DVD Drive bay / Caddy. I'll check out the link, thanks for responding all the same.


Pensive By Nature

#9 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:07 AM

Posted 24 September 2015 - 09:03 PM

Hi DeimosChaos, correction, it's the SSD in the CD/DVD Drive bay / Caddy. I'll check out the link, thanks for responding all the same.

SSD is what I meant, haha. Either way it wouldn't matter though. The only other thing I can think of is maybe a bios update will help it, but I would use that as a last resort.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#10 Al1000

Al1000

  • Global Moderator
  • 7,979 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:07 AM

Posted 25 September 2015 - 06:08 AM

@Al1000,
In response to the visibility of the SSD, please see what I wrote above to NickAu.
Regarding the Linux Bootloader and MBR, this sounds like where I want to be, however, I would need some guidance as to how to perform the "sudo fdisk -1" action. I'm not not very experienced with Linux Command Line.

There's not much point right now, since as both drives are detected from Windows as per your speccy output, it's safe to assume they would both be detected by Linux too.

1. HDD : WDC WD7500BPVT-22HXZT1
2. ATAPI CDROM :
3. USB HDD :
4. USB FDD :
5. USB CRROM :
6. Network boot : BRCM MBA Slot 0200 v14.4.5

Since you replaced the CD drive with the SSD, have you tried moving "ATAPI CDROM" to the top of the list, save and exit BIOS, to see if the computer boots into Linux?

#11 Pensive_By_Nature

Pensive_By_Nature
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:10:07 AM

Posted 25 September 2015 - 06:40 AM

Good Afternoon Al,

I'll try that now and report back...


Pensive By Nature

#12 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,570 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:08:07 PM

Posted 25 September 2015 - 06:52 AM

@ Al and Demios.

 

If that don't work. I wonder. Swap the drives around, and see if it boots Linux first. Put the SSD where the HDD is and vice versa?

 

Then we can update grub.


Edited by NickAu, 25 September 2015 - 06:52 AM.


#13 Al1000

Al1000

  • Global Moderator
  • 7,979 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:07 AM

Posted 25 September 2015 - 07:16 AM

My original idea was to "chroot" into the SSD from a live CD/DVD/USB and then install Grub to the MBR of the HDD, but I'm apprehensive about that now in case it renders the computer unbootable if the BIOS is unable to read the SSD, since that's where the Grub files are.

But if there is a way to get the computer to boot into Linux with both drives plugged in, then we can leave Grub on the MBR of the SSD, and simply update it so that it detects the Windows installation as you suggest.

Swapping the drives around might work, if they fit.

#14 Pensive_By_Nature

Pensive_By_Nature
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:10:07 AM

Posted 25 September 2015 - 07:34 AM

So, as stated above, my boot order in the BIOS was as follows:

 

 

1. HDD : WDC WD7500BPVT-22HXZT1
2. ATAPI CDROM :
3. USB HDD :
4. USB FDD :
5. USB CRROM :
6. Network boot : BRCM MBA Slot 0200 v14.4.5
 

As suggested, I went back into the BIOS and first swapped position 1 and 2. Rebooted - Windows loaded.... (no change).

So then I shut down and booted back into the BIOS to see if putting the HDD in position 6 would yield any differences..... YES! The following boot sequence loaded:

 

Broadcom UNDI PXE-2.1 v14.4.5

Copyright © 2000-2010 Broadcom Corporation
Copyright © 1997-2000 Intel Corporation
All rights reserved.
PXE-E61: Media test failure, check cable
PXE-M0F: Exiting Broadcom PXE ROM
 
.... Then Windows loaded again.
 
Next, I will try physically switching the drives as suggested, to see if that has any impact.
I'll report back later as I'm working at the moment and can't do it right now.

 

Thanks to all for your continued help and suggestions. Really appreciate it.


Pensive By Nature

#15 Al1000

Al1000

  • Global Moderator
  • 7,979 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:07 AM

Posted 25 September 2015 - 08:12 AM

Broadcom UNDI PXE-2.1 v14.4.5
Copyright © 2000-2010 Broadcom Corporation
Copyright © 1997-2000 Intel Corporation
All rights reserved.
PXE-E61: Media test failure, check cable
PXE-M0F: Exiting Broadcom PXE ROM


It looks like this might have been the computer trying to boot from the (non-existent) "network."

It might also be helpful to see what the boot menu in the BIOS looks like with the HDD disconnected.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users