Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Analog stick problems


  • Please log in to reply
5 replies to this topic

#1 Harker1

Harker1

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 17 September 2015 - 10:19 PM

I'm having a problem with my controller. It seems like it's mostly working entirely, except for the right analog stick. When I go to the properties menu for the controller, I can see the computer acknowledging which way it's tilted, same as with the left one. But when I try to play a game with it, Tomb Raider, for example, though I've tried it with Portal 2 and Jet Set Radio, it doesn't move the camera at all. Every other button works fine, even the left analog.

I'm using Windows 7 Pro on a new PC, with a Mayflash Wii classic controller adapter. Googling it, it seems like a common problem with a lot of controllers. But nothing I've found so far works. I've tried x360ce (which, again, could tell when I was turning the stick just fine), I've changed the OEM name in the registry, I've rebooted several times, I've screwed around with the properties, I've done several more things that I can't even remember right now, and it still doesn't do anything in a game.



BC AdBot (Login to Remove)

 


#2 Gorbulan

Gorbulan

  • Members
  • 832 posts
  • OFFLINE
  •  
  • Local time:03:40 AM

Posted 18 September 2015 - 12:29 AM

Does the right stick on the Wii classic controller work on a Wii or another computer?



#3 Harker1

Harker1
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 18 September 2015 - 01:18 AM

Sure does. Double checked it on the Wii before I posted. Everything else is working fine, except that no game will recognize it for camera/aiming. There was even one point when I was screwing around that I had it functioning the same as the left too, so they would both move the character around.



#4 Gorbulan

Gorbulan

  • Members
  • 832 posts
  • OFFLINE
  •  
  • Local time:03:40 AM

Posted 18 September 2015 - 10:07 AM

Did you try the Mayflash adapter on a different computer?



#5 Harker1

Harker1
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 19 September 2015 - 03:23 AM

Huh, that's bizarre, I tried it on my laptop, and it worked the same as on the desktop, everything works under properties. Tried it in TR, nothing, but tried Portal 2 instead and it moved the camera up and down, but turning it left and right shot portals, instead of a button doing that.



#6 Gorbulan

Gorbulan

  • Members
  • 832 posts
  • OFFLINE
  •  
  • Local time:03:40 AM

Posted 19 September 2015 - 10:49 AM

Is it plugged into a USB 2.0 port or a USB 3.0 port?

 

Try it in a USB 2.0 port if it is not already in there. If that does not change anything then your device may be bad. Looking at other people's reviews of the adapter it seems sometimes there are duds which press buttons randomly, perform multiple presses on one thing, or swap functions (like you described.).

 

I have an PS3 Controller>PC adapter by Mayflash. If I leave it in DInput mode instead of XInput it will stall my computer at boot, and only my computer. I also got a Mayflash DolphinBar for my Wiimote and stuff, but the first one died unexpectedly. The IR bulbs just stopped working. Amazon replaced it, and it leaves me understanding why Mayflash stuff is so cheap.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users