Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

RDP into server to lan connected PC


  • Please log in to reply
16 replies to this topic

#1 DavoP

DavoP

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 14 September 2015 - 09:06 PM

Hi...thanks for your time looking at this request.

 

I am able to remote desktop into our server here at work from home no problems.

 

My Question is how do I RDP into my PC at work which is behind a router.

 

We have seven PC's connected through a router to a main server (2008R1) we all remote desktop into the server from our workstations.

 

 

It's not a simple as remote into the server from home then remote from the server to my work computer?

 

Any assistance would be appreciated.

 

Cheers



BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 14 September 2015 - 09:53 PM

the work router would need the rdp port forwarded to your workstations static ip.

it would need to be a different port than the one the server is using

you would need to edit your workstations rdp listening port

 

you should be able to rdp to your workstation from the server unless there is a policy preventing this access



#3 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:09:01 AM

Posted 15 September 2015 - 12:20 AM

If it's a terminal server, it will depend on how the RD gateway, VPN, and group policies are setup.

Edited by Sneakycyber, 15 September 2015 - 12:21 AM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#4 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 15 September 2015 - 02:17 AM

Thanks for the reply guys. I'm pretty much up on computers but networking well ... I'm lost. We are running Windows Server 2008R2 and my client machine is Windows home Premium which has been patched to allow RDP and is currently listening on port 3389. I changed the port in the registry on my client machine to 3399 thinking this might be the problem. Tried port triggering in the modem config to that port. Still nothing. Clearly I'm missing some vital things and thinking I might need to hire a tech to come and get it running for me :(

The setup here is seven workstations and the Windows Server 2008R2 plug into a 24 port switch along with the modem that connects us to the outside. The modem is a Netgear DGND3700v2 if this helps at all. I've tried login into my own client from another computer on the same network thru the server (RDP to the server) place my local ip address in & put my credentials in and get no error just nothing.... it's as if it logs in but doesn't if that makes sense.

 

Thanks again if your able to lend assistance with some guidance to get this working.

 

Cheers



#5 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 AM

Posted 15 September 2015 - 08:46 AM

It has been a while since I set up my server at home but my mind is saying there is something about IP addresses allowed to access the server through RDP. It's a setting on the server but I seriously could be remembering that wrong. Try port forwarding rather than trigggering. Just be careful, RDP isn't the most secure out the box.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#6 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 15 September 2015 - 09:58 AM

" I've tried login into my own client from another computer on the same network thru the server (RDP to the server) place"

 

RDP is one to one.  What you describe above is not one to one but one to two.  RDP doesn't work that way.

 

Before you involve remote access you want to be successful locally with RDP.

If you logon to the server can you rdp to your workstation?

if you logon to another workstation can you rdp to your workstation?

 

Once you can do those successfully we can work on changing your listening rdp port and add the correct port forwarding to the static ip of your workstation



#7 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 15 September 2015 - 08:00 PM

HI Wand3r3r

 

Thanks for the reply. I haven't been able to do that locally as yet. I changed the listening port on my workstation. I try to log on via another workstation and it accepts the user name and password I have assigned but it just doesn't connect. Clearly missing something

 

Cheers



#8 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 15 September 2015 - 10:50 PM

When you connect are you doing ipaddress:port number or hostname:port number?



#9 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 15 September 2015 - 11:00 PM

ipaddress:port number



#10 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 15 September 2015 - 11:11 PM

Just tried hostname:port number made no difference



#11 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 16 September 2015 - 10:48 AM

ipaddress:port number is correct. 

 

What port number are you using?

 

What OS version are you running on your workstation?

 

port allowed /rdp allowed in the workstations firewall?



#12 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 16 September 2015 - 05:48 PM

ipaddress port number correct I even tried changing the port number in the registry thinking on 3389 there may ahave been a conflict. I'm running Windows Home Preimum which I have run Microsoft.Windows.7.SP1.RDP.Concurrent.Sessions.Enabler.MULTI-NA on and it tells me it's listening. as far as the firewall on this PC I enabled a rule to allow a particular user in one a particular port, both 3389 & 3399.



#13 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 16 September 2015 - 06:00 PM

Do you have access to the company router?

 

You should be using only 3399 as your listening port so as not to have a conflict.

 

Since RDP is not native to this version, and there have been reports of it still not working even after SP1, I am beginning to suspect the issue is with your workstation.



#14 DavoP

DavoP
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 16 September 2015 - 06:19 PM

I have run Netstate with the -a switch and shown below are the instances of 3399

 

 Proto  Local Address          Foreign Address        State
 TCP    0.0.0.0:135            Davo-PC:0              LISTENING
 TCP    0.0.0.0:445            Davo-PC:0              LISTENING
 TCP    0.0.0.0:554            Davo-PC:0              LISTENING
 TCP    0.0.0.0:2869           Davo-PC:0              LISTENING
 TCP    0.0.0.0:3399           Davo-PC:0              LISTENING
 TCP    0.0.0.0:5357           Davo-PC:0              LISTENING
 TCP    0.0.0.0:8000           Davo-PC:0              LISTENING

and further down the list

TCP    192.168.20.10:51168    216.134.217.31:http    TIME_WAIT
TCP    192.168.20.10:51169    216.134.217.31:http    TIME_WAIT
TCP    192.168.20.10:51170    216.134.217.31:http    TIME_WAIT
TCP    [::]:135               Davo-PC:0              LISTENING
TCP    [::]:445               Davo-PC:0              LISTENING
TCP    [::]:554               Davo-PC:0              LISTENING
TCP    [::]:2869              Davo-PC:0              LISTENING
TCP    [::]:3399              Davo-PC:0              LISTENING
TCP    [::]:5357              Davo-PC:0              LISTENING

 

Don't quite understand the 0.0.0.0 part or the [::] bit

 

Yes I have access to the modem which is pluged into the router



#15 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 16 September 2015 - 06:28 PM

"Yes I have access to the modem which is pluged into the router"

 

You can't port forward in a modem.  I suspect you mean modem router combo unit which would infer you have two routers in series doing double NAT.

You would need access to both to do port forwarding to your workstation assuming we can get RDP to work on your workstation.

 

It does appear RDP is running and listening on port 3399

 

:: is ipv6

0.0.0.0 is all local addresses on the machine [its shorthand]






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users