Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Chrome as default browser


  • Please log in to reply
12 replies to this topic

#1 ghost whistler

ghost whistler

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 13 September 2015 - 10:18 AM

I cannot select Chrome to be the default on Windows 8.1.

 

It doens't appear in the list of default programs and selecting the option within to make it default browser just brings up a list of programs to choose from that doesn't include Chrome.



BC AdBot (Login to Remove)

 


#2 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:48 PM

Posted 13 September 2015 - 11:13 AM

Have you tried changing it while in Chrome?

Click the 3 horizontal bars on the far right of the address bar.

Choose Settings/Show Advanced Settings at the bottom of the Settings page.

Scroll down for the option to make Chrome the default browser.

Edited by Queen-Evie, 13 September 2015 - 11:15 AM.


#3 ghost whistler

ghost whistler
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 13 September 2015 - 11:25 AM

Tried that, doesn't work

 

It just lists the browsers i already have (firefox nd IE) but not Chrome.



#4 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:48 PM

Posted 13 September 2015 - 12:30 PM

When I look at Settings in Chrome the only thing I see is this, no mention of other browsers
10fPsHa.png

What I see when I go to Control Panel/Default Programs/Set program access and computer defaults/Custom
aso1aGR.png

I also see Chrome in Non-Microsoft in the Web Browser field. Using the drop-down arrow next to that
gives me a choice for SeaMonkey and Chrome. IE is not listed because it is a Microsoft browser.

If nothing gives you the option of setting Chrome as the default browser, your only option may be to uninstall Chrome and reinstall.

When installing, the first screen should be this and you can check the box to make it the default browser. If you have bookmarks in Chrome you might want to back them up before uninstalling. Follow the directions here https://support.google.com/chrome/answer/96816?hl=en for exporting bookmarks. After Chrome is reinstalled, go back to it for instructions on importing them back to Chrome.


E1vx2dh.png

Chrome is not my default browser. I only have it installed so I can answer questions about it.
Every time I open up Chrome, I see a yellow bar at the top of the page telling me it is not the default and gives 2 options. Set as default and Don't ask again. I need to choose don't ask because I don't want it as the default.

Edited by Queen-Evie, 13 September 2015 - 12:35 PM.


#5 ghost whistler

ghost whistler
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 13 September 2015 - 01:16 PM

Ok, I said Windows 8.1, i'm not sure what OS you are using there.

 

When i click to set Chrome as teh default browser in the settings option it causes Windows to open a list of programs which are IE and Firefox. It doesn't allow me to choose anything else.

 

If I go into the Control Panel the default programs option brings up a list of installed software and allows me to choose what to use it for. Again Chrome is not on that list. The window you have a picture of above I do not recognise from Windows 8.1 at all.

 

I tried selecting to make the default browser when first installing as well. That didn't work either.



#6 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:48 PM

Posted 13 September 2015 - 05:16 PM

The screenshots I posted were taken from a Windows 7 system.

 

I was able to access a computer with Windows 8.1.

 

What I saw in 8.1 was the exact same thing as what I see in Windows 7.



#7 ghost whistler

ghost whistler
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 14 September 2015 - 03:12 AM

Ok, let me try again.

 

When I click to make Chrome the default browser a windows message appears asking me how I want to open HTTP files. It gives me the choice of using my current default, which is firefox, or using IE.

 

It doesn't matter waht I do with Chrome, this is what happens.

 

If I go into the Control Panel the Default Programs option brings up a list of programs on the left and allows me to associate them as I please. Chrome is not in that list.

 

The screen you have shown above does not exist in Windows 8.1 at all.



#8 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:48 PM

Posted 14 September 2015 - 09:22 AM

If no luck whatsoever with all of the above from Queen-Evie, which should normally work, try saving the following registry fix to your desktop.

 

ChromeDefaultFix

 

Unzip the fix and extract the .reg file to the desktop. Double-click it to merge it to the registry. Note that you need to be an Administrator to apply this fix.

 

Restart the computer.



#9 ghost whistler

ghost whistler
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 14 September 2015 - 10:34 AM

Didn't work.

 

Windows still doesn't list Chrome as a program in the Default list, and selecting to make it the default browser from inside Chrome just brings up the menu which still doesn't include it.



#10 Phantom010

Phantom010

  • Members
  • 1,022 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyberspace
  • Local time:03:48 PM

Posted 14 September 2015 - 10:35 AM

You did restart the computer, right?

 

 

And did you try uninstalling and reinstalling the latest version of Chrome, as suggested by Queen-Evie?


Edited by Phantom010, 14 September 2015 - 10:44 AM.


#11 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:48 PM

Posted 14 September 2015 - 10:50 AM

I was also about ask if uninstall/reinstall was tried. That is the best and quickest thing to try.

Where did you download Chrome from?

#12 ghost whistler

ghost whistler
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Local time:08:48 PM

Posted 14 September 2015 - 11:04 AM

From the official source, i've also tried installing/reinstalling multiple times. Yes i restarted the computer.


Edited by ghost whistler, 14 September 2015 - 11:07 AM.


#13 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:48 PM

Posted 14 September 2015 - 08:52 PM

When I click to make Chrome the default browser a windows message appears asking me how I want to open HTTP files. It gives me the choice of using my current default, which is firefox, or using IE.


Try this to see if Chrome is listed if you have not already done this.

Open Control Panel/Default Programs.

Select Associate a file type or protocol with a program

Scroll down to Protocols

Double click HTTP

Is Chrome listed as an option? If so, select it and then click OK.

If Chrome is there check HTTPS and change if necessary.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users