Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win 10 "File History" suddenly won't recognise ext. HDD


  • Please log in to reply
3 replies to this topic

#1 Itchy01

Itchy01

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:08:08 AM

Posted 12 September 2015 - 09:55 PM

Hi all

I'm not sure which sub-forum this should go on so, mods, feel free to move. I have two Toshiba Satellite laptops, one old, one new, both running Win 10 Home installed via the recent upgrades.

Until yesterday, 12/09/15, I used to be able to do a "File History" backup from the new laptop to a WD Ext HDD 1021 USB Device (a 4TB unit). I also backup my Norton to that drive, AND, I also backup from the old laptop to the same drive (both Norton and File History).

To avoid confusion among the two computers' backup files (backups can only be done to the HDD, not specific folders on it), I move the backup-generated files and folders into named user folders. After each backup, I would delete the old contents of each user folder, and replace them with the new backup items.

Yesterday, there was a Windows Update (details of which I mention below in case they are relevant). I also did both a Norton backup and a File History backup from the new laptop to the 4TB Ext. HDD. To save time (why do I always do these things?) while one backup was running (being a thicky, I can't remember which) I deleted the "other" backup content from the relevant user folder. (i.e., if it was a File History backup I was running, then I was deleting the Norton items. If a Norton backup was running, then I was deleting the File History folder).

Either way, a box pops up saying two actions are running simultaneously and shows them. Then one stops - I didn't notice which one.

 

Afterwards, I noticed the File History backup hadn't apparently succeeded as the "Last Backup" date was in August. I tried to run it and found I couldn't. A bit more investigation and I realised my new laptop's Win 10 wasn't recognizing the 4TB HDD as a "usable drive" now. After a few shutdowns and reboots (always turn it off and on - sometimes works) and a bit more investigation (see attached pdf below with screenshots) the situation's the same.     

 

NB - I can still - no probs - backup Norton to the 4TB HDD, and File History will recognize my old HDD (WD My Pavilion) and backup to that. It recognized and tried backing up to a usb stick also.

Re the Win update (new laptop) - it had seemed a bit funny - UPDATE HISTORY shows:

Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2 x64 Edition - September 2015 (KB890830) Successfully inastalled 12/09/15 (after hiccup) and...

Cumulative Update for Windows 10 for x64-based Systems (KB3081455) Twice failed to install 12/09/15, PBOBABLY BECAUSE it had successfully installed 9/09/15!

So,

(1) was it me and my stupidity in running those two actions together? (and maybe killing a registry entry or a Win 10 system file?) Or could it have been the Win 10 download? AND, of course,
(2) how can I get my new laptop/Win 10 to again recognize a previously recognized HDD? All is not lost if a solution can't be found - after all, I am still allowed to backup to the old HDD. COMMENT, The only difference I could see is the old WD HDD is FAT32 and the new 4TB one is NTFS. Still, it used to run ok.

Many thanks

Itchy 01

Attached Files



BC AdBot (Login to Remove)

 


#2 Itchy01

Itchy01
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:08:08 AM

Posted 14 September 2015 - 12:16 AM

OK

 

Nobody replying must mean something. As it happens, problem solved :) . Unfortunately, I'm not the most systematic and observant person so I can't remember how I did it but here's a vague outline for anyone interested.

 

The upshot had been that, after some real or imagined action on my part (or Win 10's part), one of my computers decided not to recognize the ext. HDD it had been happily backing up "File History" to. I was able to back up, however, to an older ext. HDD.

 

After a lot of pointless mucking around (and checking this page) I tried the following. I plugged in the old HDD - a WD "My Pavilion". On first opening Settings, it wasn't recognized as a "usable" drive but after a few reopenings of Settings, it was acknowledged. Then,seeing on the File History page (Control Panel > System and Security > File History) that the "Turn On/Off" button was now active, I unplugged the old "My Pavilion" and plugged in the new 4TB HDD. The Control Panel's File History page told me no "usable drives" had been detected.

 

At this point I went on an explore of Control Panel (sorry, can't remember what I clicked and where I went) and ended up back at File History. I may have clicked on the "Turn On" button and done a "Search for Drive" before I left the page to go exploring - I just can't remember now. Anyhow, point is when I got back, F: had been detected as a usable drive and I promptly did a backup to celebrate. The Win 10 "Settings > Update & Security > Backup > More options" now looks the way I think it ought to.

 

The above is all very vague but at least suggests Control Panel and a bit of waiting will solve the problem I had. Hope it points any other desperate persons in the right direction.

 

Cheers

 

Itchy01



#3 technonymous

technonymous

  • Members
  • 2,472 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:08 AM

Posted 14 September 2015 - 08:38 AM

Not sure exactly what happen either. Part of it may be that you are constantly moving the drive back and forth between machines. A HD in an enclosure, files can become corrupt just as easily as one without an enclosure. Need to find a network solution and mount it permanently. The history section you speak of: (Control Panel | System and Security | File History) clicking on the right side "Select Drive" from there you can choose to use a network drive that you have mapped. However, doing network backups you are limited by the network wifi/wired speeds. Your 4TB HD reads/writes approx 75-175Mbytes a sec. It cannot take the advantages of the full speeds of USB 3.0 or the internal SATA 3 IO bus anyways. You have to get into SSD to get better speeds. A full 1Gbit wired network is about 125 MBytes sec transfer speed. The network would be a better solution than moving/swapping a USB 4T hd constantly. Better solution is to mount the hd to a router that has a USB 3.0 port and map it. Moving a hd around like that IMO is just to painful. lol Majority of Windows users moved on from using Microsoft Backup.



#4 mdm001

mdm001

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:08 AM

Posted 31 May 2017 - 08:17 PM

The file backup and file history functions are related.  If you go to settings / update & security / backup / more options and click "stop using drive" (down at the bottom if you have defined a large number of folders to backup) and you will disable the old drive.  After that there is a link right in the same page labeled "advanced settings" that takes you right to file history settings and you should see that the drive is now usable.  You can then click "turn on" and it will start your file history again.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users