Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop Battery Not Charging but Plugged In


  • Please log in to reply
4 replies to this topic

#1 akcorp2003

akcorp2003

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:56 PM

Posted 09 September 2015 - 05:13 PM

Hello everyone!

 

Just today, I turned on my laptop and the battery is refusing to charge even though it is plugged in! As I looked around online, it seems like this is a pretty common problem...

 

My computer is a Dell Insprion 15R N5110 dual-booting Windows 7 and Windows 10. The battery is original from manufacturer (haven't changed it since I bought the laptop). My laptop is 3 years old. This "plugged in , not charging" statement appears on both Windows 7 partition and Windows 10 partition.

 

What I have tried so far are:

  1. Changing power outlets
    1. Still can't charge
  2. Removing battery and uninstalling the Microsoft AC Adapter and Microsoft ACPI-Compliant Control Adapter on either Windows 7 and Windows 10 partitions
  3. Removing battery without uninstalling any drivers
    1. Sometimes the battery charges, sometimes not, but oftentimes it doesn't charge.

I don't think it's the adapter problem as it's glowing blue and it's pretty new as well (1 year old since the last adapter went kaput).

 

Here's the weird thing: whenever I uninstall the ACPI and AC Adapter drivers, shut the computer off, and reinstall the battery, the battery light comes on for a minute or so and goes dark again. After booting into Windows, I notice that the battery gained around ~1-3% charge. 

 

Also, before this incident happened, Windows ran a check disk and my battery stopped charging... I'm not sure if it's a coincidence or that check disk actually did something wrong to the battery drivers/hardware.

 

Can someone diagnose this problem for me? Is it a software/driver problem or is it a hardware problem? I greatly appreciate any support!! Thank you in advance! :)



BC AdBot (Login to Remove)

 


#2 Darktune

Darktune

    Very Purple


  • Members
  • 1,139 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales
  • Local time:12:56 AM

Posted 09 September 2015 - 05:55 PM

Hello akcorp2003,

When the charger is plugged in what does the battery icon show?

 

Regards

 

Darktune


It's very hard to imagine all the crazy things that things really are like. 

Electrons act like waves.. no they don't exactly, they act like particles.. no they don't exactly.

Words and ideas can change the world.


#3 akcorp2003

akcorp2003
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:56 PM

Posted 09 September 2015 - 06:01 PM

Hello Darktune!

 

Thanks for replying!

 

The icon shows the standard "plugged in with battery" icon (power plug with battery beside it) and of course, the bar inside the battery icon isn't all the way up.



#4 mjd420nova

mjd420nova

  • Members
  • 1,824 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:56 PM

Posted 10 September 2015 - 12:05 PM

The connector that the AC adapter plugs into is very prone to jamming.  Inside the little connector is a small switch and if it fails, the adapter will run the unit but not charge.  New units like yours and especially Dell units, have a dual voltage adapter, one for charging and one for running the unit.  Some units also have a small board the connector is mounted to and it can create the identical fault when it fails.



#5 dannyboy950

dannyboy950

  • Members
  • 1,338 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:port arthur tx
  • Local time:05:56 PM

Posted 10 September 2015 - 02:41 PM

The batterys on all of my hp laptops quit chargeing after 3 yrs. Hp says that that is the normal battery like for that type of battery.

You can run the PC onit but the battery won't charge. I ran the Vista computer another 2 yrs after the battery was dead.

That may or may not be your issue. I do know on mine a digital voltmeter say it is dead dog. Less than 1.3 v.


HP 15-f009wm notebook AMD-E1-2100 APV 1Ghz Processor 8 GB memory 500 GB Hdd

Linux Mint 17.3 Rosa Cinamon





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users