Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer won't boot up,I use linux mint 17.2 I think it is hardware


  • Please log in to reply
14 replies to this topic

#1 jbander

jbander

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:06:19 AM

Posted 08 September 2015 - 04:54 PM

When I turn on the operating system and try to boot up my computer . It trys to load for a minute then I get this error-- The disk drive for /mnt/usb-generic_sd_reader_2004888-0:0 is not ready yet or not present.      OK I go into recovery mode and I get this -keys continue to wait,or press s to skip mounting or m for manual recovery-- I push s and it boots but I must be in recovery mode. Anyway the computer doesn't work well in this mode.


Edited by Chris Cosgrove, 08 September 2015 - 06:28 PM.
Moved from Internal hardware to 'Linux'


BC AdBot (Login to Remove)

 


#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:07:19 AM

Posted 08 September 2015 - 06:50 PM

It seems like it is trying to boot into a SD card reader... which unless you are tying to do, it should boot to the internal HDD. Go into the bios (usually by hitting one of the "F" keys during the very start of your computer bootup) and look at your boot order. Make sure you HDD is on the top of the list. I suspect that the SD card reader is on top and that is causing your boot issues.


Edited by DeimosChaos, 08 September 2015 - 06:51 PM.

OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 09 September 2015 - 11:42 AM

The outputs of the below commands may aid those who attempt to help you. Please consider running them, and sharing the outputs.

Command #1:

cat /etc/fstab
(This command will display the contents of your fstab. The fstab defines which partitions are mounted at boot.)
Command #2:
sudo parted -l
(This command uses elevated privilidges! This command will list your drives and partitions.)
Command #3:
sudo blkid
(This command uses elevated privilidges! This command will list the UUIDs for all partitions.)

#4 jbander

jbander
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  

Posted 09 September 2015 - 12:37 PM

Your right it was the last line of the fstab, I took it out and my computer boots up now, thank you all. I'm amazed at the help you can get in these forums it has changed the world. My world any way.



#5 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:06:19 AM

Posted 09 September 2015 - 12:56 PM

Your right it was the last line of the fstab, I took it out and my computer boots up now, thank you all. I'm amazed at the help you can get in these forums it has changed the world. My world any way.

That makes sense. Glad you got it working!


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#6 mremski

mremski

  • Members
  • 493 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:07:19 AM

Posted 09 September 2015 - 03:28 PM

If you had that last line in there to make it easier to mount thing you put in the card reader, you can put it back then then add "noauto" to probably the 4th column.  Here's a sample from my fstab on a FreeBSD system (it's so I can easily mount a thumb drive):

/dev/da0s1   /flash2  msdos rw,noauto 0 0

 

That mounts the drive at /flash2, says it's a FAT32, mount it read/write but not automatically, the last 2 have to do with funning fsck, put them at 0 0 for noauto drives.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#7 jbander

jbander
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 09 September 2015 - 06:35 PM

If you had that last line in there to make it easier to mount thing you put in the card reader, you can put it back then then add "noauto" to probably the 4th column.  Here's a sample from my fstab on a FreeBSD system (it's so I can easily mount a thumb drive):

/dev/da0s1   /flash2  msdos rw,noauto 0 0

 

That mounts the drive at /flash2, says it's a FAT32, mount it read/write but not automatically, the last 2 have to do with funning fsck, put them at 0 0 for noauto drives.

This is the line I took out , do I need it?  /dev/disk/by-id/usb-Generic_USB_SD_Reader_2004888-0:0 /mnt/usb-Generic_USB_SD_Reader_2004888-0:0 auto nosuid,nodev,nofail,x-gvfs-show 0--------It didn't have a # in front of it. I think someone told me I didn't have to erase the line just put the # in front of it, Is that correct.

 

 

The outputs of the below commands may aid those who attempt to help you. Please consider running them, and sharing the outputs.

Command #1:

cat /etc/fstab
(This command will display the contents of your fstab. The fstab defines which partitions are mounted at boot.)
Command #2:
sudo parted -l
(This command uses elevated privilidges! This command will list your drives and partitions.)
Command #3:
sudo blkid
(This command uses elevated privilidges! This command will list the UUIDs for all partitions.)

 



#8 jbander

jbander
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:06:19 AM

Posted 09 September 2015 - 06:36 PM

Don't know how the bottom stuf was put on my reply .From hollowface.



#9 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:06:19 AM

Posted 09 September 2015 - 07:23 PM

 

If you had that last line in there to make it easier to mount thing you put in the card reader, you can put it back then then add "noauto" to probably the 4th column.  Here's a sample from my fstab on a FreeBSD system (it's so I can easily mount a thumb drive):

/dev/da0s1   /flash2  msdos rw,noauto 0 0

 

That mounts the drive at /flash2, says it's a FAT32, mount it read/write but not automatically, the last 2 have to do with funning fsck, put them at 0 0 for noauto drives.

This is the line I took out , do I need it?  /dev/disk/by-id/usb-Generic_USB_SD_Reader_2004888-0:0 /mnt/usb-Generic_USB_SD_Reader_2004888-0:0 auto nosuid,nodev,nofail,x-gvfs-show 0--------It didn't have a # in front of it. I think someone told me I didn't have to erase the line just put the # in front of it, Is that correct.

 

Putting a "#" in front of a line in most config files, comments out that particular line so it is skipped when the config file is read. So, yes you could just put a "#" in front of the line instead of deleting the line.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#10 mremski

mremski

  • Members
  • 493 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:07:19 AM

Posted 10 September 2015 - 02:35 AM

"Do you need it"?  Not sure, but if you want it there, uncommented, add "noauto," just before the "nosuid" so that reads "noauto,nosuid,nodev,nofail,x-gvfs-show".

 

automount is probably running by default, which would mean "maybe you don't need that".


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#11 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2015 - 11:33 PM

This is the line I took out , do I need it?


You could have commented it out by adding a "#" to the front of the line, but deleting it is fine too (it's not hosting part of your OS), though as mremski has pointed out, keeping the line (and setting it NOT to automount) might be desirable if you use that device often.

#12 jbander

jbander
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 10 September 2015 - 11:54 PM

 

This is the line I took out , do I need it?


You could have commented it out by adding a "#" to the front of the line, but deleting it is fine too (it's not hosting part of your OS), though as mremski has pointed out, keeping the line (and setting it NOT to automount) might be desirable if you use that device often.

 

Is this faulty line from my SD reader, if so I pulled the sd reader already



#13 Guest_hollowface_*

Guest_hollowface_*

  • Guests
  • OFFLINE
  •  

Posted 11 September 2015 - 12:15 AM

Is this faulty line from my SD reader, if so I pulled the sd reader already

 

It does appear to be from a card reader.


Edited by hollowface, 11 September 2015 - 12:15 AM.


#14 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 6,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA

Posted 11 September 2015 - 02:39 AM

jbander, you can always try a USB card reader, should you need one. :)

 

The reason why I do, is that I have a 2GiB SD card that I use for the sole purpose of creating Linux install media on, and works perfect in a USB 2.0 (or 3.0) card reader to install OS's fast. Whenever possible, I use this method for this purpose, to test drive, if haven't used a new OS & to install with & this can be used with other utilities bootable ISO's also. Such as backup/partition software, 

 

So while the one you removed may not be needed, you may find that in the future, you'll need a card reader & these are usually under $10 if purchased on sites such as Newegg. 

 

Good Luck! :thumbup2:

 

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#15 jbander

jbander
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:06:19 AM

Posted 11 September 2015 - 10:45 AM

jbander, you can always try a USB card reader, should you need one. :)

 

The reason why I do, is that I have a 2GiB SD card that I use for the sole purpose of creating Linux install media on, and works perfect in a USB 2.0 (or 3.0) card reader to install OS's fast. Whenever possible, I use this method for this purpose, to test drive, if haven't used a new OS & to install with & this can be used with other utilities bootable ISO's also. Such as backup/partition software, 

 

So while the one you removed may not be needed, you may find that in the future, you'll need a card reader & these are usually under $10 if purchased on sites such as Newegg. 

 

Good Luck! :thumbup2:

 

Cat

Thanks Cat


 

Is this faulty line from my SD reader, if so I pulled the sd reader already

 

It does appear to be from a card reader.

 

Thank you.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users