Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WinXP to Win2k - Registry/Kernel32 Errors?


  • Please log in to reply
3 replies to this topic

#1 ryanjerome07

ryanjerome07

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:23 PM

Posted 08 September 2015 - 02:30 PM

Ok so, I have a Dell Dimension 3000 that came with XP. Someone gave me the Desktop so I do not have the Software that came with it, only the code on the tower. & Of course Windows does not offer support for XP. One day I booted my PC and i could not get in, there was an issue with missing system folder. I do not recall exactly, but i did not have access to any type of CD to install XP or recover.. I was forced to install Windows 2000. So i am not really sure what I did wrong, I can only boot up and log in safe mode, i didnt erase anything when i did this because i didnt want to lose everything. I think it may be too late for that. I dont care though at this point I just want to be able to install programs & run other programs.

There is now a C:\WINDOWS & a C:\WINNT folder.. if I try to run anything out of the windows folder i get an Entry Point Error/Could not be found in dynamic link library. or "This cannot be run in Win32 Mode". Another when I tried to install AdbeRdr "The procedure entry point FindActCtxSectionStringW could not be found in the dynamic link library KERNEL32.dll."

I seem to remember seeing alot about Kernel32.dll when it comes to errors. So what is going on? my xp folders are not compatible now, something to do with NTSF? (Im not familiar with the data types) Or is it something like when i tell my computer to do something it is looking in the wrong folders to do it?

I do not have access to the Win2k CD I used, I do have the code still tho. & I heard u can make a cd from ur pc. But please some help me here, what do i need to do?

Heres some info: System: Microsoft Windows 2000 5.00.2195 Service Pack 4

Dell DImension 3000

Intel® Pentium

® 4 CPU 2.80GHz

AT/AT COMPATIBLE


Edited by hamluis, 08 September 2015 - 04:54 PM.
Moved from Win XP to Windows NT - Hamluis.


BC AdBot (Login to Remove)

 


#2 ryanjerome07

ryanjerome07
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:23 PM

Posted 08 September 2015 - 03:34 PM

Ok so I have a Dell DImension 3000 with Windows XP Home OEM. No disk. Started with a ntldr missing error & I couldnt log on. Had access to was a Windows 2000 Disk, which I installed and everytime I tried to run a program/install I got an error. "Could not be found in dynamic link library", or "Cannot run in Win32 Mode." They also ended in kernel32..

So I'm guessing I Installed it wrong? There are both Winnt & Windows folders when I explore... & I also suppose the software isn't right for my hardware/drivers. I'd REALLY Like to just go back to having the Original Windows XP. Make my Win2k Install as if it never happened. If that isn't possible, then let's try and get this Windows 2000 working.

 

SO:

I have two XP options and a Win2000 option when I boot, so,

WHEN I BOOT XP: Reinstall missing or currupt file: "<windows 2000 root>\system32\ntoskrnlexe" I Find it odd that I choose XP and there is a Windows 2000 file error.. Why?

 

WHEN I BOOT 2000: Blue screen. "Stop: c0000263 Driver Entry Point Not Found. The \SystemRoot\system32\drivers\drmk.sys device driver could not locate entry point "IoGetLowerDeviceObject" in driver ntoskrnl.exe.

 

SAFE MODE DOES WORK. I don't believe I have access to any disks right now, maybe a repair disk i'd have to ask to borrow. So guys, where do I start without a disk for now, what kind of questions do you have for me?

 

Mod Edit:  Merged topics - Hamluis.


Edited by hamluis, 08 September 2015 - 04:58 PM.


#3 JohnC_21

JohnC_21

  • Members
  • 24,619 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:23 PM

Posted 08 September 2015 - 03:48 PM

I think your only chance at this point other than doing a clean install is to see if you can do a System Restore in Safe Mode but only if Safe Mode gives you a XP desktop and not a Win 2000 desktop.

 

You said you had two xp options and one Win 2000 option. You listed one XP option. What was the other?



#4 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:23 PM

Posted 17 September 2015 - 11:45 AM

"So I'm guessing I Installed it wrong?"

 

Nope. Not your issue.  You are assuming, incorrectly, that you can run xp applications in Windows 2000.  Not all apps are W3K compatible.  They also have to be INSTALLED in W2K for them to run.  No registry entries means W2K doesn't know what to do with them.  You need to install these apps in W2K.

 

But I suspect you have hardware not software issues.  That unit is like 10 years old [manual has a 2005 date].  Unfortunately the recovery method you used only made a bigger mess.  You should have procured a Dell XP cd and driver disk.  Contact Dell or check Ebay.  You want to do a repair install of XP to get back to where you need to be assuming you don't have a hardware issue.

 

Folder not found directly relates to hard disk health and file system health.  If you never defragged the drive sever fragmentation can lead to the OS not being able to find all the pieces of the file it want to load into memory.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users