Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Network adapter does not appear


  • Please log in to reply
1 reply to this topic

#1 Simonster

Simonster

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:07:25 AM

Posted 08 September 2015 - 10:11 AM

History

 

My computer has been running fine since it was assembled several years ago.  At times there have been DSL problems, either at the supplier's end (Telmex) or bad telephone wiring, in all cases eventually resolved by them or me (additionally one problem I suspect was caused by a problem with Telmex's DNS servers, since when I have moved to Google ones, programmed into the modem).  In all such cases my browser has been able to see the modem's internal web page, and the relevant Windows network diagram has shown my computer connected to the home network but no connection from that to the internet.  

 

About two weeks ago I noticed that there was no internet connection.  In fact the diagram showed no connection from my computer to the modem/home network, which is not normally the problem when the DSL or phone line is down, but I didn't pay much attention to that because it had been raining and there are often one or more power/internet problems.  I was in no hurry to connect or deal with Telmex's technical support, often problems at the Telmex end just resolve themselves, so I left it a few hours before tackling it.  Before I did call, I asked my wife whether she had an internet connection, she said no, so I went through the process with Telmex technical support.  They like you to reset the modem and try the system without a filter and phone, both of which I did before calling (I also took the power off for some while, and tried a different power supply as the 2Wire power supplies frequently seem to fail (they blow their output capacitors).  We both tentatively concluded that the modem was connecting on the DSL side but had a problem on its ethernet side.  The technical support guy asked me to check network adapters in the device manager while I was on the phone to him, but none were shown, at which point he gave me a Telmex code number to get a replacement modem (I suspect he had run out of flowchart at this point).  

 

Before driving some way and standing in line to do that I borrowed a modem from a friend who usually has spares.  That was one he had recently bought, still in its box, and was not yet configured to connect to Telmex, but it did have lights on each ethernet connection to show when a device was connected.  Fiddling around (I eliminated the switch I use and two other computers) I noticed that the lights were not lighting up when I connected my computer, but did light up when I connected the switch or one of the other two computers.  At that point I became suspicious of the original diagnosis, thinking instead that perhaps the network hardware in my computer had just failed, so I reinstalled the original modem and the whole network worked fine, through to the internet, other than for my computer.  I tried a second cable on my computer without joy (I just tried again).  

 

I forget why, but during this I noticed an icon that seemed unfamiliar and somewhat klutzy on the right of the Windows bar at the bottom.  That was MSE, I might have agreed to its installation some while ago, I simply do not remember, but beside the klutziness it was entirely in Spanish.  I have a Spanish language version of Vista with an English language pack, which normally seems to translate about 50% of the menu items etc, and that made me wonder about whether this program was what it said.  Going to the security center I noticed that Defender was turned off.  Attempting to re-enable it didn't work, with either nothing happening or the items in the security center status window expanding for a fraction of a second then disappearing, with the security center window offering to turn Defender on eventually hanging.  That made me wonder whether some malware was sitting there and killing Defender every time it tried to start.  At that point I did some searches on "virus disables network adapter and Windows Defender", didn't see a whole lot, but ended up at the malware forum, posting here 

 

http://www.bleepingcomputer.com/forums/t/588462/network-adaptor-and-windows-defender-disabled/?view=getnewpost

 

nasdaq very kindly took me on and went though a number of items, also mentioning that MSE disables Defender, but has now suggested that I post in this forum.  I am profoundly ignorant of both hardware and software and I do not know whether my underlying problem is just a hardware problem, that I had lots of adware/malware, that MSE/Defender interaction is just a bit buggy, or whether there is still a malware problem.  I did borrow a network card from my modem-friend yesterday and can slot it in, but have held off doing so until instructed so as not to muddy the water.  I certainly appreciate the help provided in these forums and would be grateful for suggestions.  

 

Below is my computer configuration (I have connected the computer directly to the modem, in different ports, and also via the switch).  I try not to fiddle when not necessary as I just want to use it and for the most part it always runs OK.  I have also attached the output from MiniToolBox - it was kicking up a fuss about Unicode characters and ANSI, I guess due to some Spanish characters, so I saved ANSI and Unicode versions.

 

Best regards,

 

Simon

 

Make and model of computer

 

Gigabyte motherboard (GA-G41MT-S2)

No interface cards

How the computer is connected (wireless or wired)

 

Wired connection (3 metres)

Make and model of Router

 

2Wire

2701HG-T

Approximate Distance From the router the PC is if its a wireless connection

 

(Wired)

What type of internet you have (Dsl, Cable, T-1,etc..)

 

DSL

 

MiniToolBox output attached

Attached Files



BC AdBot (Login to Remove)

 


m

#2 Simonster

Simonster
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:07:25 AM

Posted 11 September 2015 - 12:51 PM

All now seems well after installing a network card and then Bitdefender.

 

Perhaps not of relevance, but I use Chrome and had noticed for some while that it was slow and showing DNS lookup errors which then resolved after a few seconds.  The Reuters main page would sometimes not load its formatting, but using internet explorer would always load it just fine.  Everything to do with Chrome got cleared out under your instructions, but Chrome was still just as boggy.  I went to the Windows control panel, changed the DNS settings from "get automatically" to use Google, then all of a sudden Chrome was very snappy indeed, a different animal.  I set my modem to use Google DNS a year or two ago (and I just checked it now) when I suspected there was a problem with the Telmex DNS servers it defaulted to, and that seemed to have resolved that problem, so I assumed that Windows was getting its DNS server from the modem, but if that were ,the case then the change I just made to Windows should not have changed anything.  Also possibly not relevant, but my wife was having internet access issues perhaps a month ago and I changed her Windows 7 computer to use Google DNS rather than to get the DNS server automatically.  I assume that interposing a mal DNS server could be used as a route of hijacking advertising space on web pages, and I wonder whether hijacking the "get DNS server automatically" functionality could be used to do that.  Or perhaps I am just paranoid/grasping at straws.

 

I very much appreciate the help from bleepingcomputer forums.

 

Regards,

 

Simon






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users