Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

error message


  • This topic is locked This topic is locked
9 replies to this topic

#1 RAMIA

RAMIA

  • Members
  • 329 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 AM

Posted 07 September 2015 - 11:09 AM

i wrote this to terminal

sudo bash -c "echo export MOZ_USE_OMTC = 1 >> /etc/X11/Xsession.d/90environment

from this

http://www.silicongadget.com/internet/browsers/enable-firefox-hardware-acceleration-on-linux/2791/

but

I got error message, why?


I am for peace

BC AdBot (Login to Remove)

 


#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:47 AM

Posted 07 September 2015 - 11:22 AM

This might just be a accidental typo on the forum and not the temrinal... but you are missing the closing quote ( " ) at the end of the command.

Should be:

sudo bash -c "echo export MOZ_USE_OMTC = 1 >> /etc/X11/Xsession.d/90environment"

Another thing, please post the error code. Just saying you got an error and not posting what the error exactly is doesn't help anyone at all. It could be a bunch of different things. When you can please post what the error was so we can further assist you.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 RAMIA

RAMIA
  • Topic Starter

  • Members
  • 329 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 AM

Posted 07 September 2015 - 11:30 AM

i Added 2 "  in practice.


Edited by RAMIA, 07 September 2015 - 11:50 AM.

I am for peace

#4 RAMIA

RAMIA
  • Topic Starter

  • Members
  • 329 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 AM

Posted 07 September 2015 - 12:00 PM

in message write

that to Reconnect to the os linux, i need to try to Change the Configuration, but it's not sloved this problem, way?


I am for peace

#5 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:47 AM

Posted 07 September 2015 - 12:20 PM

I am not sure what you are trying to say there.. sorry. Can you just copy and paste the error message you are getting into a reply please?


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#6 RAMIA

RAMIA
  • Topic Starter

  • Members
  • 329 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 AM

Posted 07 September 2015 - 01:32 PM

it's not possible to copy in this mode.

Because this mode that before enter to terminal.

& i not have smartphone.

& if get this message

i need to reinstall the os of linux,  Because i don't know how to slove this problem


Edited by RAMIA, 07 September 2015 - 01:51 PM.

I am for peace

#7 Al1000

Al1000

  • Global Moderator
  • 7,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:47 AM

Posted 08 September 2015 - 05:14 AM

You are trying to edit a file that doesn't exist. These instructions are probably for an older version of Firefox.

To enable hardware acceleration in Firefox try this:
 

Open about:config in Firefox (url bar)

Set layers.acceleration.force-enabled and layers.offmainthreadcomposition.enabled to true

http://askubuntu.com/questions/491750/force-enable-hardware-acceleration-in-firefox


Now open a terminal and run this command:
 
bash -c "echo export MOZ_USE_OMTC=1 >> ~/.profile"
Reboot your computer, open Firefox and you should find that hardware acceleration is enabled.

If you have any problems let us know, and we can undo these steps to disable hardware acceleration again.

#8 RAMIA

RAMIA
  • Topic Starter

  • Members
  • 329 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 AM

Posted 08 September 2015 - 07:58 AM

You are trying to edit a file that doesn't exist. These instructions are probably for an older version of Firefox.

To enable hardware acceleration in Firefox try this:
 

Open about:config in Firefox (url bar)

Set layers.acceleration.force-enabled and layers.offmainthreadcomposition.enabled to true

http://askubuntu.com/questions/491750/force-enable-hardware-acceleration-in-firefox


Now open a terminal and run this command:
 
bash -c "echo export MOZ_USE_OMTC=1 >> ~/.profile"
Reboot your computer, open Firefox and you should find that hardware acceleration is enabled.

If you have any problems let us know, and we can undo these steps to disable hardware acceleration again.

 

On the other computer, it's not halp me,

after i Login to os linux

i get message it write

that i need to try to Change the Configuration &, i can't to go to terminal to Run normal the linux.


I am for peace

#9 Al1000

Al1000

  • Global Moderator
  • 7,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:10:47 AM

Posted 08 September 2015 - 09:33 AM

At the log-in screen press Ctrl + Alt + F1 (hold down Ctrl and Alt and press the F1 key)

This will take you to a terminal session.

Enter your username then password when prompted to do so.

At the command prompt, type:
nano ~/.profile
Now you should see this:
 
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi
export MOZ_USE_OMTC=1
Using your directional keys and your backspace key, delete the last line "export MOZ_USE_OMTC=1" so that the file looks like this:
 
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi
Now type Ctrl + x (hold down Ctrl and press the x key)

Then type y

Press Enter on your keyboard.

Now you should be returned to the command prompt.

Now type:
sudo shutdown -r now
Your computer will reboot and you will be back to where you started.

Edited by Al1000, 08 September 2015 - 10:11 AM.


#10 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,384 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:07:47 PM

Posted 09 September 2015 - 05:20 PM

You went into about:config and changed these 2 lines?

layers.acceleration.force-enabled
layers.offmainthreadcomposition.enabled

screenshot-from-2015-09-10-08%3A19%3A38.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users