Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I keep Getting a SELinux Error.


  • Please log in to reply
9 replies to this topic

#1 lukexj

lukexj

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 01 September 2015 - 06:32 PM

Im on Fedora 22 64 bit, the error message i keep getting is http://imgur.com/CmoaaGgl.png If anyone can help me with this i would greatly appreacite it 

 

(Linux Newbie)



BC AdBot (Login to Remove)

 


m

#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,416 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:08:43 PM

Posted 01 September 2015 - 09:12 PM

When you get the error again click on "Details" and post that... not really much to go on other than you got an error.

 

Here is some info on SELinux.


Edited by DeimosChaos, 01 September 2015 - 09:13 PM.

OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 lukexj

lukexj
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 02 September 2015 - 04:34 AM

SELinux is preventing esmtp from read access on the file /.esmtp_queue/yRAIiFOU/mail.
 
*****  Plugin catchall_labels (83.8 confidence) suggests   *******************
 
If you want to allow esmtp to have read access on the mail file
Then you need to change the label on /.esmtp_queue/yRAIiFOU/mail
Do
# semanage fcontext -a -t FILE_TYPE '/.esmtp_queue/yRAIiFOU/mail'
where FILE_TYPE is one of the following: NetworkManager_tmp_t, abrt_helper_exec_t, abrt_tmp_t, abrt_upload_watch_tmp_t, abrt_var_cache_t, abrt_var_run_t, admin_crontab_tmp_t, afs_cache_t, alsa_tmp_t, amanda_tmp_t, anon_inodefs_t, antivirus_tmp_t, apcupsd_tmp_t, apmd_tmp_t, arpwatch_tmp_t, asterisk_tmp_t, auditadm_sudo_tmp_t, automount_tmp_t, awstats_tmp_t, bacula_tmp_t, bin_t, bitlbee_tmp_t, bluetooth_helper_tmp_t, bluetooth_helper_tmpfs_t, bluetooth_tmp_t, boinc_project_tmp_t, boinc_tmp_t, boot_t, bootloader_tmp_t, bugzilla_tmp_t, cardmgr_dev_t, ccs_tmp_t, cdcc_tmp_t, cert_t, chrome_sandbox_tmp_t, cinder_api_tmp_t, cinder_backup_tmp_t, cinder_scheduler_tmp_t, cinder_volume_tmp_t, cloud_init_tmp_t, cluster_tmp_t, cobbler_tmp_t, cockpit_tmp_t, collectd_script_tmp_t, colord_tmp_t, comsat_tmp_t, condor_master_tmp_t, condor_schedd_tmp_t, condor_startd_tmp_t, conman_tmp_t, couchdb_tmp_t, courier_exec_t, courier_spool_t, cpu_online_t, crack_tmp_t, cron_spool_t, cron_var_run_t, crond_tmp_t, crond_var_run_t, crontab_tmp_t, ctdbd_tmp_t, cups_pdf_tmp_t, cupsd_lpd_tmp_t, cupsd_tmp_t, cvs_data_t, cvs_tmp_t, cyphesis_tmp_t, cyrus_tmp_t, dbadm_sudo_tmp_t, dbskkd_tmp_t, dcc_client_tmp_t, dcc_dbclean_tmp_t, dccd_tmp_t, dccifd_tmp_t, dccm_tmp_t, ddclient_tmp_t, deltacloudd_tmp_t, devicekit_tmp_t, dhcpc_tmp_t, dhcpd_tmp_t, dirsrv_tmp_t, dirsrvadmin_tmp_t, disk_munin_plugin_tmp_t, dkim_milter_tmp_t, dnssec_trigger_tmp_t, docker_tmp_t, dovecot_auth_tmp_t, dovecot_deliver_tmp_t, dovecot_tmp_t, drbd_tmp_t, etc_aliases_t, etc_mail_t, etc_runtime_t, etc_t, exim_exec_t, exim_log_t, exim_spool_t, exim_tmp_t, exim_var_lib_t, fail2ban_tmp_t, fenced_tmp_t, file_context_t, firewalld_tmp_t, firewallgui_tmp_t, fonts_cache_t, fonts_t, fsadm_tmp_t, fsdaemon_tmp_t, ftpd_tmp_t, ftpdctl_tmp_t, games_tmp_t, games_tmpfs_t, gconf_tmp_t, geoclue_tmp_t, getty_tmp_t, git_script_tmp_t, gkeyringd_tmp_t, glance_registry_tmp_t, glance_tmp_t, glusterd_tmp_t, gpg_agent_tmp_t, gpg_pinentry_tmp_t, gpg_pinentry_tmpfs_t, gpm_tmp_t, gssd_tmp_t, hostname_etc_t, httpd_php_tmp_t, httpd_squirrelmail_t, httpd_suexec_tmp_t, httpd_tmp_t, inetd_child_tmp_t, inetd_tmp_t, init_tmp_t, initrc_tmp_t, ipsec_tmp_t, iptables_tmp_t, iscsi_tmp_t, kadmind_tmp_t, kdumpctl_tmp_t, kdumpgui_tmp_t, keystone_tmp_t, kismet_tmp_t, kismet_tmpfs_t, klogd_tmp_t, krb5_conf_t, krb5_host_rcache_t, krb5kdc_tmp_t, ktalkd_tmp_t, l2tpd_tmp_t, ld_so_cache_t, ld_so_t, ldconfig_tmp_t, lib_t, livecd_tmp_t, locale_t, logrotate_mail_tmp_t, logrotate_tmp_t, logwatch_mail_tmp_t, logwatch_tmp_t, lpd_tmp_t, lpr_tmp_t, lsassd_tmp_t, lsmd_plugin_tmp_t, lvm_tmp_t, machineid_t, mail_home_rw_t, mail_home_t, mail_munin_plugin_tmp_t, mail_spool_t, mailman_cgi_tmp_t, mailman_mail_tmp_t, mailman_queue_tmp_t, man_cache_t, man_t, mandb_cache_t, mdadm_tmp_t, mediawiki_tmp_t, mock_tmp_t, mojomojo_tmp_t, mongod_tmp_t, mount_tmp_t, mozilla_plugin_tmp_t, mozilla_plugin_tmpfs_t, mozilla_tmp_t, mozilla_tmpfs_t, mpd_tmp_t, mplayer_tmpfs_t, mqueue_spool_t, mscan_tmp_t, munin_script_tmp_t, munin_tmp_t, munin_var_lib_t, mysqld_tmp_t, nagios_eventhandler_plugin_tmp_t, nagios_openshift_plugin_tmp_t, nagios_system_plugin_tmp_t, nagios_tmp_t, named_tmp_t, net_conf_t, netutils_tmp_t, neutron_tmp_t, nova_tmp_t, ntop_tmp_t, ntpd_tmp_t, nut_upsd_tmp_t, nut_upsdrvctl_tmp_t, nut_upsmon_tmp_t, nx_server_tmp_t, openshift_cgroup_read_tmp_t, openshift_cron_tmp_t, openshift_initrc_tmp_t, openshift_tmp_t, openvpn_tmp_t, openvswitch_tmp_t, openwsman_tmp_t, pam_timestamp_tmp_t, passenger_tmp_t, passwd_file_t, pcp_tmp_t, pegasus_openlmi_storage_tmp_t, pegasus_tmp_t, piranha_web_tmp_t, pkcs_slotd_tmp_t, pki_tomcat_tmp_t, podsleuth_tmp_t, podsleuth_tmpfs_t, policykit_tmp_t, portmap_tmp_t, postfix_bounce_tmp_t, postfix_cleanup_tmp_t, postfix_etc_t, postfix_local_tmp_t, postfix_map_tmp_t, postfix_master_exec_t, postfix_pickup_tmp_t, postfix_pipe_tmp_t, postfix_postdrop_exec_t, postfix_postdrop_t, postfix_postqueue_exec_t, postfix_qmgr_tmp_t, postfix_showq_exec_t, postfix_smtp_tmp_t, postfix_smtpd_tmp_t, postfix_virtual_tmp_t, postgresql_tmp_t, pppd_etc_rw_t, pppd_etc_t, pppd_tmp_t, prelink_exec_t, prelink_tmp_t, prelude_lml_tmp_t, proc_t, procmail_exec_t, procmail_tmp_t, prosody_tmp_t, psad_tmp_t, pulseaudio_tmpfs_t, puppet_tmp_t, puppetmaster_tmp_t, qmail_inject_exec_t, qmail_spool_t, qpidd_tmp_t, racoon_tmp_t, realmd_tmp_t, rhev_agentd_tmp_t, rhsmcertd_tmp_t, ricci_tmp_t, rlogind_tmp_t, rolekit_tmp_t, rpcbind_tmp_t, rpm_script_tmp_t, rpm_tmp_t, rpm_var_run_t, rsync_tmp_t, rtas_errd_tmp_t, samba_etc_t, samba_net_tmp_t, samba_var_t, sblim_tmp_t, secadm_sudo_tmp_t, sectool_tmp_t, selinux_munin_plugin_tmp_t, semanage_tmp_t, sendmail_exec_t, sendmail_log_t, sendmail_tmp_t, services_munin_plugin_tmp_t, session_dbusd_tmp_t, sge_tmp_t, shell_exec_t, shorewall_tmp_t, slapd_tmp_t, smbd_tmp_t, smoltclient_tmp_t, smsd_tmp_t, snort_tmp_t, sosreport_tmp_t, soundd_tmp_t, spamc_tmp_t, spamd_tmp_t, speech-dispatcher_tmp_t, squid_tmp_t, squirrelmail_spool_t, src_t, ssh_agent_tmp_t, ssh_keygen_tmp_t, ssh_tmpfs_t, sssd_public_t, sssd_var_lib_t, staff_sudo_tmp_t, stapserver_tmp_t, stunnel_tmp_t, svirt_tmp_t, svnserve_tmp_t, swat_tmp_t, swift_tmp_t, sysadm_passwd_tmp_t, sysadm_sudo_tmp_t, sysfs_t, syslogd_tmp_t, system_conf_t, system_cron_spool_t, system_cronjob_tmp_t, system_db_t, system_dbusd_tmp_t, system_mail_tmp_t, system_munin_plugin_tmp_t, tcpd_tmp_t, telepathy_gabble_tmp_t, telepathy_idle_tmp_t, telepathy_logger_tmp_t, telepathy_mission_control_tmp_t, telepathy_msn_tmp_t, telepathy_salut_tmp_t, telepathy_sofiasip_tmp_t, telepathy_stream_engine_tmp_t, telepathy_sunshine_tmp_t, telnetd_tmp_t, tetex_data_t, textrel_shlib_t, tgtd_tmp_t, thumb_tmp_t, tmp_t, tomcat_tmp_t, tuned_tmp_t, tvtime_tmp_t, tvtime_tmpfs_t, udev_tmp_t, uml_tmp_t, uml_tmpfs_t, unconfined_munin_plugin_tmp_t, update_modules_tmp_t, user_cron_spool_t, user_fonts_t, user_mail_tmp_t, user_tmp_t, usr_t, uucpd_spool_t, uucpd_tmp_t, var_spool_t, varnishd_tmp_t, virt_qemu_ga_tmp_t, virt_tmp_t, vmtools_tmp_t, vmware_host_tmp_t, vmware_tmp_t, vmware_tmpfs_t, vpnc_tmp_t, w3c_validator_tmp_t, webadm_tmp_t, webalizer_tmp_t, wireshark_tmp_t, wireshark_tmpfs_t, xauth_tmp_t, xend_tmp_t, xenstored_tmp_t, xserver_tmpfs_t, ypbind_tmp_t, ypserv_tmp_t, zabbix_tmp_t, zarafa_deliver_tmp_t, zarafa_indexer_tmp_t, zarafa_server_tmp_t, zarafa_var_lib_t, zebra_tmp_t. 
Then execute: 
restorecon -v '/.esmtp_queue/yRAIiFOU/mail'
 
 
*****  Plugin catchall (17.1 confidence) suggests   **************************
 
If you believe that esmtp should be allowed read access on the mail file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep esmtp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp
 
Additional Information:
Source Context                system_u:system_r:system_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:default_t:s0
Target Objects                /.esmtp_queue/yRAIiFOU/mail [ file ]
Source                        esmtp
Source Path                   esmtp
Port                          <Unknown>
Host                          new-host.home
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.12.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     new-host.home
Platform                      Linux new-host.home 4.1.6-200.fc22.x86_64 #1 SMP
                              Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64
Alert Count                   235
First Seen                    2015-09-01 15:00:07 EDT
Last Seen                     2015-09-02 03:04:27 EDT
Local ID                      19c97b1f-9120-463d-a83c-2b3c48da0b90
 
Raw Audit Messages
type=AVC msg=audit(1441177467.55:864): avc:  denied  { read } for  pid=12261 comm="esmtp" path="/.esmtp_queue/yRAIiFOU/mail" dev="dm-0" ino=1441841 scontext=system_u:system_r:system_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=file permissive=0
 
 
Hash: esmtp,system_mail_t,default_t,file,read


#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,416 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:08:43 PM

Posted 02 September 2015 - 09:57 AM

So the very first line tells you your problem - "SELinux is preventing esmtp from read access on the file /.esmtp_queue/yRAIiFOU/mail."

 

Kind of a weird one as well... SELinux is preventing an application from read access on its own file. Very strange. You can try the two suggestions (under where it says "Do") and see if they help at all. The first one is a bit weird since there are a bunch of different "file types" that would have to be tried. I would try the second option and see if it helps. Also looking up this bug it seems to do with Chrome. If you have that installed try removing it and then re-installing it to see if it helps. When I get some more time I'll look back into this for you, currently at work and don't have the time at the moment.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 lukexj

lukexj
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 02 September 2015 - 02:23 PM

So the very first line tells you your problem - "SELinux is preventing esmtp from read access on the file /.esmtp_queue/yRAIiFOU/mail."

 

Kind of a weird one as well... SELinux is preventing an application from read access on its own file. Very strange. You can try the two suggestions (under where it says "Do") and see if they help at all. The first one is a bit weird since there are a bunch of different "file types" that would have to be tried. I would try the second option and see if it helps. Also looking up this bug it seems to do with Chrome. If you have that installed try removing it and then re-installing it to see if it helps. When I get some more time I'll look back into this for you, currently at work and don't have the time at the moment.

a few more errors for /.esmtp_queue/yRAIiFOU/mail. but the "/yRAIiFOU/ kept chaning so i kept doing the 2nd method a few more times and i hope that solved the problem 



#6 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,416 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:08:43 PM

Posted 02 September 2015 - 02:45 PM

Very strange indeed. Myabe if you just set the mail file to 755 permissions it will stop as well... might be worth the experiment if the second option doesn't work for you.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#7 lukexj

lukexj
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 02 September 2015 - 04:17 PM

Very strange indeed. Myabe if you just set the mail file to 755 permissions it will stop as well... might be worth the experiment if the second option doesn't work for you.

its been a few hours since one popped up i think its fixed but if it does it again i'll chmod 755 the mail file 

 

 

~~~~~~~~~~~~~~~~~~~

Thanks for Helping me


Edited by lukexj, 02 September 2015 - 04:18 PM.


#8 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,416 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:08:43 PM

Posted 02 September 2015 - 06:18 PM

 

Very strange indeed. Myabe if you just set the mail file to 755 permissions it will stop as well... might be worth the experiment if the second option doesn't work for you.

its been a few hours since one popped up i think its fixed but if it does it again i'll chmod 755 the mail file 

 

 

~~~~~~~~~~~~~~~~~~~

Thanks for Helping me

 

Awesome! Be sure to update if it happens more!


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#9 lukexj

lukexj
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 06 September 2015 - 09:47 PM

 

Awesome! Be sure to update if it happens more!

 

 

 

It did it again twice but these 2 were different

 

 

SELinux is preventing sendmail from read access on the directory /.esmtp_queue.
 
*****  Plugin catchall_labels (83.8 confidence) suggests   *******************
 
If you want to allow sendmail to have read access on the .esmtp_queue directory
Then you need to change the label on /.esmtp_queue
Do
# semanage fcontext -a -t FILE_TYPE '/.esmtp_queue'
where FILE_TYPE is one of the following: admin_home_t, bin_t, boot_t, cert_t, courier_spool_t, cvs_data_t, device_t, devpts_t, etc_aliases_t, etc_runtime_t, etc_t, exim_log_t, exim_spool_t, fail2ban_log_t, file_context_t, fonts_cache_t, fonts_t, lib_t, locale_t, mail_home_rw_t, mail_home_t, mail_spool_t, man_cache_t, man_t, mqueue_spool_t, munin_var_lib_t, net_conf_t, nscd_var_run_t, postfix_etc_t, proc_t, qmail_spool_t, root_t, samba_etc_t, sendmail_log_t, shell_exec_t, src_t, sssd_public_t, sysfs_t, system_conf_t, system_db_t, system_mail_tmp_t, textrel_shlib_t, tmp_t, user_home_dir_t, usr_t, uucpd_spool_t, var_lib_t, var_log_t, var_run_t. 
Then execute: 
restorecon -v '/.esmtp_queue'
 
 
*****  Plugin catchall (17.1 confidence) suggests   **************************
 
If you believe that sendmail should be allowed read access on the .esmtp_queue directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep sendmail /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp
 
Additional Information:
Source Context                system_u:system_r:system_mail_t:s0
Target Context                unconfined_u:object_r:default_t:s0
Target Objects                /.esmtp_queue [ dir ]
Source                        sendmail
Source Path                   sendmail
Port                          <Unknown>
Host                          new-host.home
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.12.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     new-host.home
Platform                      Linux new-host.home 4.1.6-200.fc22.x86_64 #1 SMP
                              Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-09-06 18:01:21 EDT
Last Seen                     2015-09-06 18:01:21 EDT
Local ID                      10740bd1-bbe2-490c-8159-0f8458ae2a6e
 
Raw Audit Messages
type=AVC msg=audit(1441576881.667:1173): avc:  denied  { read } for  pid=11200 comm="sendmail" name=".esmtp_queue" dev="dm-0" ino=1441793 scontext=system_u:system_r:system_mail_t:s0 tcontext=unconfined_u:object_r:default_t:s0 tclass=dir permissive=0
 
 
Hash: sendmail,system_mail_t,default_t,dir,read

Edited by lukexj, 06 September 2015 - 09:50 PM.


#10 lukexj

lukexj
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:43 PM

Posted 06 September 2015 - 09:48 PM

SELinux is preventing mktemp from write access on the directory /.esmtp_queue.
 
*****  Plugin catchall_labels (83.8 confidence) suggests   *******************
 
If you want to allow mktemp to have write access on the .esmtp_queue directory
Then you need to change the label on /.esmtp_queue
Do
# semanage fcontext -a -t FILE_TYPE '/.esmtp_queue'
where FILE_TYPE is one of the following: admin_home_t, courier_spool_t, etc_aliases_t, etc_t, exim_log_t, exim_spool_t, mail_home_rw_t, mail_home_t, mail_spool_t, mqueue_spool_t, munin_var_lib_t, postfix_etc_t, qmail_spool_t, sendmail_log_t, system_mail_tmp_t, tmp_t, user_home_dir_t, uucpd_spool_t, var_log_t. 
Then execute: 
restorecon -v '/.esmtp_queue'
 
 
*****  Plugin catchall (17.1 confidence) suggests   **************************
 
If you believe that mktemp should be allowed write access on the .esmtp_queue directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mktemp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp
 
Additional Information:
Source Context                system_u:system_r:system_mail_t:s0
Target Context                unconfined_u:object_r:default_t:s0
Target Objects                /.esmtp_queue [ dir ]
Source                        mktemp
Source Path                   mktemp
Port                          <Unknown>
Host                          new-host.home
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.12.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     new-host.home
Platform                      Linux new-host.home 4.1.6-200.fc22.x86_64 #1 SMP
                              Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-09-06 18:01:21 EDT
Last Seen                     2015-09-06 18:01:21 EDT
Local ID                      0d029dcb-e887-4f63-8752-ac169acffdf9
 
Raw Audit Messages
type=AVC msg=audit(1441576881.666:1172): avc:  denied  { write } for  pid=11199 comm="mktemp" name=".esmtp_queue" dev="dm-0" ino=1441793 scontext=system_u:system_r:system_mail_t:s0 tcontext=unconfined_u:object_r:default_t:s0 tclass=dir permissive=0
 
 
Hash: mktemp,system_mail_t,default_t,dir,write





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users