Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

user certificate corrupted


  • Please log in to reply
No replies to this topic

#1 pimpo

pimpo

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:59 PM

Posted 01 September 2015 - 12:05 PM

trans.gif?cver=0%0D%0A
trans.gif?cver=0%0D%0A
0
 

Hello,

I have formatted a notebook PC with Windows XP SP3, installed with a digital certificate user that is configured in a VPN software. At first all went well but suddenly the connection software VPN began to fail giving errors commenting that the user certificate was not trusted. The certificate showed that it contained a private key but when I tried to export it was not possible to access it. However, it was installed with the option of exportable key and had a key to use the certicate. While software was working properly, it accessed users certificate private key and asked for the password. When testing trying to access the secure page Internet explorer 8 said that it could not display the page. Checked the event viewer was in the test access to the secure website:

id. Event ID: 36870

Failed to get access to the private key of the SSL client credential. The error code returned from the cryptographic module is 0x80090016.

After investigating I saw that this occurs because permissions apparently are lost in drive: \ Documents and Settings \ Username \ Application Data \ Microsoft \ Crypto described in:

https://support.microsoft.com/es-es/kb/943358

I removed the user certificate and installed again which the problem was solved. The question I wanted to ask is why is this happening? and what can cause the permissions are changed ?. Is there any windows or IE update which causes this? How you could check what has caused this change? I only remember that I changed:

Jinitiator was installed into the laptop to access an application web.

A client signature jar was installed on the laptop.

Best regards and thanks in advance.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users