Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lenovo G580 Enabling Wireless


  • Please log in to reply
4 replies to this topic

#1 AndrewSe

AndrewSe

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Local time:12:29 PM

Posted 01 September 2015 - 06:45 AM

Machine: Lenovo G580 with W7

 

Hi

 

I am taking my laptop abroad and need to enable the wifi. something I've not done yet as I use ethernet connection at home. 

 

First of all I established that to turn wifi on I need to press Shift F5 where I got a little pop up with radio button option to turn on the wifi in lenovo management centre, After that I proceeded to try and set up a wireless network, or at least see if it would be able to scan and find available networks.

 

I then remembered that I had turned off the wireless in the BIOS as I never wanted it on while at home. So went in and turned it on. I then proceeded to check my device manager and everything looked ok - atheros wireless device was listed with no exclamations. I also unticked the turn this device off to save power saving feature in the settings and reinstalled the driver for good measure.

 

Now if I go to start menu and type wireless I get an option to 'manage wireless network' and when I click on this I get a window up that says 'wireless is not currently enabled'.

 

Just wondering if there is a step by step wireless set up and test procedure I could work through.

 

Out of interest I read this article about an apparent common problem with this model where the wires on the wifi card were on the wrong way. Can anyone vouch this is a common problem, at least with range of the network, and that this fix is a valid one? I know I am not at this position yet but included it out of curiosity.

 

http://jamescroft.co.uk/blog/windows-8/fix-for-lenovo-g580-wifi-issues-on-windows-8/ 

 

Many thanks

 

Andrew



BC AdBot (Login to Remove)

 


#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:29 AM

Posted 01 September 2015 - 09:16 AM

You need to enable the wireless device - down by the clock, right click the network icon, click Open Network and Sharing Center, on the upper left, click Change adapter settings, look for your wireless, it will most likely be greyed out, so right click and click Enable. Just for reference, you can just right click and click Disable to turn it off again. No need for the BIOS or anything. Once it is Enabled, down by the clock you'll see the icon turned to the wireless icon, click it and you should see a list of networks. If yours is there you can connect, if you want it to remember the password put a check in the Connect Auto. This is assuming of course you setup wireless on your router.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 AndrewSe

AndrewSe
  • Topic Starter

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Local time:12:29 PM

Posted 01 September 2015 - 04:01 PM

You need to enable the wireless device - down by the clock, right click the network icon, click Open Network and Sharing Center, on the upper left, click Change adapter settings, look for your wireless, it will most likely be greyed out, so right click and click Enable. Just for reference, you can just right click and click Disable to turn it off again. No need for the BIOS or anything. Once it is Enabled, down by the clock you'll see the icon turned to the wireless icon, click it and you should see a list of networks. If yours is there you can connect, if you want it to remember the password put a check in the Connect Auto. This is assuming of course you setup wireless on your router.

 

Cheers cavedweller all that worked fine except the bit about the icon next to clock and finding any networks. All I have is my existing wired connection. All I'm trying to do is make sure the adapter is "primed" and will pick up a network when I need it too. When I right click on the wireless section and click connect/disconnect a window pops up from near the clock saying connected to network 5 internet access, which is my ethernet connection. I don't see any wireless networks and I'm quite sure with my old laptop they picked a few up round here.



#4 AndrewSe

AndrewSe
  • Topic Starter

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Local time:12:29 PM

Posted 01 September 2015 - 04:16 PM

I'm also getting this when I try and diagnose the connection:

 

https://s3-us-west-2.amazonaws.com/screenshots-general/PC/Network/wifi-problem.JPG

 

I had already reinstalled the driver, would it be worth download and reinstall from atheros site or something?


Edited by AndrewSe, 01 September 2015 - 04:17 PM.


#5 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:29 AM

Posted 01 September 2015 - 08:19 PM

Does the icon change from the PC with a plug on the side to the bars of wireless signal, like on your phone? I am guessing not if you are having a driver issue. I would try getting new drivers, not the software just the drivers. Uninstall the old and try the new.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users