Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DISM Failures


  • Please log in to reply
No replies to this topic

#1 TheGreatElBrudhini

TheGreatElBrudhini

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:13 AM

Posted 28 August 2015 - 06:25 PM

I've been trying to fix the inability of sfc to repair files by using DISM. I've made several attempts at running DISM all of which have failed. Here is a list of what I (can remember) I've tried.

DISM /Online /Cleanup-Image /RestoreHealth

I also updated a Group Policy and then tried the above command as well. Group Policy was Computer Configuration > Administrative Templates > System > Specify settings for optional component installation and component repair. I Enabled the setting and then marked the Contact Windows Updated directly [...] checkbox. 

 

I also tried the steps posted here.

 

I then downloaded the eval ISO for Windows 8.1 Enterprise 64-bit (matches my OS) and tried running:

DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\Users\<username>\Downloads\win8.ISO:\Sources\install.wim:1 /LimitAccess

At this point I am in trial and error mode so I mounted the ISO and tried

DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:D:\sources\install.wim:1 /LimitAccess

and

DISM /Online /Cleanup-Image /RestoreHealth /Source:D:\ /LimitAccess

I have also run DISM with /CheckHealth and /ScanHealth, both indicated the store was repairable. 

Attached Files



BC AdBot (Login to Remove)

 


m



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users