Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win 10 no dvd drive fix.


  • Please log in to reply
14 replies to this topic

#1 technonymous

technonymous

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 23 August 2015 - 10:29 PM

I came across this problem after installing Windows 10 no dvd drive was detected by device manager and not showing in This PC. After this fix you should see the dvd drive pop up and Windows 10 dvd player app under start. :)

 

In "Search Windows" Type in cmd and right-click run as administrator. Copy and paste the info below into cmd and hit enter.

 

reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001



BC AdBot (Login to Remove)

 


#2 Rocky Bennett

Rocky Bennett

  • Members
  • 2,597 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:03:05 PM

Posted 24 August 2015 - 09:23 AM

I think that the easier way to accomplish this is to just right click on the start menu and then click on Command Prompt (Admin) and then enter your command. When I type in "cmd" in the search windows area, nothing comes back.


594965_zpsp5exvyzm.png


#3 technonymous

technonymous
  • Topic Starter

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 25 August 2015 - 02:19 AM

Alright the above fix was for Windows 7/8 and now is causing a error in task viewer no surprise. It's logging a ton of event id 51 errors..."An error was detected on device \Device\CdRom0 during a paging operation."

 

However, I have found a better solution. The problem with my system is that Windows 10 was installled prior to not changing the hard drive controller configurations in the bios to AHCI instead of IDE. Not sure how they got mysteriously changed. I changed those prior to installing Windows 7. So this is a bios controller issue.The cdrom is SATA and that is the problem. I tried changing them to AHCI and booting Windows 10 and it won't load. Windows 10 didn't bother to load the AHCI controller drivers so it cannot detect the drive. Luckly there is a easy fix. If others out there are in the same boat as me you first you have to delete the registry key I posted above in cmd and reboot the system. Be sure to create a system restore point first.

 

reg delete HKLM\System\CurrentControlSet\Services\atapi\Controller0

 

The solution...

 

You have to boot into safemode to get windows to load the AHCI driver. How to do that you right-click Start and Run and type msconfig. Change to boot tab and put a check into safe boot. Hit apply and You will get a prompt to restart into safe boot. The next step is important... Hit the key to go into bios and change the hard drive SATA controller configurations from IDE to AHCI save to bios and restart once more. Windows automagically loads the drivers for you. Now you go to run and type msconfig again and uncheck safe-boot and reboot the system. The drives should be AHCI and the dvd drive working. Confirm that they are AHCI you type devmgmt.msc in run and go to view and Devices by Connection. Scroll down to Standard SATA AHCI Controller and your drives should be listed there. Now create a system restore point again. Hopefully this sheds some light on this particular issue.

 

NOTE:

Typically in the bios if using 1-4 ports as IDE then 5-8 must also be IDE. However, 1-4 can be AHCI and 5-8 can be IDE. Or all 1-8 can be AHCI. This change reflects on which ports your HD and cdrom drives are plugged into on the motherboard and what your motherboard supports. So you may have to physically open the computer case and change the drive to a different sata port. For me I did not have to do this since my drives and cdrom drive are all SATA and on ports 1-4 and JBOD (just a bunch of disks no raid). So my setting I put them all on AHCI for future upgrades. If you still got IDE drives as well SATA then you will have to tinker around with it and get all the SATA drives on ports 1-4 and IDE's on ports 5-8 etc. Some motherboards have 6 ports some have 8 ports or more. Those of you using RAID and have this problem then god help you LOL! Using RAID you will likely have to rebuild the raid and reinstall Windows 7/8 from image backup and then upgrade to Windows 10.


Edited by technonymous, 25 August 2015 - 07:06 PM.


#4 Sheepdisease

Sheepdisease

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:09:05 PM

Posted 12 December 2015 - 01:40 PM

Alright the above fix was for Windows 7/8 and now is causing a error in task viewer no surprise. It's logging a ton of event id 51 errors..."An error was detected on device \Device\CdRom0 during a paging operation."

 

However, I have found a better solution. The problem with my system is that Windows 10 was installled prior to not changing the hard drive controller configurations in the bios to AHCI instead of IDE. Not sure how they got mysteriously changed. I changed those prior to installing Windows 7. So this is a bios controller issue.The cdrom is SATA and that is the problem. I tried changing them to AHCI and booting Windows 10 and it won't load. Windows 10 didn't bother to load the AHCI controller drivers so it cannot detect the drive. Luckly there is a easy fix. If others out there are in the same boat as me you first you have to delete the registry key I posted above in cmd and reboot the system. Be sure to create a system restore point first.

 

reg delete HKLM\System\CurrentControlSet\Services\atapi\Controller0

 

The solution...

 

You have to boot into safemode to get windows to load the AHCI driver. How to do that you right-click Start and Run and type msconfig. Change to boot tab and put a check into safe boot. Hit apply and You will get a prompt to restart into safe boot. The next step is important... Hit the key to go into bios and change the hard drive SATA controller configurations from IDE to AHCI save to bios and restart once more. Windows automagically loads the drivers for you. Now you go to run and type msconfig again and uncheck safe-boot and reboot the system. The drives should be AHCI and the dvd drive working. Confirm that they are AHCI you type devmgmt.msc in run and go to view and Devices by Connection. Scroll down to Standard SATA AHCI Controller and your drives should be listed there. Now create a system restore point again. Hopefully this sheds some light on this particular issue.

 

NOTE:

Typically in the bios if using 1-4 ports as IDE then 5-8 must also be IDE. However, 1-4 can be AHCI and 5-8 can be IDE. Or all 1-8 can be AHCI. This change reflects on which ports your HD and cdrom drives are plugged into on the motherboard and what your motherboard supports. So you may have to physically open the computer case and change the drive to a different sata port. For me I did not have to do this since my drives and cdrom drive are all SATA and on ports 1-4 and JBOD (just a bunch of disks no raid). So my setting I put them all on AHCI for future upgrades. If you still got IDE drives as well SATA then you will have to tinker around with it and get all the SATA drives on ports 1-4 and IDE's on ports 5-8 etc. Some motherboards have 6 ports some have 8 ports or more. Those of you using RAID and have this problem then god help you LOL! Using RAID you will likely have to rebuild the raid and reinstall Windows 7/8 from image backup and then upgrade to Windows 10.

Wow, I have been having this problem for months. The fixes mentioned online worked momentarily but then after that no matter what I tried, I could not get the DVD drives to show.

 

I followed your instructions and they are back, thank you VERY much!



#5 technonymous

technonymous
  • Topic Starter

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 13 December 2015 - 04:33 AM

No problem. I am still trying to fix issues in Windows 10 v15 build. lol



#6 kposey01

kposey01

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:05 PM

Posted 04 January 2016 - 10:23 PM

Technonymous - I've also had this problem after the Win10 upgrade on a Satellite P875-s7200.  I've used your fix above, but it only seems to fix the problem in Safe Mode.  Once I boot back into normal mode, the problem is still there.  Any ideas?



#7 technonymous

technonymous
  • Topic Starter

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 04 January 2016 - 10:58 PM

The steps should work. In normal windows go to config and put a check into box for safeboot let it reboot. During that reboot you must go into bios first and make the changes & save in bios. Let it continue to boot into safeboot. Once that happens it should be locked in. Go back to config and uncheck the box safeboot and reboot to normal mode.



#8 kposey01

kposey01

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:05 PM

Posted 05 January 2016 - 02:07 AM

There must be something different in my system.  I'm able to get the DVD-CDROM operational in Safe Mode, but as soon as I reboot in normal mode, something changes and the DVD reverts to the Error 19.  I wonder if there is another setting either in MSConfig or Regedit I'm missing.  When it disappers, I can go back in to Safe Mode, delete the CD-ROM in Device Manager and Rescan, then it reappears and is working.  But then as soon as I reboot normal... poof, Error 19.



#9 wfallon

wfallon

  • Members
  • 52 posts
  • OFFLINE
  •  
  • Local time:01:05 PM

Posted 11 January 2016 - 06:26 AM

We go through this every 2 days:

 

     https://support.microsoft.com/en-us/kb/314060

 

If for some reason that doesn't fix it, Google has 807,000 hits:

 

     https://www.google.com/search?q=CD%2FDVD+drive+not+recognized&oq=CD%2FDVD+drive+not+recognized&aqs=chrome..69i57j69i58j69i65j69i60&sourceid=chrome&es_sm=122&ie=UTF-8

 

Bill



#10 kidd16

kidd16

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles
  • Local time:02:05 PM

Posted 11 January 2016 - 12:41 PM

I am having the same problem with my DVD Player, I can't get it to play Disk in windows 10
I try downloading another application and still it will not play the disk

#11 jeannot18

jeannot18

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:05 PM

Posted 14 March 2016 - 06:10 AM

Just upgraded to Win 10 and I am having the same problem, could anyone comment on the best solution before i go ahead and make a real mess of it, thanks

J



#12 jeannot18

jeannot18

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:05 PM

Posted 14 March 2016 - 09:43 AM

Actually did the resolution No. 5 and it worked, let's hope that it last

J



#13 Innocentkitten

Innocentkitten

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:05 PM

Posted 21 September 2016 - 11:55 PM

I tried this fix but now my computer is at a black screen with the circle of circulating balls on the screen. Is it actually trying to do something or is it just being really slow?

#14 technonymous

technonymous
  • Topic Starter

  • Members
  • 2,480 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 22 September 2016 - 12:33 AM

Which fix are you referring to? My posts or post #12 links?

 

For windows 10 I just go to search and type msconfig run that and go to boot tab, check the box safe boot. Before the system boots into safe boot mash your key to get into bios. Change the drives from IDE to AHCI, save bios and reboot system & let it continue to boot into safe boot. Once safe boot mode is loaded right-click the start button and choose run type msconfig. Or open cmd and type msconfig. Uncheck the box for safe boot and reboot back into normal windows boot. If booted successfully, windows should be using the AHCI drivers and people with cd drive missing should now see the cd drive.



#15 steza

steza

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:05 PM

Posted 30 March 2017 - 05:05 AM

Alright the above fix was for Windows 7/8 and now is causing a error in task viewer no surprise. It's logging a ton of event id 51 errors..."An error was detected on device \Device\CdRom0 during a paging operation."

 

However, I have found a better solution. The problem with my system is that Windows 10 was installled prior to not changing the hard drive controller configurations in the bios to AHCI instead of IDE. Not sure how they got mysteriously changed. I changed those prior to installing Windows 7. So this is a bios controller issue.The cdrom is SATA and that is the problem. I tried changing them to AHCI and booting Windows 10 and it won't load. Windows 10 didn't bother to load the AHCI controller drivers so it cannot detect the drive. Luckly there is a easy fix. If others out there are in the same boat as me you first you have to delete the registry key I posted above in cmd and reboot the system. Be sure to create a system restore point first.

 

reg delete HKLM\System\CurrentControlSet\Services\atapi\Controller0

 

The solution...

 

You have to boot into safemode to get windows to load the AHCI driver. How to do that you right-click Start and Run and type msconfig. Change to boot tab and put a check into safe boot. Hit apply and You will get a prompt to restart into safe boot. The next step is important... Hit the key to go into bios and change the hard drive SATA controller configurations from IDE to AHCI save to bios and restart once more. Windows automagically loads the drivers for you. Now you go to run and type msconfig again and uncheck safe-boot and reboot the system. The drives should be AHCI and the dvd drive working. Confirm that they are AHCI you type devmgmt.msc in run and go to view and Devices by Connection. Scroll down to Standard SATA AHCI Controller and your drives should be listed there. Now create a system restore point again. Hopefully this sheds some light on this particular issue.

 

NOTE:

Typically in the bios if using 1-4 ports as IDE then 5-8 must also be IDE. However, 1-4 can be AHCI and 5-8 can be IDE. Or all 1-8 can be AHCI. This change reflects on which ports your HD and cdrom drives are plugged into on the motherboard and what your motherboard supports. So you may have to physically open the computer case and change the drive to a different sata port. For me I did not have to do this since my drives and cdrom drive are all SATA and on ports 1-4 and JBOD (just a bunch of disks no raid). So my setting I put them all on AHCI for future upgrades. If you still got IDE drives as well SATA then you will have to tinker around with it and get all the SATA drives on ports 1-4 and IDE's on ports 5-8 etc. Some motherboards have 6 ports some have 8 ports or more. Those of you using RAID and have this problem then god help you LOL! Using RAID you will likely have to rebuild the raid and reinstall Windows 7/8 from image backup and then upgrade to Windows 10.

Thank you so much!
Your perfect explanation led me to the right direction... I checked BIOS and simply moved the DVD to port 3 from original 5..
On 7 PCs!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users