Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help with Windows 7 Toshiba Video Driver issue


  • Please log in to reply
No replies to this topic

#1 caelis

caelis

  • Members
  • 32 posts
  • OFFLINE
  •  
  • Local time:12:05 PM

Posted 21 August 2015 - 08:48 AM

Hi, I keep getting a black screen on my Toshiba Satelite laptop.  It is an issue involving the display drivers.  Microsoft put an update for my video driver in Windows update and I must have accidently installed it. Now my computer boots to a black screen.  When I reboot into Windows Safe Mode, a pair of identical drivers are listed under display adapters.

 

Mobile Intel® 945 Express Chipset Family (Microsoft  Corporation - WDDM 1.0)

Mobile Intel® 945 Express Chipset Family (Microsoft  Corporation - WDDM 1.0)

 

If I disable them both, I can boot to Windows 7 normally.  If I uninstall them and boot, Windows Update appears in my system tray and puts the pair back into display adapters and I get the black screen again. I am in an endless loop.  I keep disabling and Windows Update keeps reinstalling. In the past I could disable, uninstall and reinstall the Windows 7 drivers from Toshiba (from 2009). Now its like Microsoft has determined I will use their updated drivers no matter what. Does anyone have any idea?  Iliterally spent ALL day yesterday working on this and woke to a black screen this morning. I have tried the Toshiba drivers, the Intel update tool drivers and Microsoft update drivers, each reboot, I end up with the identical pair that gives me the black screen. I'm exhausted and out of ideas.

 

Any help would be greatly appreciated.

Thanks



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users