Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

RDP won't fill whole monitor


  • Please log in to reply
6 replies to this topic

#1 gib65

gib65

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 19 August 2015 - 11:35 PM

Hello,

I'm not sure if this should go in Hardware or Windows 8, but I have a laptop (running Windows 8) with a 1366 x 768 monitor. It's connected to a second monitor that's 1600 x 900. When I run Remote Desktop Connection and transfer the viewport to the larger monitor, it doesn't seem to fill the entire screen. It's dimensions remain 1366 x 768. How can I get the RDP viewport to take up the whole screen?

Things I've tried:

* Sarting RDP in the larger monitor.

* Making the larger monitor my primary monitor.

* Right-clicking the RDP viewport title bar and selecting "fill screen" (this does cause it to take up the full screen but with huge black margins such that the actual content of the viewport is still 1366 x 768).

There's got to be a way to tell it to take up the full screen realestate. Please help.



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,707 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:55 PM

Posted 20 August 2015 - 05:03 PM

While it is always possible I may be wrong, I believe that if the maximum resolution on your laptop is 1366x768 that is all you can get out of it.

 

To check this, right click on a blank piece of your screen then select 'Screen resolution' in the context menu that appears. In the middle of the screen resolution box that appears you will see an entry 'Resolution'. Clicking on this will bring up some sort of slider which will probably have 1366x768 at the top. If it does, that's all she wrote. If it has some higher resolution select that before or when using your higher resolution monitor.

 

Note that if you do have a higher resolution available and you are using the two screens at the same time the laptop screen will not show the whole image, it will be cropped to the central 1366x768 pixcels.

 

Chris Cosgrove



#3 gib65

gib65
  • Topic Starter

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 20 August 2015 - 10:48 PM

Chris,

 

The resolution I get depends on which monitor I click on.



#4 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,707 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:55 PM

Posted 21 August 2015 - 07:11 PM

What resolution are you getting when you click on the other one ?

 

Chris Cosgrove



#5 gib65

gib65
  • Topic Starter

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 23 August 2015 - 10:19 AM

1600 x 900



#6 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,707 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:55 PM

Posted 23 August 2015 - 05:43 PM

You've got me going !  I don't have time right now but I am going to try and repeat this with a laptop I have handy which has native  resolution of 1366x768 and my on desk monitor which is 1920x1080.

 

This is the slider I was referring to above, just to eliminate any confusion. Image taken from my desktop.

 

 

 

Chris Cosgrove


Edited by Chris Cosgrove, 23 August 2015 - 05:46 PM.


#7 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,707 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:55 PM

Posted 24 August 2015 - 05:14 AM

I have tried to duplicate your problem and I can't, quite.

 

I was using a Fujitsu laptop with native 1366x768 resolution and my desktop monitor, an Iiyama, which has 1920x1080 resolution. Connecting the monitor to the laptop and using both screens the maximum resolution I could get was the 1366x768 of the laptop but the image filled the screen on the monitor with no black spaces.

 

Switching to use only the external monitor, the available resolution from the laptop went up to 1920x768 and the image on the monitor looked like I would normally expect it to and again the screen was filled with the image. As a check I tried a couple of photos, using Irfanview, and the screen was filled at all times with no black borders when using images from my wallpaper collection which are cropped to fit the shape of a screen exactly.

 

From the above I draw two conclusions. The first is that if you are using both screens, then you are limited to the native resolution of the laptop but the limit changes if you change the settings to use the external monitor only. And second, this effect of large black borders has to be down to monitor settings as I couldn't reproduce it at all.

 

Having just re-read your OP I have realised that you were using a remote connection rather than the direct connection I was using in which case I don't think you are going to be able to increase the resolution beyond the 1366x768 of the laptop but I would still expect it to fill the screen on the remote monitor as the aspect ratios are virtually identical. So I am left thinking it has to be something to do with the external monitor settings.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users