Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sharing a nas with ubuntu server


  • Please log in to reply
19 replies to this topic

#1 TheJokerz

TheJokerz

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 15 August 2015 - 04:59 PM

Hello all,

Here is my problem, I just installed a Ubuntu server version 14.04.3 LTS.  I have setup samba server and openssh.  What I am trying to accomplish is have the movies I have on my nas shared with all of my devices on my network.  I have a ASUS rt-n66u router that allows me to attach a external hdd that acts like a nas.  

 

I have been able to share folders that I choose to all of my devices on my network with the ubuntu server, I am just having trouble sharing my movies that are on my external hdd that is attached to my router.

 

I also have plex media server installed and am having an issue getting that going as well.  I cannot connect through a browser or cmd line.

 

Any help would be appreciated!


Edited by TheJokerz, 15 August 2015 - 05:01 PM.

utl8q0-5.png


BC AdBot (Login to Remove)

 


#2 mremski

mremski

  • Members
  • 495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:02:08 AM

Posted 15 August 2015 - 05:24 PM

browser/cmd line from where?  From the Ubuntu box or from another machine?

Sharing the movies from the external hdd to where, to the Ubuntu box?  Check permissions;  you may have to open them up on the external hdd because username on the Ubuntu box may be different.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#3 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 17 August 2015 - 06:46 AM

browser/cmd line from where?  From the Ubuntu box or from another machine?

Sharing the movies from the external hdd to where, to the Ubuntu box?  Check permissions;  you may have to open them up on the external hdd because username on the Ubuntu box may be different.

Sorry for the long delay.  I am trying to set up a shared folder in the Samba server that I logged into in any browser on my network that is located on my linux box.  I can share folders that are on the linux box itself, but the hdd that is attached to my router I am having a hard time figuring out how to share.  I would like to do this so I can stream movies to non computer devices like my xbox and other streaming boxes that I have.


utl8q0-5.png


#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:02:08 AM

Posted 17 August 2015 - 08:25 AM

To share folders from your HDD connected to your router you will have to set it up via your router and not your Linux server.

 

Regarding your plex app, you more than likely have not opened the correct firewall ports to allow anything to connect to the plex server. Here is a list of ports that plex uses. You will need the top 32400 port for sure. I am also pretty sure I had to open up one other one on that list but I am not sure which one. You will have to experiment around with it.

 

If you haven't already on your server (which if its not getting through I assume you did already)

sudo ufw enable

Then use this to allow ports

sudo ufw allow 32400/tcp

Here is the ufw help gude.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 17 August 2015 - 08:36 AM

Thank you DeimosChaos I will try this tonight when I get home from work!


utl8q0-5.png


#6 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 18 August 2015 - 07:07 AM

To share folders from your HDD connected to your router you will have to set it up via your router and not your Linux server.

 

Regarding your plex app, you more than likely have not opened the correct firewall ports to allow anything to connect to the plex server. Here is a list of ports that plex uses. You will need the top 32400 port for sure. I am also pretty sure I had to open up one other one on that list but I am not sure which one. You will have to experiment around with it.

 

If you haven't already on your server (which if its not getting through I assume you did already)

sudo ufw enable

Then use this to allow ports

sudo ufw allow 32400/tcp

Here is the ufw help gude.

So I opened all of those ports, and I am still getting the web page cannot be displayed when I try to access http://127.0.0.1:32400/web.  Http://127.0.0.1:32400/web is what is posted on the plex website to access the plex media server once it is installed.  I even tried resetting the service for plexmediaserver to try again and same thing, still getting webpage cannot be displayed.

 

Any ideas?

 

Thanks


utl8q0-5.png


#7 mremski

mremski

  • Members
  • 495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:02:08 AM

Posted 18 August 2015 - 07:28 AM

127.0.0.1 is the localhost or loopback device, so that would be valid only on the machine you are running the plexmediaserver.  I'm assuming that you are on the same machine, so we should verify that service is running (there should be a "status" command for the service), if so that the port is open:

 

service plexmediaserver status   (or however you restarted it)

 

netstat -aln | grep 32400  (this shows open listening sockets)


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#8 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 18 August 2015 - 07:41 AM

12_zpso3xrg9es.jpg

 

Here is the screen shot after those commands


utl8q0-5.png


#9 mremski

mremski

  • Members
  • 495 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:02:08 AM

Posted 18 August 2015 - 08:12 AM

see the output of the netstat -aln | grep 32400?  That means nothing opened a listening socket for port 32400.  Double check any configuration files for the plexmediaserver or any log files for it.  Something is not configured correctly.


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#10 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:02:08 AM

Posted 18 August 2015 - 08:18 AM

 

To share folders from your HDD connected to your router you will have to set it up via your router and not your Linux server.

 

Regarding your plex app, you more than likely have not opened the correct firewall ports to allow anything to connect to the plex server. Here is a list of ports that plex uses. You will need the top 32400 port for sure. I am also pretty sure I had to open up one other one on that list but I am not sure which one. You will have to experiment around with it.

 

If you haven't already on your server (which if its not getting through I assume you did already)

sudo ufw enable

Then use this to allow ports

sudo ufw allow 32400/tcp

Here is the ufw help gude.

So I opened all of those ports, and I am still getting the web page cannot be displayed when I try to access http://127.0.0.1:32400/web.  Http://127.0.0.1:32400/web is what is posted on the plex website to access the plex media server once it is installed.  I even tried resetting the service for plexmediaserver to try again and same thing, still getting webpage cannot be displayed.

 

Any ideas?

 

Thanks

 

 

 

127.0.0.1 is the localhost or loopback device, so that would be valid only on the machine you are running the plexmediaserver.  I'm assuming that you are on the same machine, so we should verify that service is running (there should be a "status" command for the service), if so that the port is open:

 

service plexmediaserver status   (or however you restarted it)

 

netstat -aln | grep 32400  (this shows open listening sockets)

As mremski stated 127.0.0.1 is the loopback address. You must put in your IP address that is slated to your Ubuntu server, probably a 192.168.x.x address. I would assign your server a static IP address from your router so that it always stays the same.

 

If you do a

ifconfig

on your server you should see what your eth0 address is (that should be the one its using). You will also see the MAC address which you will need to define a static IP in your router settings.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#11 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 18 August 2015 - 08:25 AM

 

 

To share folders from your HDD connected to your router you will have to set it up via your router and not your Linux server.

 

Regarding your plex app, you more than likely have not opened the correct firewall ports to allow anything to connect to the plex server. Here is a list of ports that plex uses. You will need the top 32400 port for sure. I am also pretty sure I had to open up one other one on that list but I am not sure which one. You will have to experiment around with it.

 

If you haven't already on your server (which if its not getting through I assume you did already)

sudo ufw enable

Then use this to allow ports

sudo ufw allow 32400/tcp

Here is the ufw help gude.

So I opened all of those ports, and I am still getting the web page cannot be displayed when I try to access http://127.0.0.1:32400/web.  Http://127.0.0.1:32400/web is what is posted on the plex website to access the plex media server once it is installed.  I even tried resetting the service for plexmediaserver to try again and same thing, still getting webpage cannot be displayed.

 

Any ideas?

 

Thanks

 

 

 

127.0.0.1 is the localhost or loopback device, so that would be valid only on the machine you are running the plexmediaserver.  I'm assuming that you are on the same machine, so we should verify that service is running (there should be a "status" command for the service), if so that the port is open:

 

service plexmediaserver status   (or however you restarted it)

 

netstat -aln | grep 32400  (this shows open listening sockets)

As mremski stated 127.0.0.1 is the loopback address. You must put in your IP address that is slated to your Ubuntu server, probably a 192.168.x.x address. I would assign your server a static IP address from your router so that it always stays the same.

 

If you do a

ifconfig

on your server you should see what your eth0 address is (that should be the one its using). You will also see the MAC address which you will need to define a static IP in your router settings.

 

Right that is to connect to the ubuntu server.  On the plex site it states that 127.0.0.1:32400/web is how you access the plex server.

 

https://support.plex.tv/hc/en-us/articles/200288586-Installation

 

Its located under the Ubuntu install, unless there is something that I missed.  From what I interpreted the loopback ip with the port number at the end is how you access the plex server.


Edited by TheJokerz, 18 August 2015 - 08:27 AM.

utl8q0-5.png


#12 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:02:08 AM

Posted 18 August 2015 - 08:29 AM

True it does state that... I can't remember how I access it from the server itself... I usually do it from my main computer since I usually use TeamViewer to do maintenance on my server.

I would  try using the actual IP address anyway and see what happens, I kind of remember doing that to get in on the server itself. If that fails try doing it from another computer since you have the ports open.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#13 TheJokerz

TheJokerz
  • Topic Starter

  • Members
  • 286 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:08 AM

Posted 18 August 2015 - 08:31 AM

Okay thank you Demos, I will try that when I get home tonight.  I am currently at work....


utl8q0-5.png


#14 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:02:08 AM

Posted 18 August 2015 - 08:40 AM

Okay thank you Demos, I will try that when I get home tonight.  I am currently at work....

Me too man... me too...


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#15 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:02:08 AM

Posted 18 August 2015 - 08:02 PM

Just checked on my Ubuntu server. Just use your IP address of the machine and you will be able to connect (hopefully).


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users