Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Hoping to fix old 2TB HDD


  • Please log in to reply
1 reply to this topic

#1 DyslexicChciken

DyslexicChciken

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 11 August 2015 - 09:19 PM

My WD Caviar Green 2TB external HDD I bought long ago stopped working. I broke open the enclosure and put it into a different enclosure. I set up the HDD into my Rosewill RX356 enclosure and plugged it into my computer. In the device manager, it is listed as "USB Device" and it doesn't show up in my computer window and sometimes it doesn't show up at all. When I turn the drive on, it makes sharp "zeeekk zeeek" sound.  Anyone know if this is fixable?


Edited by DyslexicChciken, 11 August 2015 - 09:36 PM.


BC AdBot (Login to Remove)

 


m

#2 YeahBleeping

YeahBleeping

  • Members
  • 1,258 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 PM

Posted 12 August 2015 - 07:31 AM

It sounds like from what you state that the drive's spin up motor is bad/out.  In my opinion I think your out of luck unless someone else has an idea.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users