Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Free" DNS service did not update my public IP


  • Please log in to reply
8 replies to this topic

#1 gigawert

gigawert

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:59 PM

Posted 11 August 2015 - 11:53 AM

So I'm using this "free" DNS service called ydns. I was told that using it would eliminate the tedious task of updating my IP address for my website and website(s). But no, no, no! The DNS domain pointed to yesterday's IP, 69.107.93.145. Today's is 69.107.91.145. I'm not saying it changes every day, but it changes at least once every two weeks. I know that it still points to yesterday's IP because when I try to connect to my IRC server, it says mrgiga.ydns.eu (69.107.93.145) in my IRC client. Why would they advertise a non-working DNS service and how do I fix this?

 

EDIT: I checked in my router settings, and it said that the last boot was 7 1/2 hours ago (2:30 in the morning!?), which means it restarted itself while I was asleep. So what is going on here too? Shouldn't the IP that the DNS points to have changed by now?


Edited by gigawert, 11 August 2015 - 11:56 AM.

John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


BC AdBot (Login to Remove)

 


#2 m0rph

m0rph

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:09:59 PM

Posted 11 August 2015 - 02:37 PM

Hi,

I am not sure about the freedns service but use noip all the time.

Try setting it up see if it works better than the current solution.

One thing you need to make sure is you enter the username and password it updates.

#3 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:59 PM

Posted 11 August 2015 - 02:40 PM

You have 3 topics...all for the same problem with different symptoms. Pick one and put all the symptoms there.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#4 gigawert

gigawert
  • Topic Starter

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:59 PM

Posted 11 August 2015 - 03:56 PM

You have 3 topics...all for the same problem with different symptoms. Pick one and put all the symptoms there.

No, even when using my new IP, I still cannot connect to my raspberry pi, so I don't think it is related to DNS or anything.


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#5 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:01:59 PM

Posted 11 August 2015 - 06:07 PM

The updates don't happen my magic.  You need the ddns client running on a pc on your lan for the service to be updated.



#6 gigawert

gigawert
  • Topic Starter

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:59 PM

Posted 11 August 2015 - 06:12 PM

The updates don't happen my magic.  You need the ddns client running on a pc on your lan for the service to be updated.

But I can't connect to my Raspberry Pi to do that.


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#7 gigawert

gigawert
  • Topic Starter

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:59 PM

Posted 11 August 2015 - 06:17 PM

Works now. Just had to reconnect all the cables and reassign a private IP.


Edited by gigawert, 11 August 2015 - 06:22 PM.

John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#8 gigawert

gigawert
  • Topic Starter

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:59 PM

Posted 11 August 2015 - 06:27 PM

 

 

Used this tutorial to install the client: http://www.raspberrypihelp.net/tutorials/29-raspberry-pi-no-ip-tutorial


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#9 m0rph

m0rph

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:09:59 PM

Posted 12 August 2015 - 02:12 AM

This does work using the router as the updater because I use it myself.

I use noip to update my IP and ddwrt firmware for my router, it works in others though like draytek but not all routers support ddns service you have to check if yours does.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users