Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

hp scanner won't work on windows 8.1


  • Please log in to reply
12 replies to this topic

#1 AJW61

AJW61

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 05:29 AM

Hi I'm having problems getting my scanner to work on my new laptop, windows 8.1. I downloaded the correct driver for it and a patch and scan doctor but it wouldn't work. I just got the message after running scan doctor that it was HP scan flow manager error and one of the software components was missing, I ran a windows troubleshooter and it said that the device wouldn't work in usb port 3 and to move it to port 2 which I did but just got the same message.

Last night it suddenly started to work, then this morning I've scanned with it then it just stopped working again and won't open, just get the same message that I need a WIA driver. I've got the correct driver for it and don't know what to do next.

Hope someone can help out, is this a common problem?

 

Thankyou..



BC AdBot (Login to Remove)

 


#2 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,071 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:50 PM

Posted 09 August 2015 - 06:41 AM

Do you have a model number to provide? It would help us determine what your issue is

You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#3 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 06:59 AM

Hi yes, sorry. It's Hp G2410


Scanjet



#4 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,071 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:50 PM

Posted 09 August 2015 - 07:09 AM

Err thats quite old, 2007 era scanner hrm may be time to replace it.

It may not be a driver issue, could be hardware


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#5 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 07:11 AM

it's been fine up until I changed laptops, it worked with no trouble on my windows 7 one. Trouble is I can't afford a new scanner. It seems to work intermittently then stops communicating. Oh well thankyou anyway, I'll have to save up. 



#6 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,071 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:50 PM

Posted 09 August 2015 - 07:13 AM

Well its only a possibility, the only thing that makes me think its a hardware issue is you said you installed the correct driver.

But to double check do you know what architecture you have?

32bit?

64bit?


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#7 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 07:17 AM

It's 64bit. It probably is just because it's an old one as you say. I downloaded the driver from the hp site for windows 8.1 64bit so it is the right one. I've run the scan doctor again and now it can't communicate at all but when I opened up the scanner it opened ok and did a preview scan then stopped working again, so it probably is a hardware issue.



#8 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,071 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:50 PM

Posted 09 August 2015 - 07:21 AM

Well for laughs you could try the 32bit driver, it may actually work


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#9 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 07:26 AM

will do lol I'll let you know :)



#10 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,071 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:05:50 PM

Posted 09 August 2015 - 07:28 AM

Hey it cant hurt, do you know if your older setup was 32bit?

Hey who knows it could be just that, but the age of your scanner could be at issue


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

 

ljxaqg-6.png


#11 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 07:32 AM

It hasn't worked, I think it's probably the age of the scanner...it bugs me that it's still in good working order but I have to buy upgraded hardware, I've lost the installation cd for it which is annoying as I have every cd from every bit of hardware since year dot lol.



#12 JohnC_21

JohnC_21

  • Members
  • 24,006 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:05:50 PM

Posted 09 August 2015 - 08:15 AM

See if VueScan works for you. It is paid software but for the price it is very good. You can demo it I believe and it comes in Standard and Professional editions. The Pro version does Slides. It has a ton of supported scanners but you will have to install it to see if it works for you.



#13 AJW61

AJW61
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:50 PM

Posted 09 August 2015 - 08:50 AM

Thanks I'll have a look at that.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users