Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to connect, LAN doesn't have a valid IP configuration and 169.254.x.x


  • Please log in to reply
7 replies to this topic

#1 deborah91

deborah91

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 07 August 2015 - 07:13 AM

Hi,

 

I've got an assembled PC to replace my old one.

 

I installed Windows 7 and the drives provided with the gigabyte motherboard.

Also connected my D-Link D320B router and tried to connect, however despite all 4 lights lighting up green, which should be ok, I can't connect to internet and the status bar shows a ! mark on the connection icon.

 

I ran network diagnosis and it said "Local Area Connection" doesn't have a valid IP configuration". Ipconfig shows a 169.254.x.x IP which from what I've read shows something is wrong.

 

 

Tried to reboot and power off both router and PC multiple times, I can't even access 192.168.1.1 modem config page (though it should be ok with its previous config), tried installing latest realtek drivers but still nothing, tried tweaking dot com windows repair software.

 

Could you help me?

 

Thank you


C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : computer
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : FC-XX-XX-XX-XX-XX
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::XXXX:246c:XXXX:8e6%11(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.8.230(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 25143XXXX
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-XX-XX-8C-XX-FC-XX-XX-88-XX-XX

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{9D7E631A-A303-4CDB-82DC-C2E25FB5AC9E}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Edited by hamluis, 07 August 2015 - 12:37 PM.
Moved from Win 7 to Networking - Hamluis.


BC AdBot (Login to Remove)

 


#2 Nikhil_CV

Nikhil_CV

    Vestibulum Bleep


  • Members
  • 1,145 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:err: Destination unreachable! bash!
  • Local time:10:52 PM

Posted 07 August 2015 - 08:35 AM

Hi,
Please try going into device manager (start menu > type in 'device manager') and check if your ethernet adapter has yellow exclamation mark.

Checklist:
Have you visually inspected the ports and pins are intact on motherboard and router?
Was the ethernet cable inserted properly?
Are you sure the ethernet cable works fine?
Regards : CV                                                                                                    There is no ONE TOUCH key to security!
                                                                                                                                       Be alert and vigilant....!
                                                                                                                                  Always have a Backup Plan!!! Because human idiotism doesn't have a cure! Stop highlighting!
                                                     Questions are to be asked, it helps you, me and others.  Knowledge is power, only when its shared to others.            :radioactive: signature contents © cv and Someone....... :wink:

#3 deborah91

deborah91
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 07 August 2015 - 09:32 AM

Hi,
Please try going into device manager (start menu > type in 'device manager') and check if your ethernet adapter has yellow exclamation mark.

Checklist:
Have you visually inspected the ports and pins are intact on motherboard and router?
Was the ethernet cable inserted properly?
Are you sure the ethernet cable works fine?


 

 

Thanks for your reply.

 

I opened device manager and there is no yellow mark next to any network adapter (mine is realtek PCI e GBE family controller).

 

The ethernet cable always worked, isn't that old and both motherboard and router seem otherwise ok.

 

Also tried ipconfig /release and it goes on, but then trying

ipconfig /renew it lets me wait quite some time only to end with this message: "an error occurred while renewing interface Local Area Connection: unable to contacto your DHCP server. Request has timed out"


Edited by deborah91, 07 August 2015 - 10:00 AM.


#4 ShouldAt3

ShouldAt3

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 07 August 2015 - 10:54 AM

IP addresses from the 169.254.x.x range are known as Automatic Private IP Addressing (APIPA). Your computer has an IP address from that range because it can't contact the DHCP server, which is probably your router. You can manually configure an IP address for your computer. If your router is 192.168.0.1, than configure something like 192.168.0.10, with the subnet mask of 255.255.255.0. The default gateway is your router.



#5 jko2300

jko2300

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:22 PM

Posted 07 August 2015 - 11:35 AM

This is a new PC. If the MAC filtering option on the router is turned on, that could prevent the new PC from receiving an IP from the DHCP server (router) as the new MAC address would not be recognized.



#6 Nikhil_CV

Nikhil_CV

    Vestibulum Bleep


  • Members
  • 1,145 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:err: Destination unreachable! bash!
  • Local time:10:52 PM

Posted 07 August 2015 - 12:48 PM

Hi deborah,
Thanks for checking. It seems there may be some issues in communicating with your modem/router's DHCP server. Try this:
Disconnect the router from network.
Use a straightened paper clip or ball point pen to press the reset button (usually in a small pit near the power input) on your modem/router (the one to which ethernet cable is connected).

After a successful reset, all lights on device will blink (press for a minimum of 10sec while power is on). Then reconnect the ethernet cable back.
Try logging into router using factor default password and username.

Also, makesure your firewall does not block traffic, rare case but just to be sure :)
Regards : CV                                                                                                    There is no ONE TOUCH key to security!
                                                                                                                                       Be alert and vigilant....!
                                                                                                                                  Always have a Backup Plan!!! Because human idiotism doesn't have a cure! Stop highlighting!
                                                     Questions are to be asked, it helps you, me and others.  Knowledge is power, only when its shared to others.            :radioactive: signature contents © cv and Someone....... :wink:

#7 JohnHenery

JohnHenery

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:22 AM

Posted 07 August 2015 - 02:27 PM

Hi deborah,
Thanks for checking. It seems there may be some issues in communicating with your modem/router's DHCP server. Try this:
Disconnect the router from network.
Use a straightened paper clip or ball point pen to press the reset button (usually in a small pit near the power input) on your modem/router (the one to which ethernet cable is connected).

After a successful reset, all lights on device will blink (press for a minimum of 10sec while power is on). Then reconnect the ethernet cable back.
Try logging into router using factor default password and username.

Also, makesure your firewall does not block traffic, rare case but just to be sure :)

From my experience, it does not hurt to reset the modem as well..

 

I usually power down the modem, disconnect the router, power on the modem, reset it. power on the router, reset it,  power down the modem, connect the router, power on the modem. 

 

 

The reason I do it this way is because most people like to configure the router the way it used to be, same SSID and Pass. And it seems like the modem gets confused by this. Sort of like how you often have to "Forget a network" on your computer or phone, before reconnecting to a network after resetting the router.



#8 m0rph

m0rph

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:06:22 PM

Posted 11 August 2015 - 12:16 PM

Hi there,

 

I have seen this kind of problem before, sometimes a simply unplug the PC from the router/switch end is enough, or shut the router or switch down for 30 seconds then power up and try again before a reset.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users