Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ping blocked after update to Windows 10


  • Please log in to reply
3 replies to this topic

#1 suti

suti

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dundas, Ontario, Canada
  • Local time:08:18 AM

Posted 01 August 2015 - 02:54 PM

I have been using a graphic ping plotter -Nullsoft Netmon- for many years. It has run on Windows from Vista to 8.1 without any problems. After 15+ years on a satellite provider, it has saved me many hours in tracking down slow internet access.  I upgraded to windows 10 yesterday.  Netmon worked for about an hour after the upgrade and then stopped while I am still getting good internet access..

 

I am using Viper AV and Vipre firewall.  The firewall rules for ping and other ICMP packets block only Public Inbound and I have never had to change this.  I have to assume that some change in Win 10 is giving me the problem.  Where would I look to solve this problem?

 

This is an area I haven't had to deal with before and I am nervous about playing with security settings.



BC AdBot (Login to Remove)

 


#2 Aura

Aura

    Bleepin' Special Ops


  • Malware Response Team
  • 19,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:18 AM

Posted 01 August 2015 - 06:51 PM

Hi suti :)

Is this the program you are talking about?

http://www.1014.org/code/nullsoft/netmon/

From what I can see, it hasn't been updated since 2000... which is 15 years ago. We cannot assume that the program will work on Windows 10 now. If you want, you can try to run it in Compatibility Mode of an older version of Windows. However if it doesn't work, maybe it's just not compatible with Windows 10. The program is 15 years old after all.

unite_blue.png
Security Administrator | Sysnative Windows Update Senior Analyst | Malware Hunter | @SecurityAura
My timezone UTC-05:00 (East. Coast). If I didn't reply to you within 48 hours, please send me a PM.


#3 suti

suti
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dundas, Ontario, Canada
  • Local time:08:18 AM

Posted 04 August 2015 - 07:42 PM

Sorry about the delay. I made the mistake of looking at the Event Viewer and am I ever sorry I did that. I'm no expert at this but I can often figure the source of an error even if I can't correct it.  This time it was a real mess with errors I have never seen before.  Bear with me while I fill in some details on just this problem.

 

Yes this is that old dinosaur. I have kept using it because it has kept working and it has worked in Windows 10 but only for a few minutes at a time. It worked after the initial install for a few minutes and again after a problem shutting down and restarting.  The .exe program runs in compatibility mode for Windows XP service pack 3.  It has several source files (not compiled) that provide C parameters and coding.  The program runs and sets up the display and all provided parameters correctly.  It just does not detect the echo from the ping. A manual ping from the CMD environment is also not returned.

 

After my shut down problem, it took 3 power OFF/ON cycles before the computer re-booted.  On the restart, netmon ran for about a minute and then stopped getting the echo.I went immediately to the Event Viewer and got these warning and errors:

 

Warning Mon, Aug, 3, 2015 12:02:08 AM DNS Client Events 1014 (1014)

Name resolution for the name skyapi.live.net timed out after none of the configured DNS servers responded.

 

It didn't record the actual bootup time, but this was very shortly after and is the first record for this boot.

 

The next entry was the first error:

 

Error Mon, Aug, 3, 2015 12:03:11 AM DistributedCOM 10016 None

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{D63B10C5-BB46-4990-A94F-E40B9D520160}
 and APPID
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

 

Between this error at 12:03:11 and 12:03:33 it generated 37 more copies of this error and none after that. The interesting here is the interval between the warning and the first error is 63 seconds which would be about the length of time I saw the program run. There is obviously something starting up that blocks the ping. I think because it does start, there should be some way of keeping it going.  If it wasn't so useful to me, I wouldn't bother.

 

My computer is an off-the-shelf Dell N5040 laptop purchased about a month before the release of Windows 8 and came with the free upgrade coupon..


Edited by suti, 04 August 2015 - 07:48 PM.


#4 suti

suti
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dundas, Ontario, Canada
  • Local time:08:18 AM

Posted 26 August 2015 - 01:44 PM

[SOLVED?]

 

The ping blockage is due to a problem with Vipre. They are working on it.  In the meantime I have switched to Windows firewall and pin is working.

 

The error message from Event Viewer turned out to be a different problem.

What made this one interesting was that neither the CLSID nor the APID could be found anywhere on my system, (registry, C: drive, component services), so I could not identify the offending process.

 

Google eventually spat out this link:

 

rhttp://answers.microsoft.com/en-us/windows/forum/windows_8-performance/event-id-10016-the-application-specific-permission/9ff8796f-c352-4da2-9322-5fdf8a11c81e

from JokeSmith.

 

The offending program is Runtime.exe. (Runtime Broker).I have a copy on my computer from previous installations dated Dec 16, 2012.

 

Registry entry: Runtime

 

in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.aac

 

also:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\FeatureComponentID holds several entries relating to Media Player

 

Solution:

 

Missing File - Runtime.exe

 

Ignore!!

 

Since Microsoft has removed the Media Center from Windows 10, I presume these registry entries are stubs left over from old code. I don't know how much processor time is involved in generating these errors but it's probably not much. It would be professional to clean this up. The Event Viewer gets cluttered enough without unnecessary errors.






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users