Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem connecting phone to PC via bluetooth


  • Please log in to reply
1 reply to this topic

#1 chick3n

chick3n

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:03 PM

Posted 30 July 2015 - 02:26 PM

Ok, so I have a Galaxy S4 (SGH-i337) and I want to connect it to my desktop (Windows 7 64 bit Ultimate) to use my computer headset to take calls.  I bought a new 4.0 dongle from amazon and it installed fine.  Detected the phone, paired, and seemed to be working.  I could play music on my phone, and hear it through my headset.  I saw an option to receive SMS messages on the computer, so I tried it.  It seemed to attempt to download my contacts/messages, but didn't work.  Tried sending myself a text-it went through even though the program never changed from "sending...".  Ok, whatever, don't need texts on my PC.  Tested calling my voicemail and everything went to hell.  The bluetooth control panel closed along with the SMS control, and the bluetooth connection button on the phone keypad deselected itself and the voicemail played through the phone like normal.  It didn't disconnect the bluetooth entirely- I could re-open the control panel and listen to music after I clicked connect.  It just craps out when I try to use the phone.
 
I tried it on my laptop (Acer, Win7, built in bluetooth), and the phone connected perfectly, downloaded my contacts instantly, and played call audio though the computer without any problem whatsoever.  The interface looked a bit prettier as well.  Only thing missing was the ability to send texts, but I don't care about that.  I linked some pics below of what the interface looks like on both computers.
 
 
 
The only difference I could find was that my desktop dongle has a Broadcom chipset (downloaded and installed newest WIDCOMM drivers from the broadcom website) while the laptop has an Atheros chipset (old driver from 2012).
 
Anyone here come across this problem before?  Any ideas for a fix?  I don't need anything fancy, I just want to link it to my computer and talk through my headset.  At this point I'll take anything, doesn't have to be bluetooth or even wireless!
 
EDIT: Looks like I found a fix, at least for now.  Managed to locate the Atheros drivers, and they seem to be working on my broadcom device!  For anyone else that comes across this and needs them: http://support.asus.com/Download.aspx?SLanguage=en&m=Bluetooth&p=3&ft=27&os=30
I used version: V8.0.1.341 Qualcomm Atheros BlueTooth driver.  Just be sure to uninstall old bluetooth stacks/drivers, reinstall your bluetooth device, and remove and re add your phone (if it is already listed under devices from a previous try).

Edited by hamluis, 30 July 2015 - 05:11 PM.
Moved from Win 7 to External Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,289 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:03 PM

Posted 30 July 2015 - 05:09 PM

Thanks for the information...happy computing :).

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users