Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Charging Problems after installing New Display Assembly on 13" MacBook Air 2013


  • Please log in to reply
1 reply to this topic

#1 Laverily

Laverily

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Texas
  • Local time:07:26 AM

Posted 27 July 2015 - 02:14 PM

Hi,

i have a 13" Macbook Air mid 2013 A1466 that started having display issues to the point where I couldn't use it
i ruled out logic board problems because everything worked when I hooked it up to an external monitor. I also unhooked the display and made then external monitor run off my MacAir like it was the main monitor and everything worked.
So, that's when I knew what part to buy to fix my notebook. I bought a new display assembly from Amazon & used ifixit.com to change the display out. After installing the new display everything was working perfectly fine & was pleased to know my laptop was back to normal UNTIL I tried to charge it & the charger stopped working & I couldn't charge my mac (I had no charging issues prior). Im worried I did something wrong in the process of installing. I opened the back of MacBook Air & I did notice the I/o board to logic board flex cable wasn't flat so i made sure it was secured properly & it worked!! I was so relieved!
But, almost a week later Im having the same problem! It was taking the charger earlier that day but I unplugged it & planned to charge it later but I waited too long & was down to 1-2% & when I plugged it in, I didn't notice right away it wasn't charging before the laptop died on me. I can't get it to charge again. I get the same problem with no green / Amber light plus this time my display will show the red battery to connect a charger symbol. Of course, I did check the same flex cable but this time it didn't fix my problem. I haven't had another charger to test out to see if its my charger but I doubt it's my charger. I do feel it has to be a problem I created when installing the new display. I did not have charger issues before.
I am thinking of going thru all the steps of uninstalling the display to see if I can fix the problem that way but I'm nervous when I'm not specialist & although I do have a little knowledge to where I did feel comfortable doing this myself to begin with, it was mainly to save money from what apple was quoting me.

Before i try tearing my MacAir apart, Im hoping to find anyone that may have some advise or suggestions to help fix my problem.

FYI: It is running the current Yosemite OSX

Thanks,
D

BC AdBot (Login to Remove)

 


#2 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:26 AM

Posted 03 August 2015 - 03:41 PM

I agree that is sounds like you may have damaged something (probably the connection on that flex cable) on the inside when you installed the new display. If so, then you can either mess with it yourself (and risk potentially making things worse) or take it into Apple or an Apple authorized dealer to have them deal with it (potentially costing more than if you have just had them replace the display, unfortunately). That is about all the advice I could give.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users