Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Two out of three USBs won't work


  • Please log in to reply
22 replies to this topic

#1 CRBlair

CRBlair

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 27 July 2015 - 10:52 AM

I have a Lenovo G700 laptop running Windows 8.1. It has three USB ports--one on the left side (where my printer is plugged in) and two on the right. My wireless mouse died last week, so yesterday I bought a replacement. When I tried to use the mouse (for which I use one of the two right-hand ports)' it wouldn't connect. I tried the other right-hand port--still no (good) luck. When I tried plugging the printer into either of these ports, the printer didn't work until it was plugged in on the left. Also, I didn't (from any port) get the standard Windows alert tones when I plugged in or un-plugged either the mouse transmitter or the printer on the machine. The ports appear to be in good physical shape, so if there is a physical problem it's inside. I'm not sure exactly what to do if it's a sotware problem--I'd rather not go through the hassle of refreshing my machine if I don't have to, but I can (as a last resort) if it's necessary.

Thanks in advance for any help or advice you can give me.


Roger Blair

crogerblair@hotmail.com


BC AdBot (Login to Remove)

 


m

#2 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 27 July 2015 - 11:03 AM

This person had a similar problem with the right hand ports. His solution was to use canned air to clean them though I don't know if this would help you or not. Are there any yellow exclamation marks in Device Manager?

 

https://forums.lenovo.com/t5/Lenovo-B-and-G-Series-Notebooks/Faulty-USB-ports-on-Lenovo-G700/td-p/1757081

 

You could try booting a live linux disk like Puppy to rule out a hardware problem but you would first need to disable SecureBoot and possibly Fast/Quick boot if enabled in UEFI. According to the specs you have 2 USB 2.0 ports and 1 USB 3.0 port. This would probably show as Blue vs Black for USB 2.0



#3 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 29 July 2015 - 01:06 PM

JohnC_21, I tried the recommended "canned air" technique, but it didn't help. Since I'm not getting the add- and remove-hardware chimes, could there possibly be a problem with my software? I can't think of any other hardware tricks.


Roger Blair

crogerblair@hotmail.com


#4 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 29 July 2015 - 01:14 PM

Have you tried booting a linux disto like Puppy linux to confirm if it's a hardware problem? I tend to think this is hardware related but I can't say for sure.



#5 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 30 July 2015 - 04:52 AM

Where can I find a free Linux distro?


Roger Blair

crogerblair@hotmail.com


#6 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 30 July 2015 - 07:21 AM

For your Windows 8 download Fatdog64 here. You will need to disable Secure Boot in UEFI.  When you attach a USB device a USB icon will appear on the desktop next to your hard drive icons. You can create a bootable USB flash drive using the below iso and Rufus or burn a CD disk. Any data on the USB would need to be backed up first.

 

Fatdog64-701.iso



#7 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 30 July 2015 - 01:08 PM

John_C21, I've downloadeHow should I proceed from here?d an .iso file to my desktop, but  my system doesn't seem to know it's there. Also, I've read that W8.1 has a problem when you try to change the boot order--you can't get to the proper screen AT ALL!


Roger Blair

crogerblair@hotmail.com


#8 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 30 July 2015 - 05:39 PM

Do you have a CD to burn the iso to? If you right click the iso file do you see an option to Burn Disk Image? 

 

You can enter UEFI by tapping F1 at boot. You would need to disable Secure Boot in order to Boot FatDog. With the disk in the computer tap F12 at boot to bring up a boot menu where you can select the optical drive to boot from. 



#9 gigawert

gigawert

    Computer Consultant


  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Jose, California
  • Local time:11:06 AM

Posted 30 July 2015 - 06:39 PM

I had the same issue with another computer where Plug and Play devices (like usb thumb drives) didn't appear. You just need to enable and start the Plug and Play service in services.msc (search it from the start menu)


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#10 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 31 July 2015 - 05:02 AM

gigawert, I checked services msc; P&P was running with "Manual" startup. I changed it to "Automatic" startup and restarted it; there was no change--sorry.


Roger Blair

crogerblair@hotmail.com


#11 gigawert

gigawert

    Computer Consultant


  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Jose, California
  • Local time:11:06 AM

Posted 31 July 2015 - 11:44 AM

gigawert, I checked services msc; P&P was running with "Manual" startup. I changed it to "Automatic" startup and restarted it; there was no change--sorry.

P&P is supposed to be in manual mode. You may need to reinstall drivers for your motherboard~possibly.


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#12 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 31 July 2015 - 12:35 PM

JohnC_21,I tried both of the recommended video converters/CD burners, and neither one would allow me to burn aniso file to a cd or a DVD. What did I no0t do that I neeeded to do?

Roger Blair

crogerblair@hotmail.com


#13 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 31 July 2015 - 01:06 PM

You do not need any converter. Download Imgburn and install. Be sure to opt out of any optional programs it offers. Then burn the iso file using this guide. Select a low speed like 4X. A CD is fine for Fatdog or if you have not CD a DVD will work



#14 CRBlair

CRBlair
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Columbia, MD USA
  • Local time:01:06 PM

Posted 02 August 2015 - 02:46 PM

JohnC_21, I downloaded and installed ImgBurn and created my disk. However, when I hit F12, the screen only shows the Boot Manager and two web links which won't boot my system. My optical drive isn't listed; how do I add it?

(BTW, it seems like I'm working in WordPad when I reply--the formatting toolbars are grayed out. This wasn't always the case; what happened, and how do I undo it?)

Roger Blair

crogerblair@hotmail.com


#15 JohnC_21

JohnC_21

  • Members
  • 21,642 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:06 PM

Posted 03 August 2015 - 07:20 AM

Sorry for the late reply.

 

You need to preform a complete shutdown before you can use F12 but you must also do a complete shutdown in order to use F1 to access the UEFI to disable SecureBoot. Go to the Security tab after using F1 to enter UEFI settings. Before doing a complete shutdown turn off Fastboot as follows.

  1. Disable the fast startup option in Control Panel -> Hardware and Sound -> Power Options -> Choose what the power buttons do.
  1. Do a full shutdown - (hold shift while selecting shutdown)
  2. Restart and enter BIOS by tapping (F1).
  3. Go to Security > SecureBoot > disable it.

After doing the above you should be able to tap F12 at boot to get a boot menu






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users