Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My USB ports don't work anymore


  • Please log in to reply
1 reply to this topic

#1 aistokes

aistokes

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:40 PM

Posted 26 July 2015 - 03:00 PM

I had my razor synapse gaming mouse plugged into one of four USB ports on my laptop and I have used it for almost 3 years with no issues. I got a notification that said "power surge at the USB port" and it told me to press "reset" or else the USB port would stop working. So I pressed reset but my mouse never reconnected. So I disconnected it and tried it in a different port and now none of the ports are working for any devices. I tried uninstalling the USB drivers and reinstalling them and it did not help. I have a Toshiba satellite, windows 7.


Edited by hamluis, 28 July 2015 - 09:27 AM.
Moved from Computer Gaming to Internal Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:08:40 PM

Posted 31 July 2015 - 01:08 PM

See HERE .

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users