Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

FM20.dll Denies Application From Running


  • Please log in to reply
No replies to this topic

#1 CorruptCoW

CorruptCoW

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Local time:03:28 PM

Posted 25 July 2015 - 09:46 AM

I have been a long time user of a fantasic software tool for Google Earth called GE Path by a clever fellow R.Sgrillo. It's an older piece, not enhanced beyond it's current version from 2012. I have tried to consult the creator for support, but I'm not even certain he provides much towards it anymore. After a recent hard drive reformat, and reinstallation of Windows 7 Home Premium 64Bit and GEPath, I have found that I am unable to use GE Path due to an error I had never experienced before. 

 

When I execute the application, I am met with this error: "Component 'FM20.dll ' or one of its dependencies not correctly registered: a file is mising or invalid."

 

I can confirm installation of Microsoft Office has left FM20.dll in my Windows/System32 directory. What might be causing this issue, and how do I resolve it?

 

The author's website states that the software requires vb6 runtimes, which I can't say for certain I have or not.  I clicked on the link he provied to download, which takes me to a Microsoft page no longer available.

 

I found and downloaded vbrun60sp6 from Microsoft (VB6.0-KB290887-X86) and attempted to install it. A small box flashed up in the top left corner briefly, and did nothing. Just kinda ended. I have my doubts anything was installed. I downloaded and attempted installation of VB60SP6-KB2708437-x86-ENU. It wouldn't install because I needed MS VB6 SP6 installed. Which obviously I don't.

 

I Googled for "Visual Basic 6.0 SP6" and was taken to Microsoft's download page for Service Pack 6 for Visual Basic 6.0. I proceeded to download a file Vs6sp6B. I proceeded to install, only to have it halted with this message ... "Visual Studio 6 SP6 setup was not completed successfully."

 

Huh? Visual Studio? I thought I was downloading Visual Basic. (same thing perhaps?)

 

Needless to say ... I am lost as to what to do to get GE Path to work on my system. It had before, I don't know why it won't now. I would be very grateful to all those that can contribute to resolving this problem.

 

I ran a dependency check (via Dependency Walker) on fm20.dll, and I admit having no clue as to the meaning of the results, I will assume anything red might be an issue. What came up flagged in red were several "Error opening file. The system cannot find the file specified." all in elation to API-MS-WIN dlls. A couple warnings: "At least one delay-load dependency module was not found." and "At least onemodule has an unresolved import due to a missing export function in a delay-load dependent module."

 

Please help?

 

Rob

 

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users