Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win 7 Weird behaviour


  • Please log in to reply
4 replies to this topic

#1 Spiritbob

Spiritbob

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:32 AM

Posted 25 July 2015 - 04:20 AM

Hello!

 

Before 3 days i reinstalled my pc because it was infected with bitcoin miners and trojans, and today when I was playing a game, a blue screen appeared about a kernel inpage eror. After the computer restarted itself, during startup, my MBAM Premium (trial) crashed and my MSE was disabled. I tried starting MBAM but it crashed after issuing a scan. I started it again but this time enabled the self-protection module and it did not crash. As for MSE - The real time protection was disabled, there was a message describing why, i don't remember it, i enabled it but it was still red, demanding me to update the program, and so i did and then it became green. I issued a scan with both programs, nothing was found so I came here.

I did not copy the crash message for MBAM, I only remember that the type of error was an Inpage error.

 

I'd like to point out that I do not have any torrent client installed or having downloaded torrent files and that I have a static Ip address.

 

I used WinDbg to read the blue screen dump i got from Windows:

 

Dump file

 

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KERNEL_DATA_INPAGE_ERROR (7a)
The requested page of kernel data could not be read in.  Typically caused by
a bad block in the paging file or disk controller error. Also see
KERNEL_STACK_INPAGE_ERROR.
If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
it means the disk subsystem has experienced a failure.
If the error status is 0xC000009A, then it means the request failed because
a filesystem failed to make forward progress.
Arguments:
Arg1: fffff6fc40018c60, lock type that was held (value 1,2,3, or PTE address)
Arg2: ffffffffc000009d, error status (normally i/o status code)
Arg3: 000000011181ebe0, current process (virtual address for lock type 3, or PTE)
Arg4: fffff8800318c000, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)

Debugging Details:
------------------


ERROR_CODE: (NTSTATUS) 0xc000009d - STATUS_DEVICE_NOT_CONNECTED

DISK_HARDWARE_ERROR: There was error with disk hardware

BUGCHECK_STR:  0x7a_c000009d

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff80002b3a032 to fffff80002ac7a40

STACK_TEXT:  
fffff880`0331d848 fffff800`02b3a032 : 00000000`0000007a fffff6fc`40018c60 ffffffff`c000009d 00000001`1181ebe0 : nt!KeBugCheckEx
fffff880`0331d850 fffff800`02aef48b : fffffa80`04f0c640 fffff880`0331d9c0 fffff800`02d07540 fffffa80`04f0c640 : nt! ?? ::FNODOBFM::`string'+0x3593a
fffff880`0331d930 fffff800`02ad5d19 : 00000000`00000000 00000000`00000001 ffffffff`ffffffff 00000000`00000008 : nt!MiIssueHardFault+0x28b
fffff880`0331da00 fffff800`02afc2c0 : 00000000`00000001 fffff880`0318c000 fffffa80`03b8f000 fffff6fc`40018c38 : nt!MmAccessFault+0x1399
fffff880`0331db60 fffff800`02afc4a4 : fffffa80`03a7ab50 fffff880`00000001 00000000`ffffff7f 00000000`00000000 : nt!MiInPageSingleKernelStack+0x134
fffff880`0331dc70 fffff800`02afc43f : fffff880`02f67f40 fffff800`02afc100 00000000`00000000 00000000`00000001 : nt!MmInPageKernelStack+0x40
fffff880`0331dcd0 fffff800`02afc184 : 00000000`00000000 00000000`00000000 00000000`00000080 fffffa80`039d5b00 : nt!KiInSwapKernelStacks+0x1f
fffff880`0331dd00 fffff800`02d61aba : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KeSwapProcessOrStack+0x84
fffff880`0331dd40 fffff800`02ab9426 : fffff880`02f63180 fffffa80`03adc040 fffff880`02f6dfc0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`0331dd80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_IP:
nt! ?? ::FNODOBFM::`string'+3593a
fffff800`02b3a032 cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+3593a

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  5507a73c

FAILURE_BUCKET_ID:  X64_0x7a_c000009d_nt!_??_::FNODOBFM::_string_+3593a

BUCKET_ID:  X64_0x7a_c000009d_nt!_??_::FNODOBFM::_string_+3593a

Followup: MachineOwner
---------
 

 

I'm also having tons of critical errors in windows event viewer, all of which share the same error: "The driver detected a controller error on \Device\RaidPort0."

The error is located in the System category.

 

I also found supposedly the mbam crash in windows event viewer:

 

MBAM Crash

 

Faulting application name: mbam.exe, version: 2.3.55.0, time stamp: 0x557a2a02
Faulting module name: Qt5Gui.dll, version: 5.4.1.0, time stamp: 0x54f17912
Exception code: 0xc0000006
Fault offset: 0x0021cd60
Faulting process id: 0x648
Faulting application start time: 0x01d0c6b03a5b22b3
Faulting application path: C:\Program Files (x86)\Malwarebytes Anti-Malware\mbam.exe
Faulting module path: C:\Program Files (x86)\Malwarebytes Anti-Malware\Qt5Gui.dll
Report Id: 869143fa-32a3-11e5-843c-001fd09b78ae

 

 

MBAM Crash #2

 

Windows cannot access the file C:\Program Files (x86)\Malwarebytes Anti-Malware\Qt5Gui.dll for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Malwarebytes Anti-Malware because of this error.

Program: Malwarebytes Anti-Malware
File: C:\Program Files (x86)\Malwarebytes Anti-Malware\Qt5Gui.dll

The error value is listed in the Additional Data section.
User Action
1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
2. If the file still cannot be accessed and
    - It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    - It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
4. If the problem persists, restore the file from a backup copy.
5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: C0000010
Disk type: 3

 

 

I hope this gives some insight about what i'm experiencing and what the problem might be.

 

Thank you!


Edited by Spiritbob, 25 July 2015 - 04:26 AM.


BC AdBot (Login to Remove)

 


m

#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:32 AM

Posted 25 July 2015 - 05:26 AM

Hello and Welcome,

 

Please follow our new area >> Blue Screen of Death (BSOD) Posting Instructions - Windows 10, 8.1, 8, 7 & Vista         

 

This forum area is devoted mainly to BSOD problems and how to solve the problems.

I can give basic advice, but please follow what the Experts want first ...

 

Thank You -



#3 Spiritbob

Spiritbob
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:32 AM

Posted 25 July 2015 - 03:50 PM

I still would like my computer to be checked, I want to be sure I'm clean from any viruses and that any vulnerabilities/exploits are fixed. The reason i re-installed my computer was because I got infected out of nowhere. I don't want the same to happen again. I've opened a seperate topic for the BSOD.


Edited by Spiritbob, 25 July 2015 - 03:50 PM.


#4 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 72,214 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:04:32 PM

Posted 31 July 2015 - 01:36 PM

Completely remove MBAM and re install

https://support.malwarebytes.org/customer/portal/articles/1835311?b_id=6438
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#5 Spiritbob

Spiritbob
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:32 AM

Posted 01 August 2015 - 08:53 AM

Done.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users