Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wifi slow on laptop, fast on phone


  • Please log in to reply
4 replies to this topic

#1 No_Skillz

No_Skillz

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:13 AM

Posted 25 July 2015 - 02:21 AM

Hello all,

 

My wifi connection is slow on my laptop, approximately 10/10 Mbps.  When connected via ethernet cable, I am getting 50/50.  However, on my phone, I get 35/35, which is acceptable.  This is with my laptop directly next to router. 

 

I have tried playing around with channel while using inSSIDer, however my tests were really anomalous.  Also cell was working fine, so I left it where I found it.  

I tried switching from 2.4hz to 5.2hz, and found out my verizon router only broadcasts in 2.4.

I've also tethered to my cell phone which is 4g, and I get approx 25/15, which approximately matches speed tests on the phone. 

 

Any help appreciated. 



BC AdBot (Login to Remove)

 


#2 technonymous

technonymous

  • Members
  • 2,482 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:13 AM

Posted 25 July 2015 - 08:51 PM

Go to network connections and click on the wifi adapter. What is the link status and signal bar strength? Right click the adapter and go to properties. From there click on configure button and advanced button. In there switch it to performance and auto speed negotiation to auto if it's set manually or set it to just G only. Some wifi cards have very basic settings in there and some have a lot more. Some of those settings can mess with the link speed. Instead of 10/10 full duplex set to 100/100 full duplex etc. Maybe turn on/off packet offload etc. I remember reading a person had the same issue as this with Windows 7 and by disabling a setting in there immediately fixed the issue. I don't recall exactly what it was it's been so long. It was a bug in Windows apparently. That doesn't surprise me one bit. lol


Edited by technonymous, 26 July 2015 - 10:00 AM.


#3 No_Skillz

No_Skillz
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:13 AM

Posted 26 July 2015 - 08:51 PM

Signal bar strength is excellent

 

Status:

IPv4 Connectivity: internet

IPv6 Connectivity: No network access

Media State: Enabled

SSID: Private:-)

Speed: 54 Mbps

 

I tried what you said about checking configure>advanced.  I have a lot of options in there.  I methodically went through each one and tried different settings, but this does not seem to have had an effect.

 

 



#4 itthirit

itthirit

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 03 November 2015 - 12:53 PM

In my case 
my labtop wifi slow down from 10m to 4m
I found solution to solve by

1.uninstall wifi driver at device manager with (no checkbox delete the driver).
2.rescan hardware your wifi driver will appear again.

that magic my wifi speed test up to 10m like lan pc.

credit. https://www.youtube.com/watch?v=_tzA6dkLk88



#5 technonymous

technonymous

  • Members
  • 2,482 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:13 AM

Posted 03 November 2015 - 01:37 PM

Sometimes you do want to choose delete driver that MSFT updates downloaded; that caused the problem in the first place. First you want to get the lan drivers from the manufacturers website of your make & model of your motherboard.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users