Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Connect To Home Group


  • Please log in to reply
13 replies to this topic

#1 Christy Mahon

Christy Mahon

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 24 July 2015 - 11:58 PM

Running Windows 7 Home Edition Premium.  When I try to join my laptop to the home group established by my main computer running Windows 7 Ultimate, I keep getting a can't connect to home group message that then directs me to network troubleshooting, which in turn tells me it can't determine a problem.  Suggestions?

 

Thanks for taking the time to check-in on my plea.



BC AdBot (Login to Remove)

 


m

#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:52 PM

Posted 26 July 2015 - 10:23 AM

Try running through these troubleshooting tips:

 

http://windows.microsoft.com/en-US/windows7/Why-can-t-I-join-a-homegroup



#3 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 PM

Posted 26 July 2015 - 11:24 AM

Both machines on same workgroup? Windows key+pause break. Both machines must match and be on the same workgroup name. If you joined or created a workgroup on each pc you should leave them. Under Control Panel\Network and Internet\HomeGroup Do that on both systems. Also be sure to set advanced settings...networks discovery on, network sharing are on, Public sharing on/off, 128 encryption on, Login on/off. On the Windows 7 home machine go to start and type services.msc (enter) & look for Computer Browser and stop the service and disable it. On the Windows Ultimate machine do the same, but be sure it is enabled, set to automatic and started. Reboot both machines. You don't have to create a homegroup/workgroup. It is good to create one though so you generate a key. Without the key no one can join the workgroup. Even if workgroups match. It's a goofy system, but it's supposed to work by giving that key to the other pc and they can join in theory anyways. Not sure if this protects the system if on unknown public network or not. More help here at Microsoft http://windows.microsoft.com/en-us/windows7/why-can-t-i-join-a-homegroup It's funny they had to make a Fix it to fix their flawed files sharing scheme. :crazy:

 

Edit: sflatechguy beat me to the link lol. Oh well hope this all works for ya.


Edited by technonymous, 26 July 2015 - 11:25 AM.


#4 Christy Mahon

Christy Mahon
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 26 July 2015 - 01:48 PM

Try running through these troubleshooting tips:

 

http://windows.microsoft.com/en-US/windows7/Why-can-t-I-join-a-homegroup

Sflatechguy,

 

Thanks for the lead.  The link you gave didn't seem to provide a solution, but there I found another link to "Home Group Step-By-Step".  I try that.



#5 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:52 PM

Posted 26 July 2015 - 02:05 PM

Keep us posted.



#6 Christy Mahon

Christy Mahon
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 26 July 2015 - 02:20 PM

Both machines on same workgroup? Windows key+pause break. Both machines must match and be on the same workgroup name. If you joined or created a workgroup on each pc you should leave them. Under Control Panel\Network and Internet\HomeGroup Do that on both systems. Also be sure to set advanced settings...networks discovery on, network sharing are on, Public sharing on/off, 128 encryption on, Login on/off. On the Windows 7 home machine go to start and type services.msc (enter) & look for Computer Browser and stop the service and disable it. On the Windows Ultimate machine do the same, but be sure it is enabled, set to automatic and started. Reboot both machines. You don't have to create a homegroup/workgroup. It is good to create one though so you generate a key. Without the key no one can join the workgroup. Even if workgroups match. It's a goofy system, but it's supposed to work by giving that key to the other pc and they can join in theory anyways. Not sure if this protects the system if on unknown public network or not. More help here at Microsoft http://windows.microsoft.com/en-us/windows7/why-can-t-i-join-a-homegroup It's funny they had to make a Fix it to fix their flawed files sharing scheme. :crazy:

 

Edit: sflatechguy beat me to the link lol. Oh well hope this all works for ya.

Technonymous,

 

Thanks for your response.  Both systems are on the same WorkGroup which is unimaginatively named WorkGroup. In "Advanced Settings" I've setall of the settings identically.  I went to Services and did what you said.  Unfortunately, none of that has enabled my laptop to join the HomeGroup.  I didn't have both systems "leave" the network because I don't understand how they could possibly connect to each other if they're not in the network.  Anyway, like I told Sflatechguy,  I'm going to try the HomeGroup Step-By-Step to see if I can learn anything helpful there.    



#7 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 PM

Posted 26 July 2015 - 11:31 PM

Well that's just it when you create a homegroup you also create a security key. Without giving that key to the other pc to join your homegroup they cannot cannot join even if "Workgroup" are the same. So there is some kind of a secuirty policy check. By leaving the network group windows falls back on just having the workgroups match and you manage the settings manually for access. Inside adavanced setting network discovery has to be on. You should see computers at start button and network. If you still don't see the other computers then there must be some service or protocol service not installed. You can reach services by going to start type services.msc Be sure to start them and set to automatically start with windows. There are also some network card protocols that need to be installed as well. You right click the network adapter and go to properties and use the install button.

 

 

[List of services]

 

Com+ Event System

Computer Browser

DHCP client

DNS client

Network Connections

Network Location Awareness

Remote Procedure Call

Server

TCP/IP Netbios helper

Wireless Zero Configuration

Wlan AutoConfig

Workstation

 

[List of Default Protocols, Services, Client for NIC]

 

Client for Microsoft Networks (client)

Applian network Driver (service)

Virtual PC Network Filter Driver (service)

RRNetCap Driver (service)

QOs Packet Scheduler (service)

File and Printer Sharing for Microsoft Networks (service)

Internet protocol Version (TCP/IPv6)  (protocol)

Internet Protocol Version 4 (TCP/IPv4)  (protocol)

Link-Layer Topology Discovery Mapper I/O Driver  (protocol)

Link-Layer Topology Discovery Responder (protocol)

 

[Other protocols that may be installed on Windows 8 and above]

 

Microsoft LLDP protocol Driver (support for Microsoft Data Center Networking)

Microsoft Network Adapter Multiplexor (Adapter for load balancing and fail-over)

 

Note: These are mainly for very large networking infrastructured data centers that have networking server failover and server load balancing. Generally if you don't know what those are then you don't need them enabled.


Edited by technonymous, 26 July 2015 - 11:32 PM.


#8 Christy Mahon

Christy Mahon
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 27 July 2015 - 02:33 PM

 

... when you create a homegroup you also create a security key. Without giving that key to the other pc to join your homegroup they cannot cannot join even if "Workgroup" are the same.

When I initially set up the HomeGroup on my main system, I created a security key / password. However, when I try to join my laptop to the HomeGroup, I of course get prompted to enter the “HomeGroup Password”. So I enter that password and click on Next. Unfortunately, I then get a message that says: “Windows cannot set up a homegroup on this computer.”

By the way, just for backgroud, the laptop I’m trying to join to the HomeGroup had previously been functioning as part of the HomeGroup. That was a while ago though and I’ve recently re-formatted and re-installed Windows 7 Home Edition. Since the re-install is when I developed this inability to join.

By leaving the network group windows falls back on just having the workgroups match and you manage the settings manually for access.

OK, I now understand there’s a reason for your suggesting “leaving” the workgroup. Not sure though exactly what “leaving” is or how to accomplish that. Sorry, I’m confused about that term.

Inside adavanced setting network discovery has to be on.

“Network Discovery” is showing, i.e. selected, on both systems.

You should see computers at start button and network.

I see no computers listed at anything associated with the “Start Button” on either the main or laptop. At the “Network and Sharing Center” > “View your basic network informaion and set-up connections” display, the main system has “Joined” showing at “HomeGroup”. At the same display on the laptop “HomeGroup” shows “Available to join”.

In Windows Explorer (file manager) at HomeGroup the main system, as expected, reports, “There are no other people in the homegroup”. At the same display on the laptop it reports, “Windows detected a homegroup on your network”. Also, the main system used to show itself under Homegroup, but doesn’t now.

If you still don't see the other computers then there must be some service or protocol service not installed. You can reach services by going to start type services.msc. Be sure to start them and set to automatically start with windows.

I looked at all of the services you listed on both the main and laptop systems. All were set to “Start” and “Automatic” except for “Network Connections” which was “Start” - “Manual” on both systems, so I made it “Automatic” on both. Curiously, “Wireless Zero Configuration” is not present in the list on either system and I don’t know how I’d get it there?

There are also some network card protocols that need to be installed as well. You right click the network adapter and go to properties and use the install button.

Confused about this. Device Manager > Network Adapters shows two listings, one for an Ethernet Controller and one for a Network Adapter. Going to properties for the Network Adapter does not produce an “install button” nor anything about services. Consequently, I’m unable to check the list of network card protocols you suggested. How do I get to that list?

Two last points. I still can’t join the HomeGroup with my laptop. On the laptop at “Network and Sharing Center” > “Change adapter settings” I show my Wireless Network Connection and a “Local Area Connection” (LAN). The LAN is red x’d and says, “Network Cable Unplugged”. The laptop has never had a cable connection that I know of.

Again, Thanks for your help.  Christy



#9 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 PM

Posted 28 July 2015 - 04:54 AM

1. The WLAN services in services.msc that you speak of are enabled and set to auto IF you have a wireless network card. On a laptop these are probably already set, but it's good to check anyways.

 

 

2. For your Homegroup question, Go to start and type run (hit enter). Enter in run box: control.exe /name Microsoft.NetworkandSharingCenter Choose Homegroup and Sharing Options. From there you can create a homegroup clicking on the button. At the top next to the swirly blue icon. It will say, "There is currently No homegroup network" If you neither joned a network homegroup or created one yourself. If you see this then that is good. If you are joined or created one you will see an option to leave the network homegroup. You want be sure both systems say "There is currently No homegroup network" for troubleshooting purposes. You should be able to see both machines on the network and share files regardless if you created a network or joined. As long as Homegroup reads..WORKGROUP under WIN+Pause. if not this much be changed. If you network to XP machines from Windows machines it's best to use WORKGROUP. I suggest rebooting both systems after any of these changes.. Also, both system should be on the same DHCP ip range that the router assigned them. By reading the status of the network card you can gather this information from both computers for the Ipv4. Below I explain how to do that.

 

 

3. In the same Network and Sharing Center window click on Change adapter settings. From there click on the network adapter you are using to get out to the internet. From here you can gather a lot of detailed information. You can see your link speed. 10/100Mbps , 1Gbps etc. Clicking on details button you see more information. Pay close attention to the IPV4 Address and IPV4 Subnetmask. The subnetmask on both machines need to be identical 255.255.255.0 Your routers ip is the IPV4 gateway address. As an example it might be 192.168.1.1 Your ipv4 address might be 192.168.1.2, Other machine 192.168.1.3 etc. The router assigns these addreses automatically using DCHP. However, if you using static IP's they must still match 192.168.1.X The "X" Can be any number from .2 to .254, .255 is reserved for broadcast. If your pc's are 192.168.1.X and 192.168.2.X they will not see each other at all. Because the third octet of numbers puts them on different sub network. So they both need to be in the same network IP range. You need to fix this if they are not. Also, be sure in details that Netbios over tpc/ip enabled is set to Yes. Moving on...

 

4. Close out the details window. Click on the properties button. From here is where you can install new service, clients, protocols. Below I listed what you should see. For wifi it will be something similar. If you see more then that's fine too. If they are not installed you need to install them. When you install you have a choice to choose a service, client, protocol. I labeled them. If you still cannot get this to work it's possible that Microsoft Installed a junky NIC driver on one or both machines. First I would go to the computers vendor and download the driver according to motherboard make/model or laptop make/model. Before you do anymore changes I suggest creating a restore point. Go to start and type in: Create a restore point and run that. If something goes wrong you can roll the computer back to it's original state. From devmgmt.msc you can try going to network drivers and to nic's If there is a option to rollback you can try that. Sometimes uninstall/reinstall of the drivers works. Reason being, it helps blow away corrupt registry problems that just can't be fixed otherwise. Sometimes Microsoft will install a driver that is just garbage. Oh and by the way laptops Network cable unpluged is the wired nic card in the back of the laptop. No wire should be plugged in. That will sometimes automatically override the Wifi network card. One gets enabled and other gets disabled. You want the wired nic card to be disabled if it isn't already. Right click on it and choose disable. It should be grayed out. I do that just to make sure there is no conflicts even though there might be a red X.

 

Client for Microsoft Networks (client)

Applian network Driver (service)

Virtual PC Network Filter Driver (service)

RRNetCap Driver (service)

QOs Packet Scheduler (service)

File and Printer Sharing for Microsoft Networks (service)

Internet protocol Version 6(TCP/IPv6)  (protocol)

Internet Protocol Version 4 (TCP/IPv4)  (protocol)

Link-Layer Topology Discovery Mapper I/O Driver  (protocol)

Link-Layer Topology Discovery Responder (protocol)


Edited by technonymous, 28 July 2015 - 04:54 AM.


#10 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 28 July 2015 - 10:45 AM

make sure the Windows 7 Ultimate's firewall /antimalware/antivirus software is configured to allow access by host name or ip address of the Windows 7 Home Edition and visa versa.



#11 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 PM

Posted 28 July 2015 - 06:55 PM

Yes, temporary disabling the firewall helps and if things work suddenly then it's a firewall rule. However, most good firewall suites these days are good at automatically setting file sharing rules for port 137,138,139, 445 etc. Some are even more robust and create two rules of each for local and one rule for each for blocking inbound Web server and FTP traffic. This is good, but in todays age the isp blocks those ports. It's also blocked by the Router NAT as well. Ironically we're now getting into IPV6 with no NAT. lol



#12 Christy Mahon

Christy Mahon
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 28 July 2015 - 09:35 PM

 

Technonymous,

 

Well I prepared a response with lots of snapshots so you could see exactly what I am when following your suggestions, but I can't figure out how to put them into a response here.  Can you tell me how to get jpg's into a response like this?  They didn't copy in with my text.



#13 Christy Mahon

Christy Mahon
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:04:52 PM

Posted 29 July 2015 - 12:46 PM

 

How about this.  I reversed the process, i.e. set up a HomeGroup on what was supposed to be my satellite (W7 Home Premium) laptop and then tried to join that with what was supposed to be my main (W7 Ultimate) system and it worked.  What does that tell you?  Although it's opposite of what I set out to do, there's now a functioning HomeGroup.  Christy



#14 technonymous

technonymous

  • Members
  • 2,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:52 PM

Posted 29 July 2015 - 09:30 PM

I tend to keep the desktops the ones that create the homegroup. Since laptops are mobile it makes more sense to leave or join existing networks and change it if you're on a unknown public network such as a hotel. Glad you got some of it working but in reverse. That tells me that somethigs not working right on the W7 Ultimate. It can still be a simple setting, services, firewall, network card drivers and protocols. It could be a corrupt registry. Now that you joined on the laptop it could of resolved the issue on the W7 ultimate. Maybe leave network on both again and retry the other way. Do they see each other under start button & network? This has to to do with network discovery and those services.msc and Netbios helper. Netbios over tcp. Try ruinning the fix again or run network troubleshooter in windows. http://windows.microsoft.com/en-us/windows7/why-can-t-i-join-a-homegroup






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users