Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My computer won't use my Nvidia graphics card


  • Please log in to reply
4 replies to this topic

#1 NoDakSmack

NoDakSmack

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:04:23 AM

Posted 23 July 2015 - 02:07 AM

Ok, I've been fussing with this all day, doing research, trouble shooting, restarting over and over, and I'm not sure what to try next. I'm NOT a very tech savvy person, so be clear, please.

 

I have an Asus laptop with an integrated Intel Graphics HD 4600 and a Nvidia Geforce GT 740m running Windows 8.1. These are cards that came with the computer when I bought it.

 

I've had the computer for a year, but I've only just now noticed that the computer is not switching to the Nvidia card while playing games. I noticed this specifically, and figured out that this was happening, while trying to play modded Skyrim, when a mod (ENBoost) showed that it was using the Intel card.

 

Here's a list of the things I've tried

  • In the Nvidia Control Center, it was set to automatically switch between cards. This function obviously isn't working. I set it to use the Nvidia card, and applied. This was the only application that seemed to recognize the Nvidia working, but it still wasn't. DirectX Diagnostic Tool shows that it's still using the Intel card. I also tried to set the card to run for Skyrim specifically.
  • In the settings of Skyrim, it only gives me the option to use the Intel card, and doesn't bring up the Nvidia
  • If I disable the Intel card, and leave the Nvidia card enabled, it switches to the Microsoft Basic Display Adapter. I tried switching that off, but it wouldn't let me. At this point, I tried to open the Nvidia Control Panel, and it said there was no Nvidia connected. It seems the Intel card has to be enabled for it to recognize the Nvidia is there.
  • I checked to see if the drivers were up to date. It said they were, but I reinstalled them anyway.
  • I unistalled and reinstalled BOTH cards at separate time

I'm starting to think that maybe it's a hardware issue, but I'm very reluctant to send it in. I had an unpleasant 5-week long RMA with ASUS at the beginning of the summer where they ended up replacing my hard drive, processor, monitor, and other things (some of which weren't broken when I sent it in) and I'd rather not send it back.



BC AdBot (Login to Remove)

 


#2 YeahBleeping

YeahBleeping

  • Members
  • 1,258 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:23 AM

Posted 23 July 2015 - 07:39 AM

I found the information below while searching for your problem:

 

Also keep in mind that most laptops are set to use the onboard video if it is not plugged into the wall for power

 

 

1. Right Click on Desktop
2. Select nVidia Control Panel
3. In left panel select "Manage 3D Settings"
4. In right panel select Globalicon1.png Tab
5. Under "Preferred Graphicsicon1.png Processor" select "Auto-Select" and hit APPLY button

Now try again and see if it properly selects correct GPU. If not

6. Repeat steps 1 thru 3 above
7. In right panel select "Program Settings" tab
8. Under section 1., check the box for "only programs on this computericon1.png"
9. then hit the "Add" button and find the program that you want to run on nVidia card
10 Go down to section 2. and select nVidia processor
  •  


#3 NoDakSmack

NoDakSmack
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:04:23 AM

Posted 23 July 2015 - 01:25 PM

 

I found the information below while searching for your problem:

 

Also keep in mind that most laptops are set to use the onboard video if it is not plugged into the wall for power

 

 

1. Right Click on Desktop
2. Select nVidia Control Panel
3. In left panel select "Manage 3D Settings"
4. In right panel select Globalicon1.png Tab
5. Under "Preferred Graphicsicon1.png Processor" select "Auto-Select" and hit APPLY button

Now try again and see if it properly selects correct GPU. If not

6. Repeat steps 1 thru 3 above
7. In right panel select "Program Settings" tab
8. Under section 1., check the box for "only programs on this computericon1.png"
9. then hit the "Add" button and find the program that you want to run on nVidia card
10 Go down to section 2. and select nVidia processor
  •  

 

Thank you, but as I said in the original post, this isn't working. The Nvidia Control Panel allows me to make those changes, but it's still not actually using the card, even when I set it to only use that card.

 

HOWEVER I have noticed a significant performance boost when the computer is plugged in, especially during games, so I always have it plugged in while playing. Is it possible that it's using the card, but not displaying it as being used? Diagnostics and the game itself show the Intel is being used, but it does plummet performance if I unplug it. Does anything else change when it is plugged in?

 

I'm going to do some ingame tests with the nvidia completely disabled, forcing it to use the Intel, and then a normal trial, and see what is happening


Edited by NoDakSmack, 23 July 2015 - 01:36 PM.


#4 NoDakSmack

NoDakSmack
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:04:23 AM

Posted 23 July 2015 - 02:09 PM

Ok guys, I think I figured it out. I'm not a computer wiz, so correct me if something I say doesn't sound right.

 

The computer seems to be using the Nvidia card. Nothing gives any indication of this other than performance. The Diagnostics tools and Skyrim startup both say I'm using the Intel card, but I think that's because it's reading which card is being used for windows, not the skyrim app.

 

With HD graphics set to high and all render distances all the way up, with the Nvidia card disabled, I was getting 15-17 fps. With the Nvidia card enabled it jumped to 35-45 fps. If I turn off the intel card and try to force it to use the Nvidia card, it would only use the Microsoft Basic Display Adaptor, and I got a staggering 0 fps, so it seems the Intel has to be enabled for the Nvidia to work.

 

I should've done tests in the first place :P Thank you YeahBleeping, your little hint helped me figure it out.


Edited by NoDakSmack, 23 July 2015 - 02:31 PM.


#5 margate23

margate23

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:23 PM

Posted 29 June 2016 - 03:54 AM

Hey! Im also having the same problem as you are NoDakSmack, and I also have an Asus Laptop having Nvidia Geforce GT 740M and I would like to know how you were able to fix this issue in your laptop. Would really appreciate the help! :D






3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users