Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sapphire HD7750 Graphics Problem


  • Please log in to reply
No replies to this topic

#1 cdub74

cdub74

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:10:37 AM

Posted 20 July 2015 - 12:13 PM

A customer has given me his machine to have a look at, the machine has developed a problem where by as soon as you power it on the graphics are corrupt (picture attached) the BIOS screen is unreadable.

 

Thinking it was the PCI Express graphics card (HD7750 1GB GDDR5) I removed it and used the onboard card it booted fine, I put the PCI Express graphics card in another computer and it booted fine (no corruption in the graphics), I then tried another graphics card (a HD3470 256mb GDDR3) in the machine and it all booted fine, I then thought perhaps as the computer booted ok with a more basic graphics card then maybe it was the power supply at fault so I tried 2 different power supplies in the machine and the problem still occurred, I have also tried resetting the BIOS and tried different monitors and vga cables and a different DVI to VGA Connector, cleaned the machine of dust, but nothing has worked.

 

The problem is at BIOS level so I know that the Windows drivers are not at fault here.

 

The computer is a Zoostorm with a Asus F1A55-M LE, 2.10GHZ AMD A6-3500 APU with Radeon HD Graphics, 8gb Ram, 750gb WDC WD7500AARX-00N0YB0 Hard Drive, Sapphire HD7750 1GB DDR5 PCI Express Graphics Card, 300w PSU (have also tried a 400w and 480w PSU)

 

I am completely confused to what could be at fault here as the graphics card works ok in another machine and another graphics card works fine in this machine. Has anyone got any ideas what the problem could be.

 

Thanks in advance


Edited by cdub74, 20 July 2015 - 12:14 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users