Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

cannot update libc6 to 2.17...


  • Please log in to reply
4 replies to this topic

#1 TOMIS13LACK

TOMIS13LACK

  • Members
  • 213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:12 PM

Posted 12 July 2015 - 08:22 PM

Using Kali Linux and I am trying to get libc6 2.17 on my pc. I have been following the steps from this. I have done it on the same pc before my os had a fatal error due to me editing core files for reasons you are not required to know, so I had just reinstalled it. Now I have it installed it and It will not let me update my libc6. Whenever I try to do 

apt-get update

it gives me a lot of weird errors like

W: Ignoring Provides line with DepCompare0p for package php-psr-log-implementation
W: Ignoring Provides line with DepCompare0p for package php-psr-http-message-implementation
W: Ignoring Provides line with DepCompare0p for package php-math-biginteger
W: Ignoring Provides line with DepCompare0p for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompare0p for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompare0p for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompare0p for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompare0p for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompare0p for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompare0p for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompare0p for package python3-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems

## noticed the last couple of 8 lines (discluding the first one) were repeated
##also I added these tags in, were not part of the code

And I have tried apt-get upgrade, apt-get update --fix-missing and others.

 

 

Whenever I try doing the "apt-get -t sid install libc6-amd64 libc6-dev" it also gives me strange errors including:

root@kali:~# apt-get -t sid install libc6-amd64 libc6-dev
Reading package list... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6-amd64:i386 : depends libc6:i386 (= 2.19-19) but it is not going to be installed
 libc6-dev : Depends: libc6 (= 2.19-19) but 2.13-38+deb7u8 is to be installed
             Depends: libc-dev-bin (= 2.19-19)
 steam-launcher: Depends: curl
                 Depends: libc6 (>= 2.15) but 2.13-38+deb7u8 is to be installed
                 Recommends: jockey-common but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@kali~# 

I am running a 64 bit so... why am I getting the i386 thing(isn't that 32 bit?)

 

Also I have tried installing them separately with either obvious or similar errors.

 

I have followed every step correctly so please do not bring that up as I have tried over and over.


ooh, i have a signature


BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:12 PM

Posted 13 July 2015 - 05:56 AM

And I have tried apt-get upgrade, apt-get update --fix-missing and others.


Looks like something is wrong with your package management. Did you successfully update the system after installing it? What other apt-get commands have you used since installing the system?

history | grep apt-get

will list your history of apt-get commands
 

Whenever I try doing the "apt-get -t sid install libc6-amd64 libc6-dev" it also gives me strange errors including:


This output shows that you did not follow all the steps correctly, but I won't bring that up if you don't want me to. :whistle:

 

I'll also take this opportunity to mention that when using the Debian installer (which is what Kali has), leaving the root password box blank during installation makes the installer install sudo and prompts you to set up a normal user account, as happens automatically on Mint and Ubuntu etc. Of course this can all be done manually after installation, but it's not immediately obvious to novice users who then end up running as root all the time, which undermines basic Linux security protocols.



#3 TOMIS13LACK

TOMIS13LACK
  • Topic Starter

  • Members
  • 213 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:12 PM

Posted 13 July 2015 - 06:09 PM

turns out i did NOT do it correctly XD. I have done every step that was necessary except /etc/init.b/gmd3 stop or watever.

 

Also after installation i have run these apt's

   3  apt-get upgrade
   4  apt-get upgrade
   5  apt-get update
   6  apt-get install flashplugin-nonfree
   7  apt-get 
   8  apt-get dist-upgrade
   9  apt-get check


oops forgot the first 2, apt-get update and apt-get install libc6


ooh, i have a signature


#4 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:12 PM

Posted 14 July 2015 - 04:34 AM

turns out i did NOT do it correctly XD. I have done every step that was necessary except /etc/init.b/gmd3 stop or watever


Have you found the correct command for Kali, and now you know what step you missed have you tried the install again?
 

oops forgot the first 2, apt-get update and apt-get install libc6


There seems to be some commands missing from the history that you have already mentioned. For example you said:
 

And I have tried apt-get upgrade, apt-get update --fix-missing and others.


Please explain.

#5 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:12 PM

Posted 14 July 2015 - 03:52 PM

It just so happens that I had similar error messages beginning with "W: Ignoring Provides line with DepCompare0p for package" when I was updating a live session of Tails OS earlier.

I had a quick look on the internet regarding the cause but didn't find anything conclusive, but the error messages don't seem to be particularly important because the system update completed before the error messages begin.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users