Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

permissions


  • Please log in to reply
2 replies to this topic

#1 godzilla1347

godzilla1347

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:12:31 PM

Posted 04 July 2015 - 12:18 PM

Very strange! My brother-in-law was the administrator for this Dell XPM 410 desktop. The computer was not on a network but was his home computer. He gave me the administrator log in data and I log in as him.

 

Recently, I had started an Amazon business and was using a program called Fotofuze to remove the white space on photos. The program worked great and sent a zip file of the fused picture to the download file resident on the computer. When I went to the jpeg and tried to open it, I got an error message that I don't have the permissions to open it. I had a fit? Whose permission I need if I am the de facto administrator using the administrator log in? I was able to open the picture somehow with Paint and send it to Amazon but I should have permissin to access files as the administrator.  What am I missing?

 

I also can't find a way to save pictures if they open as a simple jpeg as I see no save option.



BC AdBot (Login to Remove)

 


#2 adamforum

adamforum

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:10:31 AM

Posted 04 July 2015 - 12:55 PM

I agree that an Administrator should be able to do anything...but Windows permissions can be wierd.  For example, if you have a file (say test.txt) and you alter the permissions on the file (right click, properties, security) and remove yourself and the group you belong to (e.g. Administrators) from having rights.... now when you try to open the file you will be blocked because you don't have rights...even though you are an Administrator.  However, since you ARE an Administrator, you can go back into the security configuration and grant yourself (or whoever/whatever groups) permissions to the file and then...voila you are able to open the file again.

 

If I had to guess, I would bet that the folder you downloaded your photos to is configured so that permissions are being inherited in a non-standard way (e.g. a configuration that does not grant Administator permission)  Another explanation could be if the photo software application was installed by a different user (to be available only to that user vs. to all users on the system).  Without seeing the exact error message and context it is difficult to say for certain.

Good luck,

AF


Edited by adamforum, 04 July 2015 - 01:05 PM.


#3 brainout

brainout

  • Members
  • 1,190 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Houston
  • Local time:10:31 AM

Posted 04 July 2015 - 02:23 PM

Just decided to pop in, and noticed your post.

 

Here's how I got permissions to stop in Win8, but the answer should be good in Vista, as well.  Search on 'shut' and do what it says:  http://superuser.com/questions/464758/how-do-i-disable-administrator-prompt-in-windows-8 .  Vista's restart will probably be different, but the point is to restart in Safe Mode.  Then after signin, Run command exe in dos window, and then typing "net user Administrator /active:yes" should still work.  You might have to reboot for it to take effect.

 

Works like a charm, in Win8.  Wish Linux had the same thing.  I put UAC on the middle slider after that, and now I'm never asked for my password, just reminded, so click yes each time.  You can't view a jpg file unless you put the UAC in the middle.

 

I didn't test it on my Vista machine, though.  Hope it works.


(Away, Notifications Off) AUDIT PREMISES, my guidon.  -- brainout or brainouty on vimeo or Youtube, domain brainout.net





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users