Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Issues with same name model Kingston DDR2 modules.


  • Please log in to reply
2 replies to this topic

#1 nicologic

nicologic

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:53 PM

Posted 25 June 2015 - 03:50 PM

Hello everyone.

I recently decided to buy a couple of DDR2 RAM modules to improve a little bit my 8 year-old computer. I had previously read all I thought was necessary to do things right. My motherboard (Gigabyte GA-945P-S3) runs a Core 2 Duo E6600 2.40Hz and supports up to 4GB DDR2 667MHz, in 4 DIMM Slots with a dual channel configuration. I've always had 2GB (2x1GB modules), so I decided to add a couple more to top the 4GB (though I knew my 32 bit WinXP would only detect 3 plus something else).

As I read many threads on different sites explaining the bunch of problems that can occur when mixing different RAM's, I decided to buy just the same model I've been using since the very beginning of this PC's life (Kingston KVR667D2N5/1G) to avoid any kind of compatibility issues. Despite sharing the exact model number, the new ones definitely look different. They have a much lower profile (half the height, more or less) and, more significant, just eight chips in one single side, whereas the old ones have eight chips in both sides. I thought that it was due to enhancements in the manufacturing process for the 8 year age difference between them but the performance specs should remain the same.

I first mounted them in the 2 remaining DIMM slots in my motherboard, so the configuration was: OLDS (DIMM 1&3) - NEW (DIMM 2&4). The PC started with no problem at all and it displayed a new total 3.25GB from the System window in XP. But after a few hours happily using my "new" PC it crashed, which is very rare. On the next 2 runs it ended crashing aswell. Then, I ran CPU-Z and it displayed 4GB of RAM, but at just 335MHz instead of 667MHz. Looking up for more info I read that RAM speed could be changed from the BIOS, a whole new world to me. So I picked the motherboard's manual and began reading how to do it (yes, people like me have to study first...) and checked it to make changes, but surprisingly it was already set to 667MHz. Then I decided to run a couple of free benchmarks (Novabench and PerformanceTest) to see anything. Novabench just gives a parameter regarding RAM, and with all 4 modules mounted it got a result of just over 2000MB/s. Then I ran the same test without the 2 new modules and it scored a new max over 2900MB/s. From this point, I tried different configurations (combinig them, changing the slots, etc) and what I see is that both sets (old and new) have the exact same performance (2900MB/s), but when they're put together I get poorer results (2000MB/s) whatever the combination is (2 old + 2 new; 1 old + 1 new; 2 old + 1 new;...). Finally, the PC couldn't even boot with the four modules in it, just the same configuration gave me no problems until it crashed for the first time. Another weird thing is that the other benchmark (PerformanceTest) detects 4 GB too, but then, in the details, it displays 2 modules of 1024MB (old ones) and 2 of 512MB (new ones), and all of them at ridiculous 66MHz; yes, without the final 7.

Specs like latency and others cannot be changed from my BIOS, just the speed and voltage. So I don't know what else to try. Any advice will be muchly appreciatedsmile.gif .

 

Thaks! (sorry for the long text...)



BC AdBot (Login to Remove)

 


#2 nicologic

nicologic
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:53 PM

Posted 26 June 2015 - 12:58 PM

Hi, it seems that I've solved the problem.

 

I ran memtest86 to check the hardware. After several tests with different RAM configurations I got zero errors, so everything seemed to be OK. After a bit of reading I checked my BIOS and saw that the FSB processor value was at the minimum (100), so I decided to set it to the highest possible (266), and now everything appears to work properly.

 

Cheers!



#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,391 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:11:53 AM

Posted 26 June 2015 - 02:10 PM

Glad you resolved it, thanks for letting us know...happy computing :).

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users