Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox and Chrome - Spinning Circles / Slow to Load


  • Please log in to reply
1 reply to this topic

#1 Hal06

Hal06

  • Members
  • 923 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:01:40 AM

Posted 06 June 2015 - 06:27 AM

I'm having problems with both Firefox and Chrome. Both are often, but not always, very slow to load websites. With Firefox I get a spinning green circle. With Chrome I get a spinning circle, too. I've no clue what the problem with Chrome is. It can hang and take so long to load a site that I have to close and start over. With Firefox it can be bad but not as bad as Chrome can be.

 

I don't know but suspect that, with Firefox, there's a lot of media content that causes it to load slowly. E.g., with newssites there are often multiple videos that play automatically and ads.

 

Any advice on how to address this issue?

 

Thank you.



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,233 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:40 AM

Posted 07 June 2015 - 10:51 AM

Do you have the same problem with Internet Explorer? It sounds like a problem with your network. How are you connecting to the Internet?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users